LINUX.ORG.RU

А синаптик разве не умеет предлагать варианты?

Попробуй aptitude -s install libqt4-dev, увидишь, с чем оно конфликтует.

Gattai ()
Ответ на: комментарий от kostik87

Угу, были - нарвался из-за этого на проблемы с qbittorrent. Щас отключены. Есть только репозитории конкретных программ. Я

Qwentor ★★★★★ ()
Ответ на: комментарий от Gattai
ЗАМЕЧАНИЕ: Производить только имитация работы!
      Для реальной работы apt-get требуются права суперпользователя.
      Учтите, что блокировка не используется,
      поэтому нет полного соответствия с текущей реальной ситуацией!
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Следующие пакеты устанавливались автоматически и больше не требуются:
  mate-applets-common ttf-umefont mate-screensaver-common eom-common
  gir1.2-mate-panel python-gtksourceview2 gtk2-engines-pixbuf
  libtxc-dxtn-s2tc0 mate-media mate-utils-common libcapi20-3
  mate-system-monitor mate-power-manager unixodbc mate-media-gstreamer
  mate-power-manager-common libgtksourceview2.0-common winetricks eom
  libgtksourceview2.0-0 wine-gecko1.4 pluma mate-applets mate-calc
  mate-media-common mate-utils libjpeg62 libmpg123-0 libffmpegthumbnailer4
  pluma-common ttf-unfonts-core libodbc1 fonts-droid ffmpegthumbnailer
  linux-headers-3.2.0-57-generic gnome-exe-thumbnailer mate-themes ttf-droid
Для их удаления используйте «apt-get autoremove».
Будут установлены следующие дополнительные пакеты:
  libqt4-dbus libqt4-declarative libqt4-designer libqt4-help libqt4-network
  libqt4-opengl libqt4-qt3support libqt4-script libqt4-scripttools libqt4-sql
  libqt4-sql-sqlite libqt4-svg libqt4-test libqt4-xml libqt4-xmlpatterns
  libqtcore4 libqtgui4 libqtwebkit-dev qdbus qt4-linguist-tools qt4-qmake
Предлагаемые пакеты:
  libqt4-declarative-folderlistmodel libqt4-declarative-gestures
  libqt4-declarative-particles libqt4-declarative-shaders qt4-qmlviewer
  libmysqlclient-dev libpq-dev libsqlite3-dev qt4-dev-tools qt4-doc
  unixodbc-dev qt4-qtconfig
Рекомендуемые пакеты:
  libqt4-opengl-dev
Пакеты, которые будут УДАЛЕНЫ:
  compiz compiz-plugins-main-default libgl1-mesa-dri libosmesa6
  libvisual-0.4-plugins libwxgtk2.8-0 libxatracker1 mate-desktop-environment
  mate-screensaver mesa-utils nestopia nux-tools pipelight-multi playonlinux
  python-wxgtk2.8 snes9x-gtk unity wine-compholio wine1.4 wine1.4-common
  wine1.4-i386 xorg xserver-xorg-video-all xserver-xorg-video-vmware zsnes
НОВЫЕ пакеты, которые будут установлены:
  libqt4-dev libqtwebkit-dev qt4-linguist-tools qt4-qmake
Пакеты, которые будут обновлены:
  libqt4-dbus libqt4-declarative libqt4-designer libqt4-help libqt4-network
  libqt4-opengl libqt4-qt3support libqt4-script libqt4-scripttools libqt4-sql
  libqt4-sql-sqlite libqt4-svg libqt4-test libqt4-xml libqt4-xmlpatterns
  libqtcore4 libqtgui4 qdbus
обновлено 18, установлено 4 новых пакетов, для удаления отмечено 25 пакетов, и 11 пакетов не обновлено.
Remv unity [5.20.0-0ubuntu3]
Remv compiz [1:0.9.7.12-0ubuntu3]
Remv compiz-plugins-main-default [1:0.9.7.0~bzr19-0ubuntu10.1]
Remv xserver-xorg-video-all [1:7.6+12ubuntu2]
Remv xserver-xorg-video-vmware [1:12.0.1-1ubuntu1.1]
Remv libxatracker1 [9.2.0~git20131002+9.2.2eb55601-0ubuntu0sarvatt~precise]
Remv xorg [1:7.6+12ubuntu2]
Remv libgl1-mesa-dri [9.0.1-0ubuntu1~precise]
Remv libosmesa6 [9.2.0~git20131002+9.2.2eb55601-0ubuntu0sarvatt~precise]
Remv libvisual-0.4-plugins [0.4.0.dfsg.1-7]
Remv playonlinux [4.2.1]
Remv python-wxgtk2.8 [2.8.12.1-6ubuntu2]
Remv libwxgtk2.8-0 [2.8.12.1-6ubuntu2]
Remv mate-desktop-environment [1.6.0.1+precise]
Remv mate-screensaver [1.6.0-1+precise]
Remv pipelight-multi [0.2.3~ubuntu12.04.1]
Remv mesa-utils [8.1.0-0ubuntu1~precise1]
Remv nestopia [1.40-0ubuntu0~filthypants10]
Remv nux-tools [2.14.1-0ubuntu1]
Remv snes9x-gtk [1:1.53.81-1~precise1]
Remv wine-compholio [1.7.8-1~ubuntu12.04.1]
Remv wine1.4-common [1.4.1-0ubuntu1~precise1~ppa3] [wine1.4-i386:i386 ]
Remv wine1.4 [1.4.1-0ubuntu1~precise1~ppa3] [wine1.4-i386:i386 ]
Remv wine1.4-i386 [1.4.1-0ubuntu1~precise1~ppa3]
Remv zsnes [1.510-2.2ubuntu5]
Inst libqt4-sql-sqlite [4:4.8.1-0ubuntu4.5] (4:4.8.1-0ubuntu4.6 Ubuntu:12.04/precise-proposed [i386]) []
Inst libqt4-qt3support [4:4.8.1-0ubuntu4.5] (4:4.8.1-0ubuntu4.6 Ubuntu:12.04/precise-proposed [i386]) []
Inst libqt4-help [4:4.8.1-0ubuntu4.5] (4:4.8.1-0ubuntu4.6 Ubuntu:12.04/precise-proposed [i386]) []
Inst libqt4-svg [4:4.8.1-0ubuntu4.5] (4:4.8.1-0ubuntu4.6 Ubuntu:12.04/precise-proposed [i386]) []
Inst libqt4-scripttools [4:4.8.1-0ubuntu4.5] (4:4.8.1-0ubuntu4.6 Ubuntu:12.04/precise-proposed [i386]) []
Inst libqt4-opengl [4:4.8.1-0ubuntu4.5] (4:4.8.1-0ubuntu4.6 Ubuntu:12.04/precise-proposed [i386]) []
Inst libqt4-designer [4:4.8.1-0ubuntu4.5] (4:4.8.1-0ubuntu4.6 Ubuntu:12.04/precise-proposed [i386]) []
Inst libqtgui4 [4:4.8.1-0ubuntu4.5] (4:4.8.1-0ubuntu4.6 Ubuntu:12.04/precise-proposed [i386]) [libqt4-declarative:i386 ]
Inst libqt4-declarative [4:4.8.1-0ubuntu4.5] (4:4.8.1-0ubuntu4.6 Ubuntu:12.04/precise-proposed [i386]) []
Inst libqt4-sql [4:4.8.1-0ubuntu4.5] (4:4.8.1-0ubuntu4.6 Ubuntu:12.04/precise-proposed [i386]) []
Inst libqt4-xmlpatterns [4:4.8.1-0ubuntu4.5] (4:4.8.1-0ubuntu4.6 Ubuntu:12.04/precise-proposed [i386]) []
Inst libqt4-network [4:4.8.1-0ubuntu4.5] (4:4.8.1-0ubuntu4.6 Ubuntu:12.04/precise-proposed [i386]) []
Inst libqt4-script [4:4.8.1-0ubuntu4.5] (4:4.8.1-0ubuntu4.6 Ubuntu:12.04/precise-proposed [i386]) []
Inst libqt4-test [4:4.8.1-0ubuntu4.5] (4:4.8.1-0ubuntu4.6 Ubuntu:12.04/precise-proposed [i386]) []
Inst qdbus [4:4.8.1-0ubuntu4.5] (4:4.8.1-0ubuntu4.6 Ubuntu:12.04/precise-proposed [i386]) []
Inst libqt4-dbus [4:4.8.1-0ubuntu4.5] (4:4.8.1-0ubuntu4.6 Ubuntu:12.04/precise-proposed [i386]) []
Inst libqt4-xml [4:4.8.1-0ubuntu4.5] (4:4.8.1-0ubuntu4.6 Ubuntu:12.04/precise-proposed [i386]) []
Inst libqtcore4 [4:4.8.1-0ubuntu4.5] (4:4.8.1-0ubuntu4.6 Ubuntu:12.04/precise-proposed [i386])
Inst qt4-linguist-tools (4:4.8.1-0ubuntu4.6 Ubuntu:12.04/precise-proposed [i386])
Inst qt4-qmake (4:4.8.1-0ubuntu4.6 Ubuntu:12.04/precise-proposed [i386])
Inst libqt4-dev (4:4.8.1-0ubuntu4.6 Ubuntu:12.04/precise-proposed [i386])
Inst libqtwebkit-dev (2.2.1-1ubuntu4 Ubuntu:12.04/precise [i386])
Conf libqtcore4 (4:4.8.1-0ubuntu4.6 Ubuntu:12.04/precise-proposed [i386])
Conf libqt4-sql (4:4.8.1-0ubuntu4.6 Ubuntu:12.04/precise-proposed [i386])
Conf libqt4-sql-sqlite (4:4.8.1-0ubuntu4.6 Ubuntu:12.04/precise-proposed [i386])
Conf libqt4-xml (4:4.8.1-0ubuntu4.6 Ubuntu:12.04/precise-proposed [i386])
Conf libqt4-dbus (4:4.8.1-0ubuntu4.6 Ubuntu:12.04/precise-proposed [i386])
Conf libqt4-script (4:4.8.1-0ubuntu4.6 Ubuntu:12.04/precise-proposed [i386])
Conf libqt4-network (4:4.8.1-0ubuntu4.6 Ubuntu:12.04/precise-proposed [i386])
Conf libqt4-xmlpatterns (4:4.8.1-0ubuntu4.6 Ubuntu:12.04/precise-proposed [i386])
Conf libqtgui4 (4:4.8.1-0ubuntu4.6 Ubuntu:12.04/precise-proposed [i386])
Conf libqt4-declarative (4:4.8.1-0ubuntu4.6 Ubuntu:12.04/precise-proposed [i386])
Conf libqt4-designer (4:4.8.1-0ubuntu4.6 Ubuntu:12.04/precise-proposed [i386])
Conf libqt4-qt3support (4:4.8.1-0ubuntu4.6 Ubuntu:12.04/precise-proposed [i386])
Conf libqt4-help (4:4.8.1-0ubuntu4.6 Ubuntu:12.04/precise-proposed [i386])
Conf libqt4-svg (4:4.8.1-0ubuntu4.6 Ubuntu:12.04/precise-proposed [i386])
Conf libqt4-scripttools (4:4.8.1-0ubuntu4.6 Ubuntu:12.04/precise-proposed [i386])
Conf libqt4-opengl (4:4.8.1-0ubuntu4.6 Ubuntu:12.04/precise-proposed [i386])
Conf libqt4-test (4:4.8.1-0ubuntu4.6 Ubuntu:12.04/precise-proposed [i386])
Conf qdbus (4:4.8.1-0ubuntu4.6 Ubuntu:12.04/precise-proposed [i386])
Conf qt4-linguist-tools (4:4.8.1-0ubuntu4.6 Ubuntu:12.04/precise-proposed [i386])
Conf qt4-qmake (4:4.8.1-0ubuntu4.6 Ubuntu:12.04/precise-proposed [i386])
Conf libqt4-dev (4:4.8.1-0ubuntu4.6 Ubuntu:12.04/precise-proposed [i386])
Conf libqtwebkit-dev (2.2.1-1ubuntu4 Ubuntu:12.04/precise [i386])
Qwentor ★★★★★ ()
Ответ на: комментарий от Qwentor

Отключите все сторонние репозитории, выполните 'aptitude update'

И заново попробуйте установить требуемый пакет или, если вы делаете обновление системы, выполнить его.

kostik87 ★★★★★ ()
Ответ на: комментарий от Qwentor

Похоже, что ты перед этим удалил какой-то мета пакет, у которого в зависимостях было все то, что сейчас синаптик хочет снести. Если так, то поставь его обратно

Gattai ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.