LINUX.ORG.RU

Упорно требует libqt4-webkit для установки пакета

 ,


0

1

Собственно проблемс: пытаюсь поставить пакет(не думаю, что важно какой), но: Gdebi пишет

Ошибка: Неразрешимая зависимость: libqt4-webkit(>=4:4.6.2)

dpkg пишет

dpkg: r:i386: проблемы зависимостей, но по вашему указанию всё равно производим настройку: r:i386 зависит от libqt4-webkit (>= 4:4.6.2). r:i386 зависит от libgomp1.

libgomp1 подтянул через synaptic, а вот libqt4-webkit не нашло, но я в нете нагуглил libqt4-webkit 4.8.5, поставил, но его все равно не видит и требует этот libqt4, ичсх при установке подтягиваются все зависимости libqt4-*, но именно вебкита почему-то нет

Мне мешает понять проблему лишняя хромосома, или просто неопытность(с линуксом общаюсь не так давно)? Что не так?

Система: Elementary OS 5.0 Juno (По сути - убунту 18.04, со всеми ее детскими травмами, но имхо более приятным интерфейсом из коробки), репозитории canonical подключены, все обновлено и заапдейчено

upd: ставил пакеты i386

upd: прога Rumus 1.8.4


, но я в нете нагуглил libqt4-webkit 4.8.5, поставил

Вангую, ты поставил amd64 пакет, а dpkg ругается на i386.

annerleen ★★★★★ ()

"совет"

ни за что не говори, что за программу (пакет) пытаешься ставить — обсуждение может завершиться слишком быстро...

по теме. в разных дистрах даже пакеты с одинаковыми (похожими) именами могут иметь разное «наполнение».

anymouze ★★ ()
Ответ на: "совет" от anymouze

Понимаю твое любопытство, но: 1) прога не обновлялась с 2014 года, а пару лет назад, я был свидетелем того, как она вполне себе славно на восемнадцатом минте запустилась 2) для скачивания доступны только 2 пакета .rpm и .deb, исключаем тот, что для федоры, и получаем 100% тот же пакет, что был и тогда Так что, ее название лишний раз отвлечет от решения настоящей проблемы, и нифига не изменит

И как ты мог заметить, проблема не с самой прогой, а с зависимостью от пакета(хз что это, но исходя из названия, предположу, что какая api библиотека), который, единственный из себе подобных(libqt4-network, libqt4-xml и т.п.) отсутствует в репозиториях, а тот, что я нашел, dpkg по какой-то причине не устраивает

Dru ()

Короче, на 8 часу использования великого научного метода «пальцем в небо» нашёл рабочее решение, а как говорится: «работает - не трогай»

Мне помогла установка версии 4.8.2 для восьмого дебиана, хрен его знает почему только ее приняло, причину узнать конечно интересно, но лучше пойду спать

Dru ()
Ответ на: комментарий от Dru

думаю мне эта программа не нужна. :)

понять «почему» и «как» бывает сложно, если не знаешь «что» и «откуда» надо установить.

Поясню на примере. Программа mc в Debian «состоит» из 2 пакетов (остальные уже есть*), LinuxMint та же самая mc устанавливается с 6..8 «дополнительными» пакетами. Возможно и Debian, и LinuxMint используют одно и то же ПО, но скомпоновано оно может быть по-разному.

anymouze ★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.