LINUX.ORG.RU

Network Manager не поднимает автоматически сессию.

 , ,


0

1

Я все-таки вновь подниму эту тему.

Имеется openSUSE 12.2, 3G-модем и Network Manager версии 0.9.0.2. 3G модем определяется, и сессию хорошо поднимает, если нажать на кнопочку. А вот автоматически при старте системы не поднимает, не смотря на то что галочка в настройках на пункте Connect automatically стоит.

http://storage3.static.itmages.ru/i/12/0916/h_1347810314_4482235_42e89e1858.png

После запуска системы в настройках виджета Управление сетью не стоит галочка на пункте Enable mobile broadband. Галочка там вручную не ставится и появляется автоматически только после того как нажать на кнопку соединения. То есть, как я понимаю, что-то мешает автоматически запустить сеть без действий пользователя.

http://storage6.static.itmages.ru/i/12/0916/h_1347810764_8092301_c2923efe6d.jpeg

При этом, если завершить сеанс KDE, а потом вновь залогиниться, то сессия при этом автоматически поднимается. А после полного рестарта системы-нет. Судя по поискам решения проблемы в гугле, аналогичные проблемы возникали и у пользователей последних версий убунты и федоры, и связаны, как я понял, не с криворукостью пользователей или багами системы, а с багами именно данной версии Network Manager-а. Можно данный баг исправить правкой конфигов или придется искать более сложные решения связанные со скриптами? И если правка конфигов не поможет делу, какое наиболее простое решение посоветуете?

P.S. Анонимусам просьба: не предлагать устанавливать win 7, так как она установлена и там все работает.

/etc/NetworkManager/NetworkManager.conf

[main]
plugins=ifcfg-suse,keyfile
no-auto-default=02:50:F3:00:00:00,88:AE:1D:DB:1C:E9,
/etc/NetworkManager/system-connections/Билайн GSM

[connection]
id=Билайн GSM
uuid=04331ad3-a2aa-4196-875d-6a8fcea3f063
type=gsm
timestamp=1347800293

[ipv6]
method=ignore

[ipv4]
method=auto
dns=212.44.130.6;217.118.83.6;
ignore-auto-dns=true

[gsm]
number=*99#
username=beeline
password-flags=1
apn=home.beeline.ru
pin-flags=4
home-only=true
/var/log/NetworkManager

Sep 16 19:33:41 linux-ttg6 NetworkManager[619]: <info> Activation (ttyUSB0) starting connection 'Билайн GSM'
Sep 16 19:33:41 linux-ttg6 NetworkManager[619]: <info> (ttyUSB0): device state change: disconnected -> prepare (reason 'none') [30 40 0]
Sep 16 19:33:41 linux-ttg6 NetworkManager[619]: <info> Activation (ttyUSB0) Stage 1 of 5 (Device Prepare) scheduled...
Sep 16 19:33:41 linux-ttg6 NetworkManager[619]: <info> Activation (ttyUSB0) Stage 1 of 5 (Device Prepare) started...
Sep 16 19:33:41 linux-ttg6 NetworkManager[619]: <info> (ttyUSB0): device state change: prepare -> need-auth (reason 'none') [40 60 0]
Sep 16 19:33:41 linux-ttg6 NetworkManager[619]: <info> Activation (ttyUSB0) Stage 1 of 5 (Device Prepare) complete.
Sep 16 19:33:42 linux-ttg6 NetworkManager[619]: <info> Activation (ttyUSB0) Stage 1 of 5 (Device Prepare) scheduled...
Sep 16 19:33:42 linux-ttg6 NetworkManager[619]: <info> Activation (ttyUSB0) Stage 1 of 5 (Device Prepare) started...
Sep 16 19:33:42 linux-ttg6 NetworkManager[619]: <info> (ttyUSB0): device state change: need-auth -> prepare (reason 'none') [60 40 0]
Sep 16 19:33:42 linux-ttg6 NetworkManager[619]: <info> Activation (ttyUSB0) Stage 1 of 5 (Device Prepare) complete.
Sep 16 19:33:42 linux-ttg6 NetworkManager[619]: <info> WWAN now enabled by management service
Sep 16 19:33:42 linux-ttg6 NetworkManager[619]: <info> Activation (ttyUSB0) Stage 2 of 5 (Device Configure) scheduled...
Sep 16 19:33:42 linux-ttg6 NetworkManager[619]: <info> Activation (ttyUSB0) Stage 2 of 5 (Device Configure) starting...
Sep 16 19:33:42 linux-ttg6 NetworkManager[619]: <info> (ttyUSB0): device state change: prepare -> config (reason 'none') [40 50 0]
Sep 16 19:33:42 linux-ttg6 NetworkManager[619]: <info> Activation (ttyUSB0) Stage 2 of 5 (Device Configure) successful.
Sep 16 19:33:42 linux-ttg6 NetworkManager[619]: <info> Activation (ttyUSB0) Stage 3 of 5 (IP Configure Start) scheduled.
Sep 16 19:33:42 linux-ttg6 NetworkManager[619]: <info> Activation (ttyUSB0) Stage 2 of 5 (Device Configure) complete.
Sep 16 19:33:42 linux-ttg6 NetworkManager[619]: <info> Activation (ttyUSB0) Stage 3 of 5 (IP Configure Start) started...
Sep 16 19:33:42 linux-ttg6 NetworkManager[619]: <info> (ttyUSB0): device state change: config -> ip-config (reason 'none') [50 70 0]
Sep 16 19:33:42 linux-ttg6 NetworkManager[619]: <info> starting PPP connection
Sep 16 19:33:42 linux-ttg6 NetworkManager[619]: <info> pppd started with pid 1820
Sep 16 19:33:42 linux-ttg6 NetworkManager[619]: <info> Activation (ttyUSB0) Stage 4 of 5 (IPv6 Configure Timeout) scheduled...
Sep 16 19:33:42 linux-ttg6 NetworkManager[619]: <info> Activation (ttyUSB0) Stage 3 of 5 (IP Configure Start) complete.
Sep 16 19:33:42 linux-ttg6 NetworkManager[619]: <info> Activation (ttyUSB0) Stage 4 of 5 (IPv6 Configure Timeout) started...
Sep 16 19:33:42 linux-ttg6 NetworkManager[619]: <info> Activation (ttyUSB0) Stage 4 of 5 (IPv6 Configure Timeout) complete.
Sep 16 19:33:42 linux-ttg6 NetworkManager[619]: Plugin /usr/lib64/pppd/2.4.5/nm-pppd-plugin.so loaded.
Sep 16 19:33:43 linux-ttg6 NetworkManager[619]: Using interface ppp0
Sep 16 19:33:43 linux-ttg6 NetworkManager[619]: Connect: ppp0 <--> /dev/ttyUSB0
Sep 16 19:33:43 linux-ttg6 NetworkManager[619]: CHAP authentication succeeded
Sep 16 19:33:43 linux-ttg6 NetworkManager[619]: CHAP authentication succeeded
Sep 16 19:33:46 linux-ttg6 NetworkManager[619]: Could not determine remote IP address: defaulting to 10.64.64.64
Sep 16 19:33:46 linux-ttg6 NetworkManager[619]: <info> PPP manager(IP Config Get) reply received.
Sep 16 19:33:46 linux-ttg6 NetworkManager[619]: <info> Activation (ttyUSB0) Stage 5 of 5 (IPv4 Configure Commit) scheduled...
Sep 16 19:33:46 linux-ttg6 NetworkManager[619]: <info> Activation (ttyUSB0) Stage 5 of 5 (IPv4 Commit) started...
Sep 16 19:33:46 linux-ttg6 NetworkManager[619]: local  IP address 172.19.11.253
Sep 16 19:33:46 linux-ttg6 NetworkManager[619]: remote IP address 10.64.64.64
Sep 16 19:33:46 linux-ttg6 NetworkManager[619]: primary   DNS address 217.118.66.243
Sep 16 19:33:46 linux-ttg6 NetworkManager[619]: secondary DNS address 195.68.135.5
Sep 16 19:33:46 linux-ttg6 NetworkManager[619]: Script /etc/ppp/ip-up finished (pid 1838), status = 0x0
Sep 16 19:33:47 linux-ttg6 NetworkManager[619]: <info> Clearing nscd hosts cache.
Sep 16 19:33:47 linux-ttg6 NetworkManager[619]: <info> (ttyUSB0): device state change: ip-config -> activated (reason 'none') [70 100 0]
Sep 16 19:33:47 linux-ttg6 NetworkManager[619]: <info> Policy set 'Билайн GSM' (ppp0) as default for IPv4 routing and DNS.
Sep 16 19:33:47 linux-ttg6 NetworkManager[619]: <info> Activation (ttyUSB0) successful, device activated.
Sep 16 19:33:47 linux-ttg6 NetworkManager[619]: <info> Activation (ttyUSB0) Stage 5 of 5 (IPv4 Commit) complete.
Sep 16 19:33:48 linux-ttg6 nm-dispatcher.action: Script '/etc/NetworkManager/dispatcher.d/nfs' exited with error status 2.

После завершения сеанса KDE и нового входа, в лог добавляется только одна запись:

Sep 16 20:15:45 linux-ttg6 NetworkManager[619]: Protocol-Reject for unsupported protocol 0xcd

Dnmt ()

Знаком с этой фичей Кед, когда галочка «мобильные соединения» сбрасывалась. Победить не смог. Но сейчас меня это не волнует, на Гноме 3 все пучком.

anonymous ()
Ответ на: комментарий от anonymous

Пробовал гном 3, там действительно все работает. А вот в KDE...

Dnmt ()

чтоб два раза не вставать: заставьте nm поднимать проводное соединение, а за ним VPN, т.е. (wired connection on && wpn connection on). Решается это или мне судьба каждый раз руками тыкать в него при старте?

//проблеме больше двух лет, как-то поднимал вопрос, не решили.

S-Mage ★★ ()
Ответ на: комментарий от S-Mage

И как это сделать?

Надо сказать что на Debian с KDE 4.4.5, сессия автоматически поднималась без проблем.

Dnmt ()

Снеси семерочку и все поднимется. Очевидно же.

anonymous ()

Все не читал, много букав.

Добавь в /etc/rc.local активацию соединения nmcli ...

sdio ★★★★★ ()
Ответ на: комментарий от Dnmt

Я лично юзаю гномовский аплет NM в kde3 и в kde4. Если в гноме 3 все работает, то поставь гномовский аплет, запусти настрой и добавь в автозагрузке через настройки kde.

anonymous ()
Ответ на: комментарий от Dnmt

Нет такого файла.

Обидно-то как! Что же мне теперь делать?

sdio ★★★★★ ()
Ответ на: комментарий от anonymous

А можно точное название гномовского пакета? И скрин, чтобы посмотреть как он будет выглядеть?

Dnmt ()
Ответ на: комментарий от jollheef

Я не совсем понял каким образом этот скрипт для VPN-соединения повлияет на на 3G-соединение?

Dnmt ()
Ответ на: комментарий от Dnmt

Я не совсем понял каким образом этот скрипт для VPN-соединения повлияет на на 3G-соединение?

Так я и не на твою проблему ответ писал, а на его.

Проверь, если через nmcli можно рулить 3G — то можно и к нему подобный костыль прикрутить.

jollheef ★★★★☆ ()
Ответ на: комментарий от Dnmt

Valrav

В консоли от рута выполнить

zypper install NetworkManager-gnome  NetworkManager-gnome-lang NetworkManager-pptp-gnome NetworkManager-pptp-lang

или ищешь эти пакеты в ясте и устанавливаешь через него.

Для добавления аплета в автозапуск делаешь следующее:

1. Заходишь в параметры системы

http://rghost.ru/40808570/image.png

2. Далее заходим в Запуск и завершение

http://rghost.ru/40808581/image.png

3. Жмешь добавить скрипт и вводишь как на скрине ниже

http://rghost.ru/40808587/image.png

и жмешь OK

http://rghost.ru/40808626/image.png

4. После этого гномовский аплет будет запускаться вместе с kde

----------------------------------------------------------------------------

И скрин, чтобы посмотреть как он будет выглядеть?

5. Самые левый значок в трее

http://rghost.ru/40808635/image.png

6. Жмешь изменить соединения и появляются настройки

http://rghost.ru/40808643/image.png

Чтобы кдеешный плазмоид NM настройки сети не мешался (и не кофликтовал), то можешь его удалить командой

zypper remove plasmoid-networkmanagement

или удали через яст. Можно его не удалять, а просто убрать виджет из трея:

7. Разблокирушь изменение виджетов

http://rghost.ru/40808653/image.png

8. Правой кнопкой по kde виджету настройки сети и жмешь удалить виджет управления сетью

http://rghost.ru/40808673/image.png

Аналогично заблокирушь изменение виджетов

anonymous ()
Ответ на: комментарий от anonymous

Так значит проблема все-таки в kde-шной версии Network Manager?

Dnmt ()
Ответ на: комментарий от Dnmt

У уже приводил ссылки в этом сообщении

www.linux.org.ru/forum/general/8237696?lastmod=1349711320018#comment-8313824

По-первой ссылке говорится, что проблема вроде в самом NM и ModemManager, но она вроде бы была решена. Вообщем не знаю, попробуйте гномовский аплет, если проблемы не будет, значит проблема конкретно в кдеешном плазмоиде, если осталась значит проблема в самом NM.

По второй ссылке вроде как предлагается решение на случай, если в гномовском аплете будут теже проблемы.

Вот даже нашел ссылку на багзиллу, где ваше проблема обсуждалась

https://bugzilla.gnome.org/show_bug.cgi?id=659228

Там нашел ссылку на ланчпад

https://bugs.launchpad.net/ubuntu/ source/network-manager/ bug/848164/comment...

И там чел пишет, что эту проблему решил через использование nmcli как указал несколькими сообщениями ранее sdio и ксати приводит туже ссылку, которую я указал, в качестве примера.

anonymous ()
Ответ на: комментарий от Dnmt

Valrav

Вот кстати еще есть ссылка на скрипт

http://best-ubuntu-notebook.blogspot.com/2010/12/network-manager-auto-reconne...

Вообщем попробуйте гномовский аплет, если проблема останется, то удалить его также через яст не проблема. Если проблема есть то тут думаю придется решать все через nmcli

anonymous ()
Ответ на: комментарий от anonymous

И там чел пишет, что эту проблему решил через использование nmcli как указал несколькими сообщениями ранее sdio и ксати приводит туже ссылку, которую я указал, в качестве примера.

Как и именно ее решить через использование nmcli?

Dnmt ()
Ответ на: комментарий от Dnmt

Valrav

Гномовский аплет, я так понимаю, вы не хотите использовать, что касается решения через nmcli, то по ссылке инструкция следующая

Вот инструкция

http://www.thefanclub.co.za/how-to/how-auto-connect-ubuntu-1204-gsm-mobile-br...

Значит так

Качаете архив с этим скриптом, если вам помимо автозапуска еще нужено автоматическое переподключение соединения, либо этот архив с этим скриптом, если интересует просто автозапуск.

Далее разархивируете его через архиватор (второй архив распаковывать придется дважды, т.е. при распаковке mobile-broadband-connect-0.1.tar_0.gz образуется еще один архив mobile-broadband-connect-0.1.tar_0, который надо также распаковать, что бы добраться до скрипта)

Далее у тебя был скрин там вверху есть имя соединения «Билайн GSM», переименовываешь его в допустим «Beeline_GSM»

Открываешь скрипт любым редактором и заменяешь в каждой строчке (где соответственно есть) YourMobileBroadbandConnectionNameHere на Beeline_GSM.

Далее либо в дельфине правой кнопкой мыши по скрипту mobile-broadband-connect-2.0.sh (или mobile-broadband-connect-0.1.sh) в контекстном меню выбираешь свойства, дальше вкладка права и ставим галку на «является выполняемым», либо в консоли от рута:

сd <путь до файла> 
chmod +x mobile-broadband-connect-2.0.sh (либо chmod +x mobile-broadband-connect-2.0.sh)

После этого для удобства переименовываем скрипт в mobile-broadband-connect

Далее открываем консоль

su
export $(dbus-launch) // это строчка может не понадобится
dolphin

Откроется dolphin от рута. Далее идем к нашему переименованному скрипту и копируем его в директорию /etc/init.d

Далее открываешь консоль и выполняешь

su
cd /etc/init.d
insserv mobile-broadband-connect

Перезагружаешься и проверяешь

anonymous ()
Ответ на: комментарий от anonymous

Открываешь скрипт любым редактором и заменяешь в каждой строчке (где соответственно есть) YourMobileBroadbandConnectionNameHere на Beeline_GSM.

Правильно лучше заключить Beeline_GSM в кавычки, т.е

Открываешь скрипт любым редактором и заменяешь в каждой строчке (где соответственно есть) YourMobileBroadbandConnectionNameHere на «Beeline_GSM».

anonymous ()
Ответ на: комментарий от anonymous

К сожалению не работает ни первый, ни второй скрипт. Автоконнекта как не было, так и нет.

Для удаления достаточно удалить скрипт mobile-broadband-connect из /etc/init.d или еще потребуется ввод команд?

Dnmt ()
Ответ на: комментарий от Dnmt

Valrav

Что выводит команда

LC_ALL=C nmcli -t -f TYPE,STATE dev 

при подключенном 3G-модеме

anonymous ()
Ответ на: комментарий от anonymous
~> LC_ALL=C nmcli -t -f TYPE,STATE dev 
gsm:connected
802-3-ethernet:disconnected
802-3-ethernet:unavailable
802-11-wireless:unavailable
Dnmt ()
Ответ на: комментарий от Dnmt

ValravВесь скрипт сюда запостите пожайлуста

Еще в yast зайдите в Система -> Запуск служб

и проверьте статус mobile-broadband-connect (т.е Да или Нет в статусе)

anonymous ()
Ответ на: комментарий от Dnmt

Valrav

Название соединения «Билайн GSM» на «Beeline» поняли - покажите скрин

Перезагрузитесь со вставленным 3G модемом и посмотрите не установилось ли соединение?

anonymous ()
Ответ на: комментарий от anonymous

Название соединения «Билайн GSM» на «Beeline» поняли - покажите скрин

Fix:

Название соединения в кдеешном плазмоиде NM «Билайн GSM» на «Beeline» поменяли - покажите скрин

anonymous ()
Ответ на: комментарий от Dnmt

Valrav

Так я уже запутался

Еще вопрос:

Отключите соединения с модемом

далее в консоли от рута выполните

nmcli -t con up id "Beeline"

соединение поднимается или нет

anonymous ()
Ответ на: комментарий от anonymous

Имеется ввиду отключить соединение в кдеешном плазмоиде, а потом выполнить уже команду в консоли

anonymous ()
Ответ на: комментарий от Dnmt

Valrav

После запуска системы в настройках виджета Управление сетью не стоит галочка на пункте Enable mobile broadband.

И еще одно: вы не могли бы когда запустится система с вашей проблемой вывести содержимое команды

nmcli nm

Потом вручную установить соединение (нажав на Enable mobile broadband) и вновь вывести содержимое

nmcli nm 
anonymous ()
Ответ на: комментарий от anonymous

От юзера поднялось:

~> nmcli -t con up id "Beeline"
Состояние активного соединения: активация
Путь активного соединения: /org/freedesktop/NetworkManager/ActiveConnection/8
состояние: активно
Соединение активно
А вот от рута нет:
# nmcli -t con up id "Beeline"

** (process:7355): WARNING **: async_got_type: could not read properties for /org/freedesktop/NetworkManager/ActiveConnection/9: Method "Get" with signature "ss" on interface "org.freedesktop.DBus.Properties" doesn't exist


** (process:7355): WARNING **: async_got_type: could not read properties for /org/freedesktop/NetworkManager/ActiveConnection/9: Method "Get" with signature "ss" on interface "org.freedesktop.DBus.Properties" doesn't exist




Dnmt ()
Ответ на: комментарий от anonymous

После запуска системы, когда сеть автоматически не поднялась, выдает это:

~> nmcli nm
ВЫПОЛНЯЕТСЯ     СОСТОЯНИЕ       ОБОРУДОВАНИЕ WIFI WIFI       ОБОРУДОВАНИЕ WWAN WWAN      
выполняется     отключено       отключён        отключён   включён         отключён  
А после ручного подключения, когда соответственно галочка на Enable mobile Broadband автоматически ставится, выдает это:
~> nmcli nm
ВЫПОЛНЯЕТСЯ     СОСТОЯНИЕ       ОБОРУДОВАНИЕ WIFI WIFI       ОБОРУДОВАНИЕ WWAN WWAN      
выполняется     подключено      отключён        отключён   включён         включён   

Dnmt ()
Ответ на: комментарий от Dnmt

Так теперь в вашем скрипте

Добавьте строчку

nmcli nm wwan on

перед

nmcli -t con up id "Beeline"

Не знаю какой скрипт вы предпочли поэтому

http://paste.org.ru/?1jykjd

или

http://paste.org.ru/?4e2ony

Далее когда скрипт изменити

выполните вновь

su
cd /etc/init.d
insserv mobile-broadband-connect

Перезагрузитесь.

anonymous ()
Ответ на: комментарий от anonymous

Так теперь в вашем скрипте

Добавьте строчку

nmcli nm wwan on

перед

nmcli -t con up id "Beeline"

Не знаю какой скрипт вы предпочли поэтому

Можно еще так и наверное это даже лучше

Так теперь в вашем скрипте

Добавьте строчку

nmcli -t nm wwan on

перед

nmcli -t con up id "Beeline"

Не знаю какой скрипт вы предпочли поэтому

http://paste.org.ru/?0znss9

или

http://paste.org.ru/?w5rmym

anonymous ()
Ответ на: комментарий от anonymous

Получилось, теперь подключается автоматически) Спасибо большое!

Dnmt ()
Ответ на: комментарий от anonymous

Добавьте строчку

nmcli -t nm wwan on

перед

nmcli -t con up id "Beeline"

И так тоже работате.

Может быть подскажите тогда что-нибудь по приложению Linphone, если знакомы с ним?

Dnmt ()
Ответ на: комментарий от Dnmt

Завтра вечером наверное посмотрю, а сейчас уже спать пора

anonymous ()
Ответ на: комментарий от anonymous

Качаете архив с этим скриптом, если вам помимо автозапуска еще нужено автоматическое переподключение соединения

Кстати, а в каких случаях соединения будет автоматически переподключаться, при разрыве связи?

Dnmt ()
Ответ на: комментарий от Dnmt

Valrav

~> LC_ALL=C nmcli -t -f TYPE,STATE dev 
gsm:connected
802-3-ethernet:disconnected
802-3-ethernet:unavailable
802-11-wireless:unavailable

Соотвественно первая строчка вывода

gsm:connected

означает, что модем подключен. Если по каким-то причинам соединение пропало, то эта строчка изменится на

gsm:disconnected

Соответственно в скрипте есть строчка проверяющая стастус соединения модема

LC_ALL=C nmcli -t -f TYPE,STATE dev | grep -q "^gsm:disconnected$"

Эта строчка находится внутри бесконечного цикла опроса состояния соединения и если вывод LC_ALL=C nmcli -t -f TYPE,STATE dev вдруг выдает состояние gsm:disconnected, то происходит попытка установить соединение. Если его не удалось установить, то через 30 секунд и если вывод LC_ALL=C nmcli -t -f TYPE,STATE dev вдруг опять выдаст состояние gsm:disconnected вновь произойдет попытка подключиться, если же вывод LC_ALL=C nmcli -t -f TYPE,STATE dev вдруг выдает состояние отличное от gsm:disconnected, то опрос состояния соединения будет происходить каждые 10 секунд до тех пор, пока не будет вновь состояния gsm:disconnected.

Правда вы засунули исполняться этот скрипт только при иницилизации (старте) системы и не знаю будет ли он исполняться дальше, когда произойдет обрыв соединения и нужно будет его переподключить автоматически. Это нужно вам проверить. Если окажется, что это так,т.е. во время обрыва соединения (ну допустим вы вручную в плазмоиде выключили соединение) не произойдет автоматическте переподключение, то в этом случае нужно создать файл rc.local, который будет работать дальше после того, как система уже будет загружена (он будет висеть в системном мониторе как процесс rc) и поместить туда вызов вашего скрипта. Ну и не забыть надо поместить rc.local в автозагрузку.

anonymous ()
Ответ на: комментарий от anonymous

Это нужно вам проверить. Если окажется, что это так,т.е. во время обрыва соединения (ну допустим вы вручную в плазмоиде выключили соединение) не произойдет автоматическте переподключение,

Не, при ручном отключение через плазмоид реконнекта не происходит. Но это не важно, мне и не нужно чтобы инет был постоянно подключен, да еще и без возможности отключения. Меня гораздо больше волнует другая проблема связанная с сетью, по которой я уже поднимал тему. Может что подскажете?

Dnmt ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.