LINUX.ORG.RU

USB адаптер TP-Link TL-WN722N не подключается к сети

 , ,


0

1

Лор, помоги с адаптером! Вставлен TP-Link TL-WN722N, установлено firmware-atheros из реп debian 10. Адаптер видно!

Bus 001 Device 003: ID 0cf3:9271 Qualcomm Atheros Communications AR9271 802.11n
Couldn't open device, some information will be missing
Device Descriptor:
  bLength                18
  bDescriptorType         1
  bcdUSB               2.00
  bDeviceClass          255 Vendor Specific Class
  bDeviceSubClass       255 Vendor Specific Subclass
  bDeviceProtocol       255 Vendor Specific Protocol
  bMaxPacketSize0        64
  idVendor           0x0cf3 Qualcomm Atheros Communications
  idProduct          0x9271 AR9271 802.11n
  bcdDevice            1.08
  iManufacturer          16 
  iProduct               32 
  iSerial                48 
  bNumConfigurations      1

Когда пытаюсь подключается в какой-нибудь сети через нетворк манагер, он висит секунд 30, а потом уведомляет, что не может подключится. В логе такая фигня

Sep 08 11:50:26 localhost NetworkManager[831]: <info>  [1567932626.2613] device (wlx8416f911b8b2): Activation: starting connection 'wifi_home' (***)
Sep 08 11:50:26 localhost NetworkManager[831]: <info>  [1567932626.2614] audit: op="connection-activate" uuid="***" name="wifi_home" pid=1730 uid=1000 result="success"
Sep 08 11:50:26 localhost NetworkManager[831]: <info>  [1567932626.2615] device (wlx8416f911b8b2): state change: disconnected -> prepare (reason 'none', sys-iface-state: 'managed')
Sep 08 11:50:26 localhost NetworkManager[831]: <info>  [1567932626.2619] manager: NetworkManager state is now CONNECTING
Sep 08 11:50:26 localhost NetworkManager[831]: <info>  [1567932626.2816] device (wlx8416f911b8b2): set-hw-addr: reset MAC address to ** (preserve)
Sep 08 11:50:26 localhost NetworkManager[831]: <info>  [1567932626.4324] device (wlx8416f911b8b2): state change: prepare -> config (reason 'none', sys-iface-state: 'managed')
Sep 08 11:50:26 localhost NetworkManager[831]: <info>  [1567932626.4327] device (wlx8416f911b8b2): Activation: (wifi) access point 'wifi_home' has security, but secrets are required.
Sep 08 11:50:26 localhost NetworkManager[831]: <info>  [1567932626.4328] device (wlx8416f911b8b2): state change: config -> need-auth (reason 'none', sys-iface-state: 'managed')
Sep 08 11:50:26 localhost NetworkManager[831]: <info>  [1567932626.4362] device (wlx8416f911b8b2): state change: need-auth -> prepare (reason 'none', sys-iface-state: 'managed')
Sep 08 11:50:26 localhost NetworkManager[831]: <info>  [1567932626.4367] device (wlx8416f911b8b2): state change: prepare -> config (reason 'none', sys-iface-state: 'managed')
Sep 08 11:50:26 localhost NetworkManager[831]: <info>  [1567932626.4372] device (wlx8416f911b8b2): Activation: (wifi) connection 'wifi_home' has security, and secrets exist.  No new secrets needed.
Sep 08 11:50:26 localhost NetworkManager[831]: <info>  [1567932626.4372] Config: added 'ssid' value 'wifi_home'
Sep 08 11:50:26 localhost NetworkManager[831]: <info>  [1567932626.4372] Config: added 'scan_ssid' value '1'
Sep 08 11:50:26 localhost NetworkManager[831]: <info>  [1567932626.4372] Config: added 'bgscan' value 'simple:30:-80:86400'
Sep 08 11:50:26 localhost NetworkManager[831]: <info>  [1567932626.4373] Config: added 'key_mgmt' value 'WPA-PSK WPA-PSK-SHA256'
Sep 08 11:50:26 localhost NetworkManager[831]: <info>  [1567932626.4373] Config: added 'auth_alg' value 'OPEN'
Sep 08 11:50:26 localhost NetworkManager[831]: <info>  [1567932626.4373] Config: added 'psk' value '<hidden>'
Sep 08 11:50:26 localhost NetworkManager[831]: <info>  [1567932626.5661] device (wlx8416f911b8b2): supplicant interface state: disconnected -> authenticating
Sep 08 11:50:31 localhost NetworkManager[831]: <info>  [1567932631.6401] device (wlx8416f911b8b2): supplicant interface state: authenticating -> disconnected
Sep 08 11:50:36 localhost NetworkManager[831]: <info>  [1567932636.7011] device (wlx8416f911b8b2): supplicant interface state: disconnected -> scanning
Sep 08 11:50:40 localhost NetworkManager[831]: <info>  [1567932640.9093] device (wlx8416f911b8b2): supplicant interface state: scanning -> authenticating
Sep 08 11:50:45 localhost NetworkManager[831]: <info>  [1567932645.9818] device (wlx8416f911b8b2): supplicant interface state: authenticating -> disconnected
Sep 08 11:50:51 localhost NetworkManager[831]: <warn>  [1567932651.7653] device (wlx8416f911b8b2): Activation: (wifi) association took too long, failing activation
Sep 08 11:50:51 localhost NetworkManager[831]: <info>  [1567932651.7653] device (wlx8416f911b8b2): state change: config -> failed (reason 'ssid-not-found', sys-iface-state: 'managed')
Sep 08 11:50:51 localhost NetworkManager[831]: <info>  [1567932651.7657] manager: NetworkManager state is now DISCONNECTED
Sep 08 11:50:51 localhost NetworkManager[831]: <warn>  [1567932651.7664] device (wlx8416f911b8b2): Activation: failed for connection 'wifi_home'
Sep 08 11:50:51 localhost NetworkManager[831]: <info>  [1567932651.7667] device (wlx8416f911b8b2): state change: failed -> disconnected (reason 'none', sys-iface-state: 'managed')
Sep 08 11:50:51 localhost NetworkManager[831]: <info>  [1567932651.7861] device (wlx8416f911b8b2): set-hw-addr: set MAC address to * (scanning)

Попробовал гуглить, но ничего не нашел! Тут даже ошибок каких-то блин нету, я не понимаю, что не так. Адаптер должен работать, он у меня уже работал год назад, когда я сидел еще на debian 9. А теперь не понимаю, почему не работает. Пароль 100% правильный, я пробовал даже менять пароль к сети на 11111111, но все равно не могу подключиться.

Попробуй сделать как здесь

[device]
 wifi.scan-rand-mac-address=0

=====
А после чего началось заметил? У меня сейчас тоже есть похожая «непонятка». Встроенный адаптер работал, система не изменялась... Но толком не работает в последнее время... Сначала вообще не подключался по wifi, позже к открытым сетям стал подключаться... Сегодня подключался и к защищенным, но не всем... Что-то я не могу уловить закономерность...

anymouze ★★ ()

device (wlx8416f911b8b2): set-hw-addr: reset MAC address to ** (preserve)

В /etc/NetworkManager/NetworkManager.conf добавь

[device]
wifi.scan-rand-mac-address=no

Ну или скорми ядру

net.ifnames=0
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=842422#45

So maybe a wpa_supplicant problem or some WiFi drivers doesn't play well with long device file names.

Samsky ()
Последнее исправление: Samsky (всего исправлений: 1)

Попробуйте загрузиться в девятом дебиане хоть с лайв сиди, либо поставить девятый дебиан на виртуалку и пробросить в него свистой вай-фай. Может статься, что ваша железка могла выйти из строя аппаратно, и не будет работать нигде.

Infra_HDC ★★★★★ ()
Ответ на: комментарий от anymouze

@anymouze, @Samsky, спасибо! Так оно и есть. Теперь подключается. Правда проявился другой баг - теперь иконка нетворк манагера всегда показывает отключено, даже когда подключено, но это пофиг. Главное работает.

Linux_Newbie ()