LINUX.ORG.RU

Ноут не подключается к WiFi

 , ,


1

3

Доброго времени суток. Столкнулся с ситуацией - мой ноут не может подключиться к WiFi сети. Имеющееся оборудование: ноут Леново Т400, операционка openSUSE 13.2, ядро 3.16.7-13-desktop из стандартных реп, сетевуха Intel PRO/Wireless 5100 AGN. Сеть регулируется NetworkManager'ом. WiFi точка - H3C wa2620-agn. Шифрование AES, метод WPA2-personal psk.

journalctl -u NetworkManager выдаёт следующее:

(NetworkManager:873): libnm-util-CRITICAL **: get_secret_flags: assertion 'is_secret_prop (setting, secret_name, error)' fa 
<info> Activation (wlp3s0) Stage 1 of 5 (Device Prepare) scheduled... 
<info> Activation (wlp3s0) Stage 1 of 5 (Device Prepare) started... 
<info> (wlp3s0): device state change: need-auth -> prepare (reason 'none') [60 40 0] 
<info> Activation (wlp3s0) Stage 2 of 5 (Device Configure) scheduled... 
<info> Activation (wlp3s0) Stage 1 of 5 (Device Prepare) complete. 
<info> Activation (wlp3s0) Stage 2 of 5 (Device Configure) starting... 
<info> (wlp3s0): device state change: prepare -> config (reason 'none') [40 50 0] 
<info> Activation (wlp3s0/wireless): connection 'Sparta' has security, and secrets exist.  No new secrets needed. 
<info> Config: added 'ssid' value 'Sparta' 
<info> Config: added 'scan_ssid' value '1' 
<info> Config: added 'key_mgmt' value 'WPA-PSK' 
<info> Config: added 'auth_alg' value 'OPEN' 
<info> Config: added 'psk' value '<omitted>' 
<info> Activation (wlp3s0) Stage 2 of 5 (Device Configure) complete. 
<info> Config: set interface ap_scan to 1 
<info> (wlp3s0): supplicant interface state: disconnected -> authenticating 
<info> (wlp3s0): supplicant interface state: authenticating -> associating 
<info> (wlp3s0): supplicant interface state: associating -> disconnected 
<info> (wlp3s0): supplicant interface state: disconnected -> scanning 
<info> (wlp3s0): supplicant interface state: scanning -> authenticating 
<info> (wlp3s0): supplicant interface state: authenticating -> associating 
<info> (wlp3s0): supplicant interface state: associating -> disconnected 
<info> (wlp3s0): supplicant interface state: disconnected -> scanning 
<warn> Activation (wlp3s0/wireless): association took too long. 
<info> (wlp3s0): device state change: config -> failed (reason 'no-secrets') [50 120 7] 
<info> NetworkManager state is now DISCONNECTED 
<warn> Activation (wlp3s0) failed for connection 'Sparta' 
<info> (wlp3s0): device state change: failed -> disconnected (reason 'none') [120 30 0] 
<info> (wlp3s0): deactivating device (reason 'none') [0] 
<info> (wlp3s0): supplicant interface state: scanning -> disconnected 
<warn> Couldn't disconnect supplicant interface: This interface is not connected. 

dmesg сыпет сообщениями:

wlp3s0: authenticate with 58:66:ba:18:a1:d0 
wlp3s0: send auth to 58:66:ba:18:a1:d0 (try 1/3) 
wlp3s0: authenticated 
wlp3s0: associate with 58:66:ba:18:a1:d0 (try 1/3) 
wlp3s0: RX AssocResp from 58:66:ba:18:a1:d0 (capab=0x8431 status=1 aid=0) 
wlp3s0: 58:66:ba:18:a1:d0 denied association (code=1)

в логе wpa_supplicant появляется следующее:

SME: Trying to authenticate with 58:66:ba:18:a1:d0 (SSID='Sparta' freq=2462 MHz) 
wlp3s0: Trying to associate with 58:66:ba:18:a1:d0 (SSID='Sparta' freq=2462 MHz) 
wlp3s0: CTRL-EVENT-ASSOC-REJECT bssid=58:66:ba:18:a1:d0 status_code=1 
wlp3s0: SME: Deauth request to the driver failed 
wlp3s0: CTRL-EVENT-SSID-TEMP-DISABLED id=0 ssid="Sparta" auth_failures=1 duration=10 reason=CONN_FAILED 
wlp3s0: CTRL-EVENT-SSID-REENABLED id=0 ssid="Sparta"

При этом виндовые клиенты, всякие андроиды, яблодевайсы подключаются без проблем. Вставлял в ноут другой диск с вендой, тоже подключилась. Запускал на ноуте live-cd Ubuntu, те же грабли - не подключается. Сам ноут при этом без проблем подключается к другим точкам. А так же если эту точку перевести на 802.11g, то мой ноут тоже без проблем подключается. Подскажите где и что подкрутить, что бы заработало. Варианты из гугла типа - отключить ipv6, рестартануть NetworkManager пользы не принесли.

попробуй подключаться в режиме g, а не n

echo "options iwlwifi 11n_disable=1" | sudo tee /etc/modprobe.d/iwlwifi.conf
sudo modprobe -rfv iwlwifi
sudo modprobe -v iwlwifi
JB ★★★★★ ()
Ответ на: комментарий от JB

Так я же писал в сообщении что если точку перевожу в g only, то ноут без проблем подключается.

Toten_Kopf ()

аналогичная ситуация. Периодически не хочет подключаться через WPA2. Иногда проходит само собой. Забил и перевёл роутер на WEP (думаю, в роутере проблема)

Sahas ★★★★★ ()
Ответ на: комментарий от Toten_Kopf

я тебе предлагаю не точку перевести в g-only, а адаптер на ноуте. Другие клиенты пусть и дальше работают в n

JB ★★★★★ ()
Ответ на: комментарий от Sahas

Ну вот фиг знает. К другим точкам с WPA2 подключается же, и вообще без проблем. У меня дома их три - Asus RT-N56U, Cisco WAP4410N и вот эту H3C приволок ещё. К первым двум в режиме N only, никаких проблем, работает и не отваливается. K H3C же не то что периодически, а вообще не подключается. Но, как уже упоминал, если перевожу Н3С в g only, то тоже без проблем, всё с тем же WPA2. Я конечно, для эксперимента попробую WEP, но что-то терзают меня смутные сомнения. Я думаю или проблема в драйверах на сетевуху, или что-то не доконфигурировал на точке. Там этих настроек как собак не резаных. А я с wifi не очень близко знаком.

Toten_Kopf ()
Ответ на: комментарий от JB

Попробую. Только уточнить хочу - если к моей точке подключается хоть один клиент в g режиме, разве она не перейдёт в режим g со всеми клиентами?

Toten_Kopf ()
Ответ на: комментарий от Toten_Kopf

если верить гуглу - не только у тебя такая проблема, это похоже на косяк в модуле карты

JB ★★★★★ ()
Ответ на: комментарий от Toten_Kopf

Только уточнить хочу - если к моей точке подключается хоть один клиент в g режиме, разве она не перейдёт в режим g со всеми клиентами?

не должна

JB ★★★★★ ()
Ответ на: комментарий от JB

Сделал, как ты предложил, мой ноут подключился по g, ноут жены подключился по n. Хотя конечно это дикий костыль.

Toten_Kopf ()
Ответ на: комментарий от Toten_Kopf

можно еще попробовать собрать свежее ядро с новым firmware, может уже починили

JB ★★★★★ ()

Доброго времени суток.

Go away!!!

По теме:
просто драйвер твоего вай-вай сломался в текущих линуксах.
У меня такое было, когда карточка вроде как и подключается, но ничего не работает. вот прям на всех убунта, хведора и зюзя.
через релиз починяли обычно.

Deleted ()

Сеть регулируется NetworkManager'ом.

Отсюда копать. Взад NetworkManager, настроить сеть по-человечески, и не знать горя. Ещё при зачатии этого недоразумения я нутром почуял неладное, сразу отнёсся к нему скептически и никогда не использую, а посему — никаких проблем с сетью до сих пор не имею. Да: SuSE 13.2, сеть настроена посредством YaST без NM.

anonymous ()
Ответ на: комментарий от anonymous

прежде чем ляпнуть тебе стоило хотя бы погуглить. Проблема в модуле карты

JB ★★★★★ ()
Ответ на: комментарий от JB

УРАААААА

Спасибо большое тёзка! Больше года мучался. Вчера с горя дебиан jessie накатил, пол системы поломал.... А вот оно решения... аж прослезился

AT_95 ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.