LINUX.ORG.RU

Не монтируются разделы ntfs

 , ,


0

1

Поставил операционную систему Debian 6.0.5 с графической средой KDE 4.4.5. Понадобился доступ к NTFS разделам, расположенным на этом же жестком диске. Dolphin их видит, но при попытке примонтировать их, выдает ошибку:

Прооизошла ошибка при обращении к Media, ответ системы: org.freedesktop.Hal.Device.Volume.PermissionDenied: Refusing to mount device /dev/sda2 for uid=1000
(Media-это название раздела)

ntfs-3g установлен. Логин пользователя в группу plugdev добавил - безрезультатно. Пробовал прописывать логин пользователя в файл /etc/sudoers.tmp - безрезультатно.

В результате поправил файл fstab и добавил туда ntfs разделы:

# / was on /dev/sda5 during installation
UUID=57262a78-b6c4-4574-87d2-90d4d638d773 /               ext4    defaults          0       1
# /home was on /dev/sda6 during installation
UUID=8a47b13f-c236-45d9-96e9-add3767e73c4 /home           ext4    defaults          0       2
# swap was on /dev/sda7 during installation
UUID=a254c2e4-135e-48ab-a6ba-4b4dd70d5c96 none            swap    sw                0       0
# /mnt/Windows was on /dev/sda1 during installation
UUID=8ADCC429DCC4117D /mnt/Windows                        ntfs    defaults         0       0
# /mnt/Media was on /dev/sda2 during installation
UUID=3FCF5A8B80170633 /mnt/Media                          ntfs    defaults          0       0
/dev/scd0       /media/cdrom0   udf,iso9660 user,noauto                             0       0

Но меня это не совсем устраивает, так как в таком случае разделы прописанные в fstab автоматически монтируются каждый раз при запуске системы, что мне не нужно. Помню что на убунте без редактирования fstab ntfs разделы хорошо монтировались и отмонтировались. Хочу что бы раздел sda1 не монтировался автоматически. Как так сделать на Debian?


Хочу что бы раздел sda1 не монтировался автоматически. Как так сделать на Debian?

удалить эту строку из fstab

при попытке примонтировать их, выдает ошибку

надеюсь от рута монтируешь?

teod0r ★★★★★ ()

Пробовал прописывать логин пользователя в файл /etc/sudoers.tmp - безрезультатно.

Что именно писал? Вообще проблема в нехватке прав, че долфин не предлагает пароль ввести?

J ★★★★ ()

org.freedesktop.Hal

Неужели ещё где-то остался hal? Он реально установлен и запущен, или KDE пытается обратиться к нему, когда его нет? Сейчас вместо него используется udisks для монтирования, надо его установить.

Но меня это не совсем устраивает, так как в таком случае разделы прописанные в fstab автоматически монтируются каждый раз при запуске системы, что мне не нужно.

Хочу что бы раздел sda1 не монтировался автоматически.

Можно в fstab прописать noauto в 4-ую колонку, тогда не будет автоматически монтироваться.

gentoo_root ★★★★★ ()
Ответ на: комментарий от gentoo_root

Кстати, udisks тоже не даст монтировать локальные разделы, поэтому надо добавиться в группу wheel, если polkit настроен, чтобы эта группа была административной.

Пробовал прописывать логин пользователя в файл /etc/sudoers.tmp - безрезультатно.

Прописывать надо в /etc/sudoers с помощью команды visudo, но это не поможет.

gentoo_root

Можно в fstab прописать noauto в 4-ую колонку, тогда не будет автоматически монтироваться.

Нужно будет ещё user дописать в 4-ую колонку, чтобы смог смонтировать потом руками, если не осилишь udisks.

gentoo_root ★★★★★ ()
Ответ на: комментарий от teod0r

Если удалю этот раздел из fstab, то вообще его примонтировать без танцев с бубном в консоли не смогу. Я же хочу в ручную монтировать его и отмонтировать из дельфина, когда мне захочется. Нет, запускаю с правами юзера.

Dnmt ()
Ответ на: комментарий от J

Что что, имя пользователя, наверно. Нет, не предлагает. По моему дольфин запрашивает пароль только от команды: kdesu dbus-launch dolphin

Dnmt ()
Ответ на: комментарий от gentoo_root

Прописывал noauto. С таким параметром раздел не монтируется ни автоматически, ни в ручную. Монтируется только с параметром defaults, автоматически, естественно. Про Hal можно подробнее? Как установить?

Dnmt ()
Ответ на: комментарий от Dnmt

Когда он у меня был, то работало, так что тут я пас.

Deleted ()
Ответ на: комментарий от Dnmt

то есть должно быть так:

Да, только в третьем столбце не ntfs, а ntfs-3g. Монтировать можно будет командой «mount /mnt/Windows».

Про Hal можно подробнее? Как установить?

Он устарел очень давно и уже давно отовсюду выпилен. Странно, что KDE его дёргает, в Дебиане, наверное, его ещё поддерживают. А вообще, нужно устанавливать udisks. На одном моём компе с Дебианом нет хала, всё работает, но там xfce.

gentoo_root ★★★★★ ()
Ответ на: комментарий от teod0r

Пробовал запускать дельфин с правами рута, он при попытке монтировать искомый радел выдает такую же ошибку.

Dnmt ()
Ответ на: комментарий от teod0r

По идее noauto эту возможность должен давать, но мне не дает. И потом, в убунте же у меня наутилус видел эти разделы и монтировал их и отмонтировал, когда мне хочется. Хочу так же в дебиан.

Dnmt ()

Но меня это не совсем устраивает, так как в таком случае разделы прописанные в fstab автоматически монтируются каждый раз при запуске системы, что мне не нужно

Чем это не устраивает?

ymuv ★★★★ ()
Ответ на: комментарий от Dnmt

Что не так?

Пробел после user лишний. Пробел или таб начинает новую колонку, поэтому нужно написать «user,noauto» без пробела после запятой.

gentoo_root ★★★★★ ()
Ответ на: комментарий от Deleted

dep: hal

Тьфу, я и забыл, что у меня не стейбл стоит, а смесь анстейбла и экспериментала, а там уже точно нет хала. Но всё равно странно, что в стейбле есть хал, он же, вроде, релизнулся после того, как я выпилил хал в Генте.

gentoo_root ★★★★★ ()
Ответ на: комментарий от ymuv

А мало ли, вдруг вирус какой вражеский проберется на линукс и потрет системные файлы старушки винды)

Dnmt ()

Поищите в /etc/hal, какие права требуются пользователю, чтобы монтировать через HAL жёсткие диски.

AITap ★★★★★ ()
Ответ на: комментарий от gentoo_root

k3b тогда ещё от него зависел, как минимум. Возможно ещё что-то. Скорее всего из-за подобных вещей.

Deleted ()
Ответ на: комментарий от AITap

Поискал, там по направлению /etc/hal/fdi/policy/ есть только один файлик:

<?xml version="1.0" encoding="UTF-8"?> <!-- -*- SGML -*- -->

<!-- 
  Some examples how to use hal fdi files for system preferences 
  You can either uncomment the examples here or put them in a seperate .fdi
  file.
-->
<deviceinfo version="0.2">
<!-- 
  The following shows how to hint gnome-volume-manager and other programs 
  that honor the storage.automount_enabled_hint to not mount non-removable
  media.
-->
<!--
  <device>
    <match key="storage.hotpluggable" bool="false">
      <match key="storage.removable" bool="false">
        <merge key="storage.automount_enabled_hint" type="bool">false</merge>
      </match>
    </match>
  </device>
-->
</deviceinfo>

Что это все значит?

Dnmt ()
Ответ на: комментарий от Dnmt

Device /dev/sda1 is listed in /etc/fstab. Refusing to mount.

Странно, у меня это не мешало монтированию, когда у меня был хал. Все флешки были прописаны в /etc/fstab.

Добавление в группу wheel не помогает?

Что это все значит?

Попробуй поменять на такое:

<?xml version="1.0" encoding="UTF-8"?> <!-- -*- SGML -*- -->

<deviceinfo version="0.2">
  <device>
    <match key="storage.hotpluggable" bool="false">
      <match key="storage.removable" bool="false">
        <merge key="storage.automount_enabled_hint" type="bool">true</merge>
      </match>
    </match>
  </device>
</deviceinfo>

А мало ли, вдруг вирус какой вражеский проберется на линукс и потрет системные файлы старушки винды)

От этого не спасёт noauto. Если вирус умный, он смонтирует то, что сможет. Или оно уже будет смонтировано.

gentoo_root ★★★★★ ()
Ответ на: комментарий от gentoo_root

А как добавить в группу wheel? Редактирование не помогло, дельфин при попытке обращения выдает ту же ошибку, что и на скринах выше.

Dnmt ()
Ответ на: комментарий от Dnmt

Редактирование не помогло, дельфин при попытке обращения выдает ту же ошибку, что и на скринах выше.

А если отредактировать, а потом убрать из /etc/fstab строку с вендовым разделом?

А как добавить в группу wheel?

От рута:

gpasswd -a имя_пользователя wheel

gentoo_root ★★★★★ ()
Ответ на: комментарий от gentoo_root

А если отредактировать, а потом убрать из /etc/fstab строку с вендовым разделом?

А я так и делал.

valrav@Note:~$ gpasswd -a valrav wheel
gpasswd: группа wheel не существует в /etc/group
valrav@Note:~$ 

Dnmt ()
Ответ на: комментарий от Dnmt

А я так и делал.

дельфин при попытке обращения выдает ту же ошибку, что и на скринах выше.

Из /etc/fstab убрал, а hal говорит, что устройство есть в /etc/fstab? Странно. А если перезапустить hal или перезагрузиться?

gentoo_root ★★★★★ ()
Ответ на: комментарий от gentoo_root

Не совсем. Я имел ввиду что дельфин выдает эту ошибку:

Прооизошла ошибка при обращении к Media, ответ системы: org.freedesktop.Hal.Device.Volume.PermissionDenied: Refusing to mount device /dev/sda2 for uid=1000
Кстати, дельфин запущенный из под рута монтирует ntfs раздел и отмонтирует. Как заставить его делать это из под юзера?

Dnmt ()
Ответ на: комментарий от Dnmt

Если с правами юзера и не автоматически - пропиши в опции раздела user и noauto

Quasar ★★★★★ ()
Ответ на: комментарий от Dnmt

Попробуй от юзера через pmount примонтировать.

pmount /dev/sda2 в твоём случае

Quasar ★★★★★ ()

Посмотри файлы /etc/groups и /etc/users - может, у пользователя другой UID, а у группы - другой GID? А по этой хорошей ссылке я настроил NTFS даже в Mageia Linux (не хотел запускать exe-файл в Wine): http://wiki.debian.org/NTFS/

ZenitharChampion ★★★★★ ()
Ответ на: комментарий от Dnmt

Как заставить его делать это из под юзера?

Советы отсюда не помогают?

Нужно убедиться, что ConsoleKit запущен, сессия в нём регистрируется. И попробовать добавить в /etc/PolicyKit/PolicyKit.conf:

<match group="plugdev">
        <match action="org.freedesktop.hal.storage.*">
                <return result="yes" />
        </match>
        <match action="hal-storage-mount-fixed-extra-options">
                <return result="yes" />
        </match>
        <match action="hal-storage-mount-removable-extra-options">
                <return result="yes" />
        </match>
</match>

Это старый формат конфигов. Если есть каталог /etc/polkit-1, то могу переписать под более новый формат, потому что старый не сработает. Если сработает, то можно попробовать удалить последние 2 подсекции, скорее всего, они не нужны.

gentoo_root ★★★★★ ()
Ответ на: комментарий от ZenitharChampion

В файле /etc/groups вот это:

root:x:0:
daemon:x:1:
bin:x:2:
sys:x:3:
adm:x:4:
tty:x:5:
disk:x:6:
lp:x:7:
mail:x:8:
news:x:9:
uucp:x:10:
man:x:12:
proxy:x:13:
kmem:x:15:
dialout:x:20:
fax:x:21:
voice:x:22:
cdrom:x:24:valrav
floppy:x:25:valrav
tape:x:26:
sudo:x:27:
audio:x:29:valrav
dip:x:30:valrav
www-data:x:33:
backup:x:34:
operator:x:37:
list:x:38:
irc:x:39:
src:x:40:
gnats:x:41:
shadow:x:42:
utmp:x:43:
video:x:44:valrav
sasl:x:45:
plugdev:x:46:valrav
staff:x:50:
games:x:60:
users:x:100:
nogroup:x:65534:
libuuid:x:101:
crontab:x:102:
Debian-exim:x:103:
mlocate:x:104:
ssh:x:105:
utempter:x:106:
messagebus:x:107:
avahi-autoipd:x:108:
avahi:x:109:
netdev:x:110:valrav
bluetooth:x:111:valrav
lpadmin:x:112:
ssl-cert:x:113:
fuse:x:114:
haldaemon:x:115:
powerdev:x:116:valrav
scanner:x:117:saned,valrav
saned:x:118:
valrav:x:1000:

А файла /etc/users я не нашел.

Dnmt ()
Ответ на: комментарий от Dnmt

Советы оттуда для арча, а у меня дебиан.

И что?

Файла по адресу /etc/PolicyKit/PolicyKit.conf я вообще не нашел.

Тогда в /etc/polkit-1/localauthority/50-local.d/hal-mount.pkla:

[Permit mount for plugdev group]
Identity=unix-group:plugdev
Action=org.freedesktop.hal.storage.*
ResultActive=yes

Если не сработает, ещё можно попробовать поменять ResultActive на ResultAny.

gentoo_root ★★★★★ ()
Ответ на: комментарий от gentoo_root

Файла по адресу /etc/polkit-1/localauthority/50-local.d/hal-mount.pkla я вообще не нашел. Создал таковой, не помогло.

В папке polkit-1 есть следующие файлы: /etc/polkit-1/localauthority.conf.d/50-localauthori.conf:

# Configuration file for the PolicyKit Local Authority.
#
# DO NOT EDIT THIS FILE, it will be overwritten on update.
#
# See the pklocalauthority(8) man page for more information
# about configuring the Local Authority.
#

[Configuration]
AdminIdentities=unix-user:0
Так же /etc/polkit-1/localauthority.conf.d/51-debian-sudo.conf:
[Configuration]
AdminIdentities=unix-group:sudo
B /etc/polkit-1/nullbackend.conf.d/50-nullbackend.conf:
#
# Configuration file for the PolicyKit null backend.
#
# DO NOT EDIT THIS FILE, it will be overwritten on update.
#
# To change configuration, create another file in this directory with
# a filename that is sorted after the 50-nullback.conf and make
# sure it has the .conf extension.
#
# Only a single configuration item, Priority, is supported.
#
# See the PolicyKit documentation for more information about PolicyKit.
#

[Configuration]
Priority=-10
А в папке /etc/polkit-1/localauthority/ не нашел ни одного конфига.

Dnmt ()
Ответ на: комментарий от Dnmt

Файла по адресу /etc/polkit-1/localauthority/50-local.d/hal-mount.pkla я вообще не нашел. Создал таковой

Конечно, его там не было. Действительно, нужно создать.

не помогло.

А если так?

[Permit mount for plugdev group]
Identity=unix-group:plugdev
Action=org.freedesktop.Hal.Device.Storage.*;org.freedesktop.Hal.Device.Volume.*
ResultAny=yes
gentoo_root ★★★★★ ()
Ответ на: комментарий от gentoo_root

Тоже не помогло. Все та же ошибка:

Прооизошла ошибка при обращении к Media, ответ системы: org.freedesktop.Hal.Device.Volume.PermissionDenied: Refusing to mount device /dev/sda2 for uid=1000

Dnmt ()
Ответ на: комментарий от Dnmt

Монтируй пока вручную:

$ su
Password:
# mkdir /1
# mount -t ntfs-3g /dev/sda2 -o rw,uid=1000,gid=1000,dmask=0002,fmask=0003 /1

Когда поработаешь:

# umount /1

Или выключаться прямо так.

ZenitharChampion ★★★★★ ()
Ответ на: комментарий от ZenitharChampion

И опять пришли к консоли...

В убунте же можно монтировать и отмонтировать разделы вручную, а значит и на дебиане можно. Тем более что дельфин из под рута монтирует их. Значит нужно прав простому юзеру добавить. Как это сделать?

Dnmt ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.