LINUX.ORG.RU

cat /proc/mounts > /etc/mtab ?

aol ★★★★★ ()
Ответ на: комментарий от N1ghtmare
If you have a separate /boot partition and plan to install grub2, be sure to mount only the root partition before chroot'ing, and not the boot partition as well. Mount /boot later, once inside chroot. If you mount the /boot partition before chrooting, grub-mkconfig will not detect /boot as a separate partition and will assume /boot and root are on the same partition. 

?

AlexCones ★★★ ()
Ответ на: комментарий от ymuv

Да пробовал я, он при загрузке опять на device.map ругается и ни в какую

N1ghtmare ★★ ()
Ответ на: комментарий от AlexCones

Монтирую бут тоже из-под чрута, все равно говорит, проверьте device.map. Его в /boot/grub2 нету, grub2-install не создает его, в mtab бут есть

N1ghtmare ★★ ()
Ответ на: комментарий от N1ghtmare

$ cat /boot/grub/device.map
(hd0) /dev/sda

А что у тебя в этом файле?

imul ★★★★★ ()
Ответ на: комментарий от N1ghtmare

проверьте device.map. Его в /boot/grub2 нету, grub2-install не создает его

Создай руками, там содержимое тривиально.

imul ★★★★★ ()
Ответ на: комментарий от ananas
mount -o bind /dev /mnt/dev
mount -t proc none /mnt/proc

откатил граб, граб-инсталл создал device.map, но mkconfig конфиг все равно не генерирует. с конфигом в ручную не грузится, говорит мол no such device, перепроверил 10 раз, написано правильно

N1ghtmare ★★ ()
Ответ на: комментарий от AlexCones

И чего вас всех потянуло на grub2 под gentoo? Есть же родной незамасканный grub.

Старый граб нифига не умеет. Ни EFI, ни GPT, ни LVM, ни btrfs и т.д.

gentoo_root ★★★★★ ()
Ответ на: комментарий от ananas

Смонтировал /sys, сделал на всякий revdep-rebuild, он мне пересобрал udisks и после этого граб сделал конфиг. ОС загрузилась

N1ghtmare ★★ ()

У меня тоже была такая же (или похожая) проблема, но я не помню, как решал. ЕМНИП, граб ещё и не мог определить тип файловой системы FAT, которая в /boot/efi. Если используете бету граба 2.00, то лучше откатить на что-то постарее, хотя бы на 2.00_beta0, потому что со всеми бетами у меня были проблемы (там ещё и опечатка в grub-install есть, связанная с EFI).

gentoo_root ★★★★★ ()
Ответ на: комментарий от N1ghtmare

а всё дело в хэндбуке, который не учит монтировать /sys

yurikoles ★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.