LINUX.ORG.RU

опять Xorg


0

0

Xorg 6.8.1 дистриб Debian. все вроде сделал как было написано в какой-то статье в инете... но когда набираю startx - то екран становится черный и все... убиваю иксы - и вот - монитор типа подсел... все консоли стали такими мутными!!! еще раз стартикс - и вообще на екране ничего почти различить невозможно!! удалось просмотреть xorg.log- ошибок загрузки нету! видеокарта GF4MX дрова 6111. Если можна то киньте сюда свой ДЕЙСТВИТЕЛЬНО рабочий конфиг xorg.conf!!! буду очень признателен!

Re: опять Xorg

Лучше кинь сюда свой. Про снижение яркости в первый раз слышу за много лет.

jackill ★★★★★ ()
Ответ на: Re: опять Xorg от jackill

Re: Re: опять Xorg

Section "Files"
	FontPath	"unix/:7100"			# local font server
	# if the local font server has problems, we can fall back on these
	FontPath	"/usr/lib/X11/fonts/misc"
	FontPath	"/usr/lib/X11/fonts/cyrillic"
	FontPath	"/usr/lib/X11/fonts/100dpi/:unscaled"
	FontPath	"/usr/lib/X11/fonts/75dpi/:unscaled"
	FontPath	"/usr/lib/X11/fonts/Type1"
	FontPath	"/usr/lib/X11/fonts/CID"
	FontPath	"/usr/lib/X11/fonts/Speedo"
	FontPath	"/usr/lib/X11/fonts/100dpi"
	FontPath	"/usr/lib/X11/fonts/75dpi"
EndSection
Section "Module"
	Load	"extmod"
	Load	"freetype"
	Load	"glx"
	Load	"type1"
	Load    "dbe"
	Load    "v4l"
EndSection
Section "InputDevice"
	Identifier	"Generic Keyboard"
	Driver		"kbd"
	Option		"XkbRules" "xorg"
	Option		"AutoRepeat" "500 30"
	Option		"CoreKeyboard"
	Option		"XkbModel"	"pc104"
	Option		"XkbLayout"	"us,ru,ua"
	Option		"XkbVariant"	",winkeys"
	Option		"XkbOptions"	"grp:ctrl_shift_toggle,grp_led:scroll"

EndSection
Section "InputDevice"
	Identifier	"Configured Mouse"
	Driver		"mouse"
	Option		"CorePointer"
	Option		"Device"		"/dev/psaux"
	Option		"Protocol"		"ExplorerPS/2"
	Option		"ZAxisMapping"		"4 5"
EndSection

#Section "Extensions"
#	Option		"Composite" "Enable"
#EndSection

Section "InputDevice"
	Identifier	"Generic Mouse"
	Driver		"mouse"
	Option		"SendCoreEvents"	"true"
	Option		"Device"		"/dev/input/mice"
	Option		"Protocol"		"ImPS/2"
	Option		"ZAxisMapping"		"4 5"
EndSection
Section "Device"
	Identifier	"NVIDIA Corporation NV18 [GeForce4 MX 440 AGP 8x]"
	Driver 		"nvidia"
	Option		"DPMS"
#	Option		"RenderAccel" "true"
EndSection
Section "Monitor"
	Identifier	"Generic Monitor"
	HorizSync	30-60
	VertRefresh	50-75
	Option		"DPMS"
EndSection
Section "Screen"
	Identifier	"Default Screen"
	Device		"NVIDIA Corporation NV18 [GeForce4 MX 440 AGP 8x]"
	Monitor		"Generic Monitor"
	DefaultDepth	24
	SubSection "Display"
		Depth		1
		Modes		"1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		4
		Modes		"1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		8
		Modes		"1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		15
		Modes		"1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		16
		Modes		"1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		24
		Modes		"1024x768" "800x600" "640x480"
	EndSubSection
EndSection
Section "ServerLayout"
	Identifier	"Default Layout"
	Screen		"Default Screen"
	InputDevice	"Generic Keyboard"
	InputDevice	"Configured Mouse"
	InputDevice	"Generic Mouse"
EndSection
Section "DRI"
	Mode	0666
EndSection

baltazor ()
Ответ на: Re: Re: опять Xorg от baltazor

Re: Re: Re: опять Xorg

По большой и светлой идее все нормально.

Единственное, раз у тебя xorg (и если он >=6.8.0), убери    
Load    "type1"
Оно не нужно. Type1 теперь поддерживается во freetype. Модуль type1 deprecated. Модули выглядят так:

Section "Module"
        Load  "extmod"
        Load  "glx"
        Load  "record"
        Load  "xtrap"
        Load  "v4l" #У меня есть тюнер, тебе, наверно, не нужно
        Load  "freetype"
    SubSection  "extmod"
           Option  "omit xfree86-dga"
    EndSubSection
EndSection


FontPath        "unix/:7100"
тоже не нужно. Ты же не раздаешь шрифты по сети другим машинам, правда?

Рекомендую сначала в список поставить папки с ttf, потом с киррилическими шрифтами, а потом со всеми остальными, дабы в
будущем избежать проблем.

Вот раздел устройств. Раньше у меня была карточка как у тебя, кстати.

Section "Device"
        Option  "NoLogo"        "True"
        Option  "RenderAccel"   "True"
        Option  "NvAGP" "2"
        Option  "ConnectedMonitor"      "CRT"
        Identifier  "Videocard0"
        Driver      "nvidia"
        VendorName  "Nvidia"
        BoardName   "NVIDIA GeForce 5600 XT"
EndSection

Монитор... У меня еще указан размер экрана, поэтому весь раздел выглядит так:

Section "Monitor"
        Identifier   "Monitor0"
        VendorName   "Monitor Vendor"
        ModelName    "CTX5378"
        DisplaySize  330        250
        HorizSync    30.0 - 72.0
        VertRefresh  50.0 - 130.0
        ModeLine     "1152x864" 108.0 1152 1200 1328 1528 864 865 868 904 +hsync +vsync
        ModeLine     "1024x768" 94.5 1024 1076 1172 1372 768 769 772 812 +hsync +vsync
        ModeLine     "800x600" 56.3 800 832 896 1032 600 601 604 619 +hsync +vsync
        ModeLine     "640x480" 36.0 640 712 768 808 480 485 488 525 -hsync -vsync
        ModeLine     "400x300" 28.1 400 412 444 508 300 304 306 327 +hsync +vsync doublescan
        ModeLine     "320x200" 15.8 320 360 392 396 200 204 206 222 -hsync +vsync doublescan
        Option      "dpms"
EndSection

Модлайны прописаны для того, чтобы некоторые старые игрушки работали не на 60Гц.

И в разделе dri прописана группа:

Section "DRI"
        Group        0
        Mode         0666
EndSection


Слушай, а что будет, если ты просто наберешь в командной строке 
X
?
По идее ты должен перейти в графический режим и должен появиться курсор мыши (крестообразный).

jackill ★★★★★ ()

Re: опять Xorg

К слову: для включения прозрачности в extensions добавь Option "RENDER".

drish ★★ ()
Ответ на: Re: опять Xorg от drish

Re: Re: опять Xorg

У него эта приблуда, как и RenderAccel, закомментирована.

jackill ★★★★★ ()
Ответ на: Re: Re: опять Xorg от jackill

Re: Re: Re: опять Xorg

у меня пытается загрузиться Xorg лишь в том случае если я напишу
export LD_LIBRARY_PATH=/usr/local/X11R6.8/lib
    export PATH=/usr/local/X11R6.8/bin:$PATH 
если же єтого не сделаю грузит XFree.
как сделать чтоб по-умолчанию грузился xorg?? куда нада дописать єти строки чтоб они при старте системи сами выполнялись.???
или есть другой способ старта?

baltazor ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.