LINUX.ORG.RU

Не обновляется portage(не дерево пакетов) в Gentoo


0

1

Здравствуйте. В Gentoo я совсем недавно. Сталкнулся с одной проблемой:

1) Обновляю дерево «портежей» {emerge --sync}

2) пытаюсь обновить сам portage {emerge portage}

и он начинает ругаться:

# emerge portage -av

These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds to satisfy «>=dev-db/sqlite-3.3.8:3[extensions]». (dependency required by «dev-lang/python-2.7.1-r1» [ebuild]) (dependency required by «sys-apps/portage-2.1.9.50» [ebuild]) (dependency required by «portage» [argument])

не могу понять как это исправить... прошу помощи.

текущая версия portage - Portage 2.1.6.7

Ответ на: комментарий от tn1

мне к сожалению нужен portage...а насчет информативности...там совершенно непонятно, что делать с sqlite-3.3.8:3[extensions] (и вообще, что это за версия sqlite ?)

antonre ()
Ответ на: комментарий от antonre

У вас в portage есть флаг --python3? Если есть, включайте его и не парьтесь. У вас ведь установлен python 3.1 или 3.2?

Если же вы по каким-то причинам хотите именно с вторым питоном и обязательно с sql, то не помешало бы увидеть вывод:

equery u portage sqlite =python-2.7.1-r1

delete83 ★★ ()
Ответ на: комментарий от antonre

Флаг, с которым необходимо собрать пакет, чтоб удовлетворить зависимости. Иногда и такое требуется.

Выполните команду, как вас просили:

ls -l /usr/portage/dev-db/sqlite

И запостите сюда вывод. Мы все посмотрим, что же там есть :)

delete83 ★★ ()
Ответ на: комментарий от delete83

вывод команды:

# ls -l /usr/portage/dev-db/sqlite total 104 -rw-r--r-- 1 root root 51280 May 20 00:31 ChangeLog -rw-r--r-- 1 root root 5941 May 20 00:31 Manifest drwxr-xr-x 2 portage portage 4096 Apr 12 21:01 files -rw-r--r-- 1 root root 1011 Sep 11 2010 metadata.xml -rw-r--r-- 1 root root 2693 Jun 26 2010 sqlite-2.8.16-r4.ebuild -rw-r--r-- 1 root root 4532 Mar 22 23:01 sqlite-3.7.5.ebuild -rw-r--r-- 1 root root 4607 Apr 18 22:45 sqlite-3.7.6.2.ebuild -rw-r--r-- 1 root root 4607 May 20 00:11 sqlite-3.7.6.3.ebuild -rw-r--r-- 1 root root 4502 Apr 12 20:46 sqlite-3.7.6.ebuild

antonre ()
Ответ на: комментарий от delete83

вывод команды:

# equery u portage sqlite =python-2.7.1-r1 [ Searching for packages matching =python-2.7.1-r1... ] [ Colour Code : set unset ] [ Legend : Left column (U) - USE flags from make.conf ] [ : Right column (I) - USE flags packages was installed with ] [ Found these USE variables for dev-lang/python-2.7.1-r1 ] U I - + berkdb : Adds support for sys-libs/db (Berkeley DB for MySQL) - - build : !!internal use only!! DO NOT SET THIS FLAG YOURSELF!, used for creating build images and the first half of bootstrapping [make stage1] - - doc : Adds extra documentation (API, Javadoc, etc) - - elibc_uclibc : <unknown> - - examples : Install examples, usually source code + + gdbm : Adds support for sys-libs/gdbm (GNU database libraries) - - ipv6 : Adds support for IP version 6 + + ncurses : Adds ncurses support (console display library) + + readline : Enables support for libreadline, a GNU line-editing library that almost everyone wants + + sqlite : Adds support for sqlite - embedded sql database + + ssl : Adds support for Secure Socket Layer connections - - threads : Adds threads support for various packages. Usually pthreads - - tk : Adds support for Tk GUI toolkit + - wide-unicode : Enable wide Unicode implementation which uses 4-byte Unicode characters. Switching of this USE flag changes ABI of Python and requires reinstallation of many Python modules. (DON'T DISABLE THIS UNLESS YOU KNOW WHAT YOU'RE DOING) - - wininst : Install Windows executables required to create an executable installer for MS Windows. + + xml : Add support for XML files

antonre ()
Ответ на: комментарий от delete83

тот же результат:

~# USE=«extensions» emerge -av portage

These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds to satisfy «>=dev-db/sqlite-3.3.8:3[extensions]». (dependency required by «dev-lang/python-2.7.1-r1» [ebuild]) (dependency required by «sys-apps/portage-2.1.9.50» [ebuild]) (dependency required by «portage» [argument])

antonre ()
Ответ на: комментарий от backbone

на emerge -uDNav1 portage :

!!! All ebuilds that could satisfy «dev-vcs/subversion[-dso]» have been masked. !!! One of the following masked packages is required to complete your request: - dev-vcs/subversion-1.6.16 (masked by: EAPI 3, invalid: SLOT is undefined) - dev-vcs/subversion-1.6.15 (masked by: EAPI 3, invalid: SLOT is undefined)

The current version of portage supports EAPI '2'. You must upgrade to a newer version of portage before EAPI masked packages can be installed.

For more information, see the MASKED PACKAGES section in the emerge man page or refer to the Gentoo Handbook. (dependency required by «dev-vcs/git-1.6.4.5» [ebuild]) (dependency required by «sys-devel/gettext-0.18.1.1-r1» [ebuild]) (dependency required by «sys-apps/attr-2.4.44» [ebuild]) (dependency required by «sys-apps/acl-2.2.49» [ebuild]) (dependency required by «sys-apps/coreutils-8.5» [ebuild]) (dependency required by «sys-apps/portage-2.1.9.50» [ebuild]) (dependency required by «portage» [argument])

на emerge -uDNav world

emerge -uDNav world

These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! All ebuilds that could satisfy «dev-vcs/subversion[-dso]» have been masked. !!! One of the following masked packages is required to complete your request: - dev-vcs/subversion-1.6.16 (masked by: EAPI 3, invalid: SLOT is undefined) - dev-vcs/subversion-1.6.15 (masked by: EAPI 3, invalid: SLOT is undefined)

The current version of portage supports EAPI '2'. You must upgrade to a newer version of portage before EAPI masked packages can be installed.

For more information, see the MASKED PACKAGES section in the emerge man page or refer to the Gentoo Handbook. (dependency required by «dev-vcs/git-1.6.4.5» [ebuild]) (dependency required by «sys-devel/gettext-0.18.1.1-r1» [ebuild]) (dependency required by «sys-devel/gcc-4.4.5» [ebuild]) (dependency required by «world» [argument])

antonre ()
Ответ на: комментарий от antonre

Я знаю, что вам поможет.

USE="-sqlite" emerge -av portage

К тому времени, когда вам захочется включить эту опцию в portage, вы уже поставите себе paludis или хотя бы eix и необходимость в ней отпадет сама собой. Что у вас там с sqlite такое непонятное, вот что интересно.

На всякий случай, покажите вывод команды

equery y sqlite

delete83 ★★ ()
Ответ на: комментарий от delete83

на USE="-sqlite" emerge -av portage: выводит много всего:

USE="-sqlite" emerge -av portage

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N    ] app-arch/xz-utils-5.0.1  USE="nls threads -static-libs" 1,208 kB
[ebuild  N    ] dev-libs/libffi-3.0.9-r2  USE="-debug -static-libs -test" 715 kB
[ebuild     U ] sys-devel/binutils-2.20.1-r1 [2.18-r1] USE="nls -multislot -multitarget -test -vanilla" 17,106 kB
[ebuild     U ] sys-devel/automake-wrapper-4 [3-r1] 0 kB
[ebuild     U ] sys-devel/autoconf-wrapper-10-r1 [4-r3] 0 kB
[ebuild     U ] sys-devel/autoconf-2.65-r1 [2.61-r2] USE="-emacs" 1,302 kB
[ebuild     U ] sys-apps/sandbox-2.4 [1.2.18.1-r2] USE="(-multilib)" 337 kB
[ebuild  N    ] virtual/libffi-0  0 kB
[ebuild  NS   ] sys-devel/automake-1.11.1 [1.7.9-r1, 1.9.6-r2, 1.10.1] 1,042 kB
[ebuild  NS   ] sys-devel/libtool-2.2.10 [1.5.24] USE="-vanilla" 771 kB
[ebuild     U ] app-admin/eselect-1.2.15 [1.0.11-r1] USE="bash-completion -doc (-vim-syntax%*)" 166 kB
[ebuild     U ] app-admin/eselect-python-20100321 [20090606] 6 kB
[uninstall    ] app-admin/eselect-news-20080320
[blocks b     ] app-admin/eselect-news ("app-admin/eselect-news" is blocking app-admin/eselect-1.2.15)
[ebuild  NS   ] dev-lang/python-2.7.1-r1 [2.4.6, 2.5.4-r3] USE="gdbm ncurses readline ssl threads (wide-unicode) xml -berkdb -build -doc -examples -ipv6 -sqlite -tk -wininst" 11,461 kB
[ebuild     U ] sys-apps/portage-2.1.9.50 [2.1.6.7] USE="(ipc%*) -build -doc -epydoc -python2% -python3% (-selinux)" LINGUAS="-pl" 767 kB
*** Portage will stop merging at this point and reload itself,
    then resume the merge.
[blocks B     ] <sys-apps/portage-2.1.9 ("<sys-apps/portage-2.1.9" is blocking dev-lang/python-2.7.1-r1)

Total: 14 packages (8 upgrades, 3 new, 3 in new slots, 1 uninstall), Size of downloads: 34,877 kB
Conflict: 2 blocks (1 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  ('ebuild', '/', 'dev-lang/python-2.7.1-r1', 'merge') pulled in by
    dev-lang/python:2.7 required by ('ebuild', '/', 'sys-apps/portage-2.1.9.50', 'merge')


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked

на equery y sqlite:

equery y sqlite
!!! unknown global option y, reusing as local option
!!! unknown global option sqlite, reusing as local option
!!! No command or unknown command given
Usage: equery <global-opts> command <local-opts>
where <global-opts> is one of
 -q, --quiet   - minimal output
 -C, --nocolor - turn off colours
 -h, --help    - this help screen
 -V, --version - display version info
 -N, --no-pipe - turn off pipe detection
where command(short) is one of
 belongs(b) <local-opts> files... - list all packages owning files...
 changes(c)  - not implemented yet
 check(k) pkgspec - check MD5sums and timestamps of pkgspec's files
 depends(d) <local-opts> pkgspec - list all direct dependencies matching pkgspec
 depgraph(g) <local-opts> pkgspec - display a dependency tree for pkgspec
 files(f) <local-opts> pkgspec - list files owned by pkgspec
 glsa(a)  - not implemented yet
 hasuse(h) <local-opts> useflag - list all packages with useflag
 list(l) <local-opts> pkgspec - list all packages matching pkgspec
 size(s) <local-opts> pkgspec - print size of files contained in package pkgspec
 stats(t)  - not implemented yet
 uses(u) <local-opts> pkgspec - display USE flags for pkgspec
 which(w) pkgspec - print full path to ebuild for package pkgspec
antonre ()
Ответ на: комментарий от antonre

> there are no ebuilds to satisfy «>=dev-db/sqlite-3.3.8:3[extensions]»

Тебе говорят на чистом английском, что в дереве нет ебилда для скюлайта, у которого есть юз-флаг экстеншын-с.
Поэтому собирай портеж без зависимости от скюлайт.
Не знаю, как в sys-apps/portage-2.1.9.50, но в более новых ебилдах sqlite нужен для какой-то левой документации. Посмотри в ебилде, какой юз-флаг требует sqlite и собери portage с выключенным флагом.

Lumi ★★★★★ ()
Ответ на: комментарий от Lumi

sqlite ускоряет поиск через emerge

в данной ситуации старый python не даёт обновиться portage-у, а старый portage не даёт обновиться python.

не знаю, может USE="-extensions -sqlite" emerge -1 python portage
потом python-updater

backbone ★★★★★ ()
Ответ на: комментарий от antonre

собери эти пакеты руками

emerge =app-arch/xz-utils-5.0.1
emerge =dev-libs/libffi-3.0.9-r2
emerge =sys-devel/binutils-2.20.1-r1
emerge =sys-devel/automake-wrapper-4
emerge =sys-devel/autoconf-wrapper-10-r1
emerge =sys-devel/autoconf-2.65-r1
emerge =sys-apps/sandbox-2.4
emerge =virtual/libffi-0
emerge =sys-devel/automake-1.11.1
emerge =sys-devel/libtool-2.2.10
emerge =app-admin/eselect-1.2.15
emerge =app-admin/eselect-python-20100321
emerge =dev-lang/python-2.7.1-r1

А потом покажи что хочет

emerge -pv =sys-apps/portage-2.1.9.50

В принципе можно будет сразу

emerge -O =sys-apps/portage-2.1.9.50

Хорошо ещё собирать с -b
Это позволит при случае быстро сносить и ставить пакеты и в случае чего быстро восстанавливать систему после бесчеловечных экспериментов с ней.

Lumi ★★★★★ ()
Ответ на: комментарий от delete83

eselect python list

# eselect python list
Available python interpreters:
  [1]   python2.4
  [2]   python2.5 *

USE="-sqlite python2" emerge -av portage


These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N    ] app-arch/xz-utils-5.0.1  USE="nls threads -static-libs" 1,208 kB
[ebuild  N    ] dev-libs/libffi-3.0.9-r2  USE="-debug -static-libs -test" 715 kB
[ebuild     U ] sys-devel/binutils-2.20.1-r1 [2.18-r1] USE="nls -multislot -multitarget -test -vanilla" 17,106 kB
[ebuild     U ] sys-devel/automake-wrapper-4 [3-r1] 0 kB
[ebuild     U ] sys-devel/autoconf-wrapper-10-r1 [4-r3] 0 kB
[ebuild     U ] sys-devel/autoconf-2.65-r1 [2.61-r2] USE="-emacs" 1,302 kB
[ebuild     U ] sys-apps/sandbox-2.4 [1.2.18.1-r2] USE="(-multilib)" 337 kB
[ebuild  N    ] virtual/libffi-0  0 kB
[ebuild  NS   ] sys-devel/automake-1.11.1 [1.7.9-r1, 1.9.6-r2, 1.10.1] 1,042 kB
[ebuild  NS   ] sys-devel/libtool-2.2.10 [1.5.24] USE="-vanilla" 771 kB
[ebuild     U ] app-admin/eselect-1.2.15 [1.0.11-r1] USE="bash-completion -doc (-vim-syntax%*)" 166 kB
[ebuild     U ] app-admin/eselect-python-20100321 [20090606] 6 kB
[uninstall    ] app-admin/eselect-news-20080320
[blocks b     ] app-admin/eselect-news ("app-admin/eselect-news" is blocking app-admin/eselect-1.2.15)
[ebuild  NS   ] dev-lang/python-2.7.1-r1 [2.4.6, 2.5.4-r3] USE="gdbm ncurses readline ssl threads (wide-unicode) xml -berkdb -build -doc -examples -ipv6 -sqlite -tk -wininst" 11,461 kB
[ebuild     U ] sys-apps/portage-2.1.9.50 [2.1.6.7] USE="(ipc%*) python2%* -build -doc -epydoc -python3% (-selinux)" LINGUAS="-pl" 767 kB
*** Portage will stop merging at this point and reload itself,
    then resume the merge.
[blocks B     ] <sys-apps/portage-2.1.9 ("<sys-apps/portage-2.1.9" is blocking dev-lang/python-2.7.1-r1)

Total: 14 packages (8 upgrades, 3 new, 3 in new slots, 1 uninstall), Size of downloads: 34,877 kB
Conflict: 2 blocks (1 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  ('ebuild', '/', 'dev-lang/python-2.7.1-r1', 'merge') pulled in by
    dev-lang/python:2.7 required by ('ebuild', '/', 'sys-apps/portage-2.1.9.50', 'merge')


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked

antonre ()
Ответ на: комментарий от backbone

Не так все просто. После установки питона еще придется eselect сделать, а потом уже python-updater, и не факт, что все корректно с первого раза обновится. А вот насчет -1 это хорошая идея.

Попробовать обновиться командой: USE="-sqlite python2" emerge -av1 portage

delete83 ★★ ()
Ответ на: комментарий от backbone

> sqlite ускоряет поиск через emerge

Всё равно там поиск черепаший, его и скюлайт не спасает.

в данной ситуации старый python не даёт обновиться portage-у, а старый portage не даёт обновиться python.


Эту ситуацию вполне хорошо разруливать через ключ -O

Lumi ★★★★★ ()
Ответ на: комментарий от antonre

Попробуй сразу как выше посоветовали отключить юз-флаг. А насчёт необходимости питона 2.7 это дурь какая-то. У меня портеж 2.2.2 нормально с 2.6 работал.

USE=-sqlite emerge -O =sys-apps/portage-2.1.9.50



Lumi ★★★★★ ()
Ответ на: комментарий от antonre

Это отключение зависимостей при установке пакетов. Соответственно, могут быть проблемы.

delete83 ★★ ()
Ответ на: комментарий от antonre

> простите, а можно поподробней насчет ключа -O ?

Он позволяет собирать пакет без учёта зависимостей. Иногда хорошо выручает на таких петлях. Но, успешная сборка пакета не гарантирована.

Lumi ★★★★★ ()
Ответ на: комментарий от Lumi

А насчёт необходимости питона 2.7 это дурь какая-то. У меня портеж 2.2.2 нормально с 2.6 работал.

Он и требует все лишь 2.6, но раз есть 2.7, то соответственно его и пытается ставить.

delete83 ★★ ()
Ответ на: комментарий от Lumi

попробовал..начал ставиться, но не поставился:



>>> Verifying ebuild manifests

>>> Emerging (1 of 1) sys-apps/portage-2.1.9.50
 * portage-2.1.9.50.tar.bz2 RMD160 SHA1 SHA256 size ;-) ...              [ ok ]
 * checking ebuild checksums ;-) ...                                     [ ok ]
 * checking auxfile checksums ;-) ...                                    [ ok ]
 * checking miscfile checksums ;-) ...                                   [ ok ]
 * Attempting to select a compatible default python interpreter
 * Unable to select a compatible default python interpreter!
 *
 * ERROR: sys-apps/portage-2.1.9.50 failed.
 * Call stack:
 *                 ebuild.sh, line   49:  Called pkg_setup
 *   portage-2.1.9.50.ebuild, line  106:  Called die
 * The specific snippet of code:
 *                      die "This version of portage requires at least python-2.6 to be selected as the default python interpreter (see `eselect python --help`)."
 *  The die message:
 *   This version of portage requires at least python-2.6 to be selected as the default python interpreter (see `eselect python --help`).
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/sys-apps/portage-2.1.9.50/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/sys-apps/portage-2.1.9.50/temp/die.env'.
 *

>>> Failed to emerge sys-apps/portage-2.1.9.50, Log file:

>>>  '/var/tmp/portage/sys-apps/portage-2.1.9.50/temp/build.log'

 * Messages for package sys-apps/portage-2.1.9.50:

 * Attempting to select a compatible default python interpreter
 * Unable to select a compatible default python interpreter!
 *
 * ERROR: sys-apps/portage-2.1.9.50 failed.
 * Call stack:
 *                 ebuild.sh, line   49:  Called pkg_setup
 *   portage-2.1.9.50.ebuild, line  106:  Called die
 * The specific snippet of code:
 *                      die "This version of portage requires at least python-2.6 to be selected as the default python interpreter (see `eselect python --help`)."
 *  The die message:
 *   This version of portage requires at least python-2.6 to be selected as the default python interpreter (see `eselect python --help`).
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/sys-apps/portage-2.1.9.50/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/sys-apps/portage-2.1.9.50/temp/die.env'.
 *


antonre ()
Ответ на: комментарий от delete83

Из обязательных зависимостей там не установлена только xz, что на общий процесс не повлияет. А портеж такой древней версии на 2.6 питоне будет работать без проблем.

Lumi ★★★★★ ()
Ответ на: комментарий от Lumi

Хорошо. Только когда у него emerge станет падать с жалобами на python, ты же первый предложишь ему систему переустановить...

delete83 ★★ ()

Можно ещё попробовать обновить portage до промежуточной, а не последней версии (возможно, поможет). И да, вручную ничего не замаскировано/размаскировано?

В Gentoo я совсем недавно.

Если система установлена недавно, то, возможно, проще будет переустановить совсем, но из более свежего stage.

И ещё можно попробовать emerge с опцией -k.

gentoo_root ★★★★★ ()
Ответ на: комментарий от antonre

Значит собирай сначала питон поновее.
Только посмотри, что он требует в зависимостях и собери их руками с -1.
Когда дойдёшь до состояния, когда питон не требует зависимостей и ругается только на блокировки, тогда собирай с -O.

Lumi ★★★★★ ()
Ответ на: комментарий от antonre

>что за опция -k ?

man emerge. Она позволяет использовать бинарные пакеты, но не для всех пакетов. Сам я никогда не пробовал, но можно попробовать установить что-нибудь, не собирая, удовлетворить зависимость для другого пакета, а потом пересобрать первый.

gentoo_root ★★★★★ ()
Ответ на: комментарий от delete83

> Только когда у него emerge станет падать с жалобами на python, ты же первый предложишь ему систему переустановить...

Не станет, он просто либо не соберётся, либо соберётся и будет работать.

Если вы не заметили, то там только питон 2.5 и 2.4


Ну да, вот это я проглядел

[ebuild NS ] dev-lang/python-2.7.1-r1 [2.4.6, 2.5.4-r3] USE=«gdbm ncurses readline ssl threads (wide-unicode) xml -berkdb -build -doc -examples -ipv6 -sqlite -tk -wininst» 11,461 kB

Но, от этого никак не случится, что портеж соберётся, но работать не будет.

Lumi ★★★★★ ()
Ответ на: комментарий от delete83

> Попробуйте обновить python ДО обновления portage до версии 2.6:

А это очень даже правильно, плюсую всеми руками этот шаг.
С 2.7 огребал проблемы, а 2.6 очень хорош.

Lumi ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.