LINUX.ORG.RU

Установка KDE Plasma под Gentoo и @kde-plasma-live

 , , , ,


0

1

Приветствую, пытаюсь поставить плазму.

Читал это: https://wiki.gentoo.org/wiki/KDE/Overlay

@kde-frameworks-live - встал.

@kde-plasma-live - не хочет.

# emerge --ask @kde-plasma-live

There are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds to satisfy ">=kde-frameworks/kauth-9999:5[policykit]".
(dependency required by "kde-plasma/powerdevil-9999::kde" [ebuild])
(dependency required by "@kde-plasma-live" [argument])

emerge: there are no ebuilds to satisfy это вроде бы про недостающие зависимости.

kde-frameworks/kauth-9999 установлен. Установка флага policykit ничего не меняет.

Что я делаю не так?

Ответ на: комментарий от Pinkbyte

Покажи layman -l

*kde                [Git    ](git://anongit.gentoo.org/proj/kde.git

eix kde-frameworks/kauth

[I]kde-frameworks/kauth
    Available versions: (5) `5.13.0(5/5.13) (**)9999(5/9999)[1]
      {debug doc nls +policykit test}
    Installed versions: 9999(5/9999)[1](17:35:03 26.08.2015)(nls -debug -doc -policykit -test)
    Homepage:           http://www.ked.org/
    Description:        Framework to let applications perform actions as a privileged user

[1]"kde" /var/lib/layman/kde
c0deum ()
Ответ на: комментарий от anonymous

там по ссылке сайт программы kids escaping drugs, всё ок значит

anonymous ()

из-за проблем с pulseaudio в их последних сетах (мес назад) перебрался на meta* чего и вам желаю

deity ★★★★ ()
Ответ на: комментарий от deity

а вообще похоже на лаймано проблемы, как им синкают?

deity ★★★★ ()
Ответ на: комментарий от c0deum

Installed versions: 9999(5/9999)[1](17:35:03 26.08.2015)(nls -debug -doc -policykit -test)
-policykit

Еще вопросы есть?

Установка флага policykit ничего не меняет.

У меня меняет. Проверяй где ты его отключил/замаскировал

Pinkbyte ★★★★★ ()
Последнее исправление: Pinkbyte (всего исправлений: 1)

emerge app-portage/gentoolkit && equery u kauth

В столбце U показано текущее значение флага, в I — то, с которым был собран пакет

XMs ★★★★★ ()
Ответ на: комментарий от Pinkbyte

Еще вопросы есть?
У меня меняет. Проверяй где ты его отключил/замаскировал

Что-то не выходит.

emerge --info 

говорит, что policykit установлен.

https://wiki.gentoo.org/wiki/Handbook:PPC/Working/USE

Precedence Of course there is a certain precedence on what setting has priority over the USE setting. The precedence for the USE setting is, ordered by priority (first has lowest priority):

Default USE setting declared in the make.defaults files part of your profile User-defined USE setting in /etc/portage/make.conf User-defined USE setting in /etc/portage/package.use User-defined USE setting as environment variable To view the final USE setting as seen by Portage, run emerge --info. This will list all relevant variables (including the USE variable) with their current definition as known to portage.

Систему ставлю с нуля. Плазму устанавливаю сразу после базы по хэндбуку. Где мог накосячить( make.conf, package.{accept_keywords, mask, unmask, use}, профиль plasma без systemd )?

c0deum ()
Ответ на: комментарий от XMs

emerge app-portage/gentoolkit && equery u kauth

В столбце U показано текущее значение флага, в I — то, с которым был собран пакет

* Found these USE flags for kde-frameworks/kauth-9999:
U I
...
- - policykit : Enable PolicyKit authentication support
...
c0deum ()
emerge --info kauth

=================
Package Settings
=================

kde-frameworks/kauth-9999::kde was built with the following:
USE="nls -debug -doc (-policykit) -test"
c0deum ()
Ответ на: комментарий от c0deum

Значит, действительно, флаг не включен. grep -H kauth /etc/portage/package.use/* (или просто package.use, если одним файлом) покажет, где он у тея задаётся

XMs ★★★★★ ()
Ответ на: комментарий от Pinkbyte
#eselect profile list
Available profile symlink targets:
...
   [8]   default/linux/x86/13.0/desktop/plasma *
...

Я тут это, что-то подумал, что kde это для четвёртых кед, соответственно всё собрано c -kde, polkit без поддержки kde, не оно?

Если оно, то emerge --uavDN world?

c0deum ()
Ответ на: комментарий от c0deum
pinkbyte@oas1 /usr/portage/profiles $ grep -m 1 -r kauth
arch/x86/package.use.mask:kde-frameworks/kauth policykit
pinkbyte@oas1 /usr/portage/profiles $ grep -B 20 kauth arch/x86/package.use.mask
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

# This file requires >=portage-2.1.1

# Michael Palimaka <kensington@gentoo.org> (12 Aug 2015)
# Unkeyworded dependencies
kde-frameworks/kauth policykit
Pinkbyte ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.