LINUX.ORG.RU

Debian rolling release


0

1

В последнее время Aptosid начинает все больше разочаровывать. Приведу пример.

Не так давно после очередного dist-upgrade при следующем включении компа я благополучно вылетел в консоль. Оказалось, что в Debian обновились иксы, но не обновились дрова от видеокарты. Ну для Debian это понятно, unstable он и есть unstable. Но Aptosid чем занимался в это время? Эта система по заявлениям разработчиков призвана специально для того, чтобы сглаживать такие огрехи, как битые пакеты. И если уж такое случилось, нужный пакет должен был появиться в их собственном репозитории, а он не появился даже спустя неделю. Хорошо еще, что какой-то немец открыл свой собственный репозиторий frickelplatz.de и выложил там нормальные дрова от NVidia, предназначенные для новой версии иксов, я и подключил его в качестве стороннего репозитория.

Приведу еще один пример. Захотел я на свежекупленном ноуте со свежеустановленным Aptosid'ом установить пакет «gdebi-kde», чтобы с пакетами было проще обходиться. Я не смог его установить, битый пакет, классическая дебиановская матрешка. Даже не стал выяснять до конца, из-за какого именно пакета он не может поставиться, но понял, что Aptosid ничем не отличается от Debian Sid.

Вот из-за такого Aptosid и разочаровывает. Получается, что разработчики не выполняют своих обещаний и в нем ничего и нет, кроме пары идиотских тем и каждый день по новому ядру. Мне кажется, что если уж делать из какого-то дистрибутива rolling release, то это должны делать сами разработчики этого дистрибутива, а не третья сторона. К тому же разработчики Debian обещали после выхода релиза Squeeze открыть новую ветку rolling release, основанную на testing, никаких новостей по поводу этого не было? Когда ее откроют?

★★★★★

ссылку на твой багрепорт дай

lazyklimm ★★★★★ ()

Два пути: 1)Уходить на тестинг или стейбл. 2)Ставить арч.

Loki29 ★★ ()
Ответ на: комментарий от Loki29

>2)Ставить арч.

если ты мне скажешь, что в арче не бывает проблем при обновлениях - я рассмеюсь тебе в лицо

lazyklimm ★★★★★ ()
Ответ на: комментарий от lazyklimm

>> >2)Ставить арч.

У меня эта мысль тоже промелькнула в голове, но я очень люблю систему пакетов Debian.

Rinaldus ★★★★★ ()

кстати, только что поставил gdebi-kde без каких-либо проблем

nvidia сто лет ставлю с помощью sgfxi - они быстрее реагируют на появление новых версия ядер и прочего багофиксинга

и в нем ничего и нет, кроме пары идиотских тем и каждый день по новому ядру.

репоз fix.main не сказать, что пустой.

Я не воспринимаю sidux/aptosid как отдельный дистр, для меня это как быстроустанавливаемый готовый дебиан с мелкими плюшками и свежим ядром.

И повторюсь, если что-то сломано - пишите багрепорты либо чините сами

lazyklimm ★★★★★ ()
Ответ на: комментарий от Rinaldus

но я очень люблю систему пакетов Debian

В Arch ещё лучше.Попробуй просто.

le_legioner ★★ ()

На aptosid не тявкать - это раз! Debian с роллинг-релизом и есть aptosid - это два.

Arrakis ()
Ответ на: комментарий от lazyklimm

>> кстати, только что поставил gdebi-kde без каких-либо проблем

Странно, а я вот с рабочего компа, на котором тоже Aptosid, и делал dist-upgrade сегодня утром, не могу поставить и тут gdebi-kde. Для него требуется sip-api-7.1, который в репозиториях вообще отсутствует.

репоз fix.main не сказать, что пустой.

Он не пустой, но я бы не сказал, что полный.

И повторюсь, если что-то сломано - пишите багрепорты либо чините сами

Куда писать: в Aptosid или в Debian? Неужели они могут добавить в свой репозиторий пакет по репорту одного человека?

Rinaldus ★★★★★ ()
Ответ на: комментарий от le_legioner

>> В Arch ещё лучше.Попробуй просто.

Я около года на нем сидел и успел достаточно его изучить для того чтобы решить, что он мне не очень подходит.

Rinaldus ★★★★★ ()

Читай мейллист CUT. «usable» срезы тестинга уже недели две-три как выкладываются на фтп (где-то в дебрях мейллиста ссылка пробегала недавно).

leave ★★★★★ ()
Ответ на: комментарий от Rinaldus

>Он не пустой, но я бы не сказал, что полный.

ну, разработчиков мало

не могу поставить и тут gdebi-kde.

приду домой - проверю ещё раз

sip-api-7.1, который в репозиториях вообще отсутствует.

он виртуальный

Куда писать: в Aptosid или в Debian? Неужели они могут добавить в свой репозиторий пакет по репорту одного человека?

gdebi-kde из аптосидовского репоза? Тогда им пиши. Нет - тогда в дебиан. Кстати, какое зеркало используешь, может быть просто несинхронизировался с главным?

lazyklimm ★★★★★ ()
Ответ на: комментарий от lazyklimm

>> gdebi-kde из аптосидовского репоза? Тогда им пиши. Нет - тогда в дебиан. Кстати, какое зеркало используешь, может быть просто несинхронизировался с главным?

Только что поставил главное аптосидовское зеркало, там все так же. В качестве дебиановского зеркала использую Яндекс-зеркало, оно наиболее качественное для Москвы.

Rinaldus ★★★★★ ()
Ответ на: комментарий от leave

Ага, только там большая часть исошек 403 выплевывают.

madgnu ★★★★★ ()
Ответ на: комментарий от Rinaldus
sudo aptitude install gdebi-kde                                                                                                ☺
Следующие НОВЫЕ пакеты будут установлены:        
  akonadi-server{a} gdebi-core{a} gdebi-kde kdepim-runtime{a} kdepimlibs-kio-plugins{a} kdesudo{a} libakonadi-kabc4{a} libakonadi-kcal4{a} 
  libakonadi-kde4{a} libakonadi-kmime4{a} libakonadiprivate1{a} libkabc4{a} libkcal4{a} libkimap4{a} libkldap4{a} libkmime4{a} libkpimutils4{a} 
  libkresources4{a} libmailtransport4{a} libmicroblog4{a} libqt4-assistant{a} libqt4-scripttools{a} libqt4-test{a} mysql-server-core-5.1{a} 
  python-chardet{a} python-debian{a} python-kde4{a} python-qt4{a} python-sip{a} 
0 пакетов обновлено, 29 установлено новых, 0 пакетов отмечено для удаления, и 766 пакетов не обновлено.
Необходимо получить 24,7 MB архивов. После распаковки 93,7 MB будет занято.
Хотите продолжить? [Y/n/?] y
Получить:1 http://mirror.yandex.ru/debian/ sid/main python-chardet all 2.0.1-1 [175 kB]
Получить:2 http://mirror.yandex.ru/debian/ sid/main python-debian all 0.1.18 [58,4 kB]
Получить:3 http://mirror.yandex.ru/debian/ sid/main gdebi-core all 0.7.0 [120 kB]
Получить:4 http://mirror.yandex.ru/debian/ sid/main libkmime4 i386 4:4.4.5-2 [157 kB]
Получить:5 http://mirror.yandex.ru/debian/ sid/main libkimap4 i386 4:4.4.5-2 [177 kB]
Получить:6 http://mirror.yandex.ru/debian/ sid/main libkldap4 i386 4:4.4.5-2 [102 kB]
Получить:7 http://mirror.yandex.ru/debian/ sid/main kdepimlibs-kio-plugins i386 4:4.4.5-2 [317 kB]
Получить:8 http://mirror.yandex.ru/debian/ sid/main libakonadi-kabc4 i386 4:4.4.5-2 [18,1 kB]
Получить:9 http://mirror.yandex.ru/debian/ sid/main libkresources4 i386 4:4.4.5-2 [85,0 kB]
Получить:10 http://mirror.yandex.ru/debian/ sid/main libkabc4 i386 4:4.4.5-2 [387 kB]
Получить:11 http://mirror.yandex.ru/debian/ sid/main libkpimutils4 i386 4:4.4.5-2 [49,3 kB]
Получить:12 http://mirror.yandex.ru/debian/ sid/main libkcal4 i386 4:4.4.5-2 [445 kB]
Получить:13 http://mirror.yandex.ru/debian/ sid/main libakonadi-kcal4 i386 4:4.4.5-2 [21,3 kB]
Получить:14 http://mirror.yandex.ru/debian/ sid/main libakonadiprivate1 i386 1.3.1-3+b1 [639 kB]
Получить:15 http://mirror.yandex.ru/debian/ sid/main libakonadi-kde4 i386 4:4.4.5-2 [727 kB]
Получить:16 http://mirror.yandex.ru/debian/ sid/main libakonadi-kmime4 i386 4:4.4.5-2 [67,6 kB]
Получить:17 http://mirror.yandex.ru/debian/ sid/main libmailtransport4 i386 4:4.4.5-2 [181 kB]
Получить:18 http://mirror.yandex.ru/debian/ sid/main libmicroblog4 i386 4:4.4.5-2 [23,9 kB]
Получить:19 http://mirror.yandex.ru/debian/ sid/main mysql-server-core-5.1 i386 5.1.55-1 [3 960 kB]
Получить:20 http://mirror.yandex.ru/debian/ sid/main akonadi-server i386 1.3.1-3+b1 [210 kB]                                                            
Получить:21 http://mirror.yandex.ru/debian/ sid/main kdepim-runtime i386 4:4.4.7-1 [1 872 kB]                                                           
Получить:22 http://mirror.yandex.ru/debian/ sid/main libqt4-assistant i386 4:4.6.3-4 [45,4 kB]                                                          
Получить:23 http://mirror.yandex.ru/debian/ sid/main libqt4-scripttools i386 4:4.6.3-4 [320 kB]                                                         
Получить:24 http://mirror.yandex.ru/debian/ sid/main libqt4-test i386 4:4.6.3-4 [95,2 kB]                                                               
Получить:25 http://mirror.yandex.ru/debian/ sid/main python-sip i386 4.10.2-1 [130 kB]                                                                  
Получить:26 http://mirror.yandex.ru/debian/ sid/main python-qt4 i386 4.7.3-1+b1 [5 013 kB]                                                              
Получить:27 http://mirror.yandex.ru/debian/ sid/main python-kde4 i386 4:4.4.5-3 [9 184 kB]

ну итп

аптосид тут вообще не при чём, все пакеты с дебиановского (яндексовского) зеркала. Все разрешается, ставится итп

lazyklimm ★★★★★ ()
Ответ на: комментарий от lazyklimm

> аптосид тут вообще не при чём, все пакеты с дебиановского (яндексовского) зеркала. Все разрешается, ставится итп
Во-первых, Эптосид. А че ты тогда на него бычешь? Яндекс виноват же.

Arrakis ()
Ответ на: комментарий от Arrakis

Во-первых, Эптосид. А че ты тогда на него бычешь?

во-первых: бычишь, во-вторых: я-то как раз не бычу, а защищаю, если ты не заметил

lazyklimm ★★★★★ ()

>Оказалось, что в Debian обновились иксы, но не обновились дрова от видеокарты.

sgfxi тебе в руки, тем более что в аптосиде он есть изкаробки.

Polugnom ★★★★★ ()
Ответ на: комментарий от lazyklimm

И тем не менее,

sudo apt-get install gdebi-kde
Чтение списков пакетов... Готово
Построение дерева зависимостей       
Чтение информации о состоянии... Готово
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
 gdebi-kde : Зависит: python-kde4 (>= 3.16.0-0ubuntu11) но он не будет установлен

Почему от убунтовского питона зависит, понятия не имею. У меня из убунтовских реп только репа с Wine, и там точно никакого питона нет.

Rinaldus ★★★★★ ()
Ответ на: комментарий от Polugnom

Из коробки его нет, но я его нашел в гугле. Если он качает дрова прямо с сайта NVidia и сам компиллирует их для каждого ядра, то это именно то, что мне нужно. А автоматически он умеет детектировать установку нового ядра, как в DKMS?

Rinaldus ★★★★★ ()
Ответ на: комментарий от Rinaldus

>А автоматически он умеет детектировать установку нового ядра, как в DKMS?

На сколько я помню - нет.

Polugnom ★★★★★ ()

Да установите вы calculate, какое же жуткое неосиляторство calculate! Хочется красноглазия, ставь из исходников, хочется из бинарников, ставь из бинарников, ну вот чем вас calculate не угодил?

babusha ()
Ответ на: комментарий от lazyklimm

У меня не бывает проблем при обновлениях. Доказывай обратное (что у меня бывают проблемы) или признавай что обосрался.

anonymous ()

А вот не надо делать dist-upgrade. Ну и dkms решает, да.

philosoft ()

заодно и Линукс выучишь! )))

ipwww ★★ ()
Ответ на: комментарий от anonymous

нет, это ты доказывай что ни у кого нет, а также учись читать

lazyklimm ★★★★★ ()
Ответ на: комментарий от Rinaldus

> репа с Wine

необязательно python, может какой побочный пакет, мало ли.

Да и нафига убунтовский вайн, если есть frickelplatz?

lazyklimm ★★★★★ ()
Ответ на: комментарий от Rinaldus

автоматически - сам не умеет, но если есть желание - можеш покурить help и сделать DKMS скрипт, только проблема в том, что нвидияшные дрова не любят собираться с запущеными иксами

lazyklimm ★★★★★ ()
Ответ на: комментарий от Rinaldus

О, у вас еще и убунтовские репы прикручены? И после этого вы плачетесь, что все сломалось?

strangeman ★★★★ ()
Ответ на: комментарий от le_legioner

> В Arch ещё лучше. Попробуй просто.

См. про старую поломку ffmpeg: http://patrakov.blogspot.com/2009/01/package-dependencies.html . В arch получилась тихая поломка в runtime, в debian в таком случае получается две версии библиотеки и конфликт в runtime только в том случае, если обе версии косвенно используются в одной программе.

AEP ★★★★★ ()
Ответ на: комментарий от Rinaldus

мои яйца, так это ведь сам Ринальдус. Скажу тебе, все ВОВеры на арче сидят. Плохо пробовал. gife one more try.

ngsupb ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.