LINUX.ORG.RU

Ctrl+Alt+F[1-6] - чёрный экран


0

1

При переключении в другой терминал по Ctrl+Alt+F[1-6] вижу только чёрный экран, Ctrl+Alt+F7 возвращает на рабочий стол. Терминалы точно работают: если при загрузке системы (Gentoo) выбрать интерактивный режим и запустить всё кроме иксов, после чего залогиниться - по терминалам можно свободно гулять, текст будет виден. Также после любого отключения иксов ноут падает в чёрный экран. Драйвер иксов - nvidia-260. Хочу опять увидеть свои терминалы.

★★★★★

Ответ на: комментарий от backbone

если сработает, то откатиться на старую версию nvidia

backbone ★★★★★ ()

>260
крайне неудачные дрова:
оверклок поломали
у многих косяки скажем с гимпом
но твоей проблемы не наблюдал у себя - не важно, но терминалов у меня всего 2 и на 3-ем иксы

megabaks ★★★★ ()
Ответ на: комментарий от backbone

>xf86-video-nv

После гладкого 1080 на ютубе даже на nouveau возвращаться не хочется :) Сейчас попробую откатить блоб.

крайне неудачные дрова


Не спорю, но с предыдущими у меня возникали какие-то проблемы при сборке, кажется с make - только 260 смогли собраться.

Кстати да, на nouveau всё работало.

jcd ★★★★★ ()
Ответ на: комментарий от megabaks

>и да - а с логами то чего?

Вроде бы всё чисто.

jcd ★★★★★ ()
Ответ на: комментарий от jcd

>но с предыдущими у меня возникали какие-то проблемы при сборке, кажется с make - только 260 смогли собраться.
прозреваю >=36-е ядро

megabaks ★★★★ ()

А монитора не 2, случаем? У меня такое было, кажется, в режиме separate X screen(?) на двух мониторах.

Deleted ()
Ответ на: комментарий от jcd

ничего не поломали - просто 256* не дружат с >=36
на 35-ом нормально

megabaks ★★★★ ()
Ответ на: комментарий от jcd

После гладкого 1080 на ютубе даже на nouveau возвращаться не хочется :)

та не, я не предлагал лезть в петлю =)
просто чтобы причину установить...

backbone ★★★★★ ()

Похожее поведение у меня на 4870. Решается полным выпиливанием любых упоминаний о KMS из конфига, и установке(а это кажется необязательно) vga консоли.

GAMer ★★★★★ ()
Ответ на: комментарий от backbone

Оказывается у меня и стоял vesafb. Откат на ядро 2.6.35 и драйвер 256 не помогли, правда настройки я не менял.

jcd ★★★★★ ()
Ответ на: комментарий от jcd

ps aux|grep getty|head -n -1
- убедиться, что в неинтерактивном режиме терминалы запущены
временно поменять /etc/X11/xorg.conf

Section "Device"
    Identifier     "Device0"
    Driver         "nv"
EndSection
(или vesa) - чтобы убедиться, что дело именно в драйверах
проверить наличие в /boot/grub/grub.conf опций vga=..., quiet, splash, возможно из-за них

backbone ★★★★★ ()

попробуй (ели еще не сделал) заблеклистить nouveaufb и дописать в строку grub «nomodeset»

madgnu ★★★★★ ()

У меня во всех дистрибутивах, кроме Убунты, все работает хорошо. А в Убунте есть этот баг, да и при загрузке тоже черный экран. Это из-за того что у меня есть встроенная видеркарта ATi, а BIOS не дает выключить ее насовсем. Только выбрать основную.

Zenithar ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.