LINUX.ORG.RU

[gentoo] Пара вопросов


0

1

Прикупил же себе вифи роутер давеча, решил вот прикрутить вафлю к моей генточке, чтобы избавиться от проводов. Но возникла такая проблема. Для начала после недолгого гугления я заюзал ndiswrapper для дров, интерфейс wlan0 появился, все хорошо. Поставил wicd, запускаю wicd-client дял настройки, и тут-то начинаются лаги и баги. А точнее один баг - wicd виснет в момент «genereting WPA...» (как-то так), при этом, судя по мигающему Scroll Lock происходит Kernel Panic, о чем говорит еще и полностью повисшая система. Собственно, как быть? МБ кто сталкивался с таким? (Какие логи показать?)

Ну и небольшой второй вопрос - собрал себе деадбиф последний из сырцов, все собралось без проблем, запускается. Но запускается только из-под рута, т.е.

 /usr/local/bin/deadbeef
под рутом запускает дедбиф нормально, но та же команда из-под обычного пользователя ничего не дает, он либо запускается с намертво повисшим окошком, либо просто мигает окном и все. Как быть? Я уж начал грешить на права, психанул и дал ему 777, но тоже не помогло.

З.Ы. Гуглил, ничего дельного не нагуглил, поэтому и обратился к великому и могучему ЛОРу.

★★★★★

про права: в моей генте тоже какая-то свистопляска с ними творится - свежеустановленные пакеты не появляются в меню, запускаются только от рута и прочий идиотизм, приходится ручками разгребать каждый случай

этот экземпляр как-то очень неудачно я собрал, видимо, собирать генту надо всё-таки на трезвую голову

anonymous ()

А что за wifi-железо?

AITap ★★★★★ ()
Ответ на: комментарий от anonymous

>пакеты не появляются в меню

У меня тоже не появляются. Мне привычнее ручками прописать в ~/.fluxbox/menu

Zhbert ★★★★★ ()
Ответ на: комментарий от AITap
zhbertpc zhbert # lspci | grep Wireless
05:00.0 Ethernet controller: Atheros Communications Inc. AR5001 Wireless Network Adapter (rev 01)

Ради интереса воткнулся флешкой с бубунтой, все работает...

Zhbert ★★★★★ ()

>но та же команда из-под обычного пользователя ничего не дает, он либо запускается с намертво повисшим окошком, либо просто мигает окном и все.

/etc/profile.d/ ?
ldconfig ?

anon_666 ()
Ответ на: комментарий от KevinDetry

>В убунте тоже через ndiswrapper?

Да кто ж ее, бубунту, знает, черех что она там работает? Она сама чем-то подхватила и предложила пароль впа ввести.

Zhbert ★★★★★ ()
Ответ на: комментарий от Zhbert

> Она сама чем-то подхватила и предложила пароль впа ввести.
ath5k, скорее всего.

AITap ★★★★★ ()
Ответ на: комментарий от KevinDetry

Лень ребутаться опять. Попробую покрасноглазить с мадвифи немного.

Zhbert ★★★★★ ()

Кстати, так толком ничего и не сказали про дедбиф. Мне, конечно, не сложно его каждый раз толкать из терминала с-под рута, но все-таки...

Zhbert ★★★★★ ()

Это что за карточка, что дрова к ней через ndiswrapper?

CyberTribe ★★ ()

ath5k собери модулем в ядре и всё, никакие madwifi и ndiswrapper не нужны будут.
дальше всё прямолинейно.

CyberTribe ★★ ()
Ответ на: комментарий от Zhbert

Зато, если не поленишься, то узнаешь название нормально работающего драйвера вафли и значительно упростишь себе работу.

KevinDetry ()

>05:00.0 Ethernet controller: Atheros Communications Inc. AR5001 Wireless Network Adapter (rev 01)

Для начала после недолгого гугления я заюзал ndiswrapper для дров, интерфейс wlan0 появился, все хорошо.


Ты что курил? wlan0 искаропки появляется и работает без лишних телодвижений

xorik ★★★★★ ()

напихал какашек и потом удивляешься - плохой гентушнег :3

megabaks ★★★★ ()

Тащемта, разобрался с дровами вафли. Wicd теперь не валит напрочь систему, а просто говорит «Неправильный пароль». И опять приходится перегугливать половину инета...

Zhbert ★★★★★ ()
Ответ на: комментарий от Zhbert

Сети увидел? Заходишь в параметры и пишешь ключ сети

xorik ★★★★★ ()
Ответ на: комментарий от megabaks

>ты чего с гентой сделал?

собрал по пьяни

anonymous ()
Ответ на: комментарий от xorik

>Заходишь в параметры и пишешь ключ сети

Спасибо, кэп!

Это все сделано, ключ проверил 10 раз, все правильно, но пишет «Неправльный ключ». Гугль говорит, что он может конфликтовать с нетворкманагером, но того вроде как и нет. Сети видит, да.

Zhbert ★★★★★ ()
Ответ на: комментарий от Zhbert

все /etc/init.d/net.* выключены кроме lo?
На крайняк попробуй networkmanager поставить

xorik ★★★★★ ()
Ответ на: комментарий от xorik

>все /etc/init.d/net.* выключены кроме lo?

Ну я ограничился выдергиванием витухи из гнезда. Сейчас попробую выкоючить ручками в консольке.

На крайняк попробуй networkmanager поставить


Была такая мысля...

Zhbert ★★★★★ ()
Ответ на: комментарий от Zhbert

Кстати у меня тоже к одной точке доступа перестало коннектится, хотя пароль 100% правильный и до этого всё нормально работало. Возможно баг драйвера, но наступил он неожиданно...

xorik ★★★★★ ()
Ответ на: комментарий от xorik

Не, ну мне вафля не критична, можно по старинке и с проводом посидеть, один черт в ноут и так втыкается зарядка, но все-таки хотелось бы, чтобы было по феншую =)

Zhbert ★★★★★ ()
Ответ на: комментарий от Zhbert

Я потом попробую разобраться в чем баг и репорт написать, а то все на работе сидят через точку доступа, а я не могу :)

xorik ★★★★★ ()
Ответ на: комментарий от andreyu

Вдогонку, вчера собирал deadbeef руками - все завелось и взлетело. Потом собрал с помощью ebuild'а, предварительно снеся самосбор.

И да, USE=gtk не забудьте, иначе без морды соберется.

andreyu ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.