LINUX.ORG.RU

[paludis][gentoo] package.provided

 ,


0

1

В манах к палудису сказано, что нужно использовать importare вместо package.provided. Сказано - сделано, создал репу, импортирую пустую директорию.

# importare -i -l /tmp/blank/ media-sound/sound-juicer 9999 0

Однако при установке гнома вываливается

paludis@1278062968: [WARNING dep_list.downgrade] In thread ID '26613':
  ... In program paludis -ip gnome:
  ... When performing install action from command line:
  ... When executing install task:
  ... When building dependency list:
  ... When adding PackageDepSpec 'gnome-base/gnome':
  ... When adding package 'gnome-base/gnome-2.28.2:2.0::gentoo':
  ... When adding run dependencies as pre dependencies:
  ... When adding PackageDepSpec '>=media-sound/sound-juicer-2.28.1':
  ... Downgrade to 'media-sound/sound-juicer-2.28.2-r1:0::gentoo' from 'media-sound/sound-juicer-9999:0::installed-unpackaged' forced
$ cat /var/paludis/repositories/gentoo/gnome-base/gnome/gnome-2.28.2.ebuild | grep sound-juicer
	>=media-sound/sound-juicer-2.28.1

чяднт?

★★★★★

Последнее исправление: tensai_cirno (всего исправлений: 1)

Ответ на: комментарий от name_no

Размаскировал и прописал кейворды, хотя от этого никакого толку и не должно быть. Это не ебилд всё-таки. importare просто мержит выбранную папку в корень, записывая как названный пакет.

tensai_cirno ★★★★★
() автор топика
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.