LINUX.ORG.RU

libeap0 в gentoo


0

0

собираю тут wimax-1.5 с сайтика http://linuxwimax.org и не знаю откуда библиотеку достать.

checking for LIBEAP0... configure: error: Package requirements (libeap0) were not met:

No package 'libeap0' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you installed software in a non-standard prefix.

Alternatively, you may set the environment variables LIBEAP0_CFLAGS and LIBEAP0_LIBS to avoid the need to call pkg-config. See the pkg-config man page for more details.

откуда её достать :( подскажите

зы - по хавту вот этому ставил в убунте. http://icelord.livejournal.com/322069.html

★★★★★

Ответ на: комментарий от Zhbert

не. не мэд. мэд то по ебилду как раз нормально собрался %)

тут интеловский чип вимакс/вифи

tazhate ★★★★★ ()
Ответ на: комментарий от Lumi

я дурак. искал по gentoo libeap.

спасибо, попробую

tazhate ★★★★★ ()
Ответ на: комментарий от Sylvia

Я не проверял, лень было, каюсь, с телефона на сорсфорж идти.

Lumi ★★★★★ ()
Ответ на: комментарий от DoctorSinus

у меня железо другое. madwimax работает со свистками, а у меня intel wimax|wifi 5150. под убунтой все прекрасно собирается, что весьма досадно.

tazhate ★★★★★ ()
Ответ на: комментарий от daemonpnz

hag libeap # make make: *** Не заданы цели и не найден make-файл. Останов.

hag libeap # ./install-sh install:   no input file specified

tazhate ★★★★★ ()
Ответ на: комментарий от Sylvia

wimax-1.5. он же wimax network service, ага.

я собираю новую версию всего, который с фирмварой 1.6 идет. решил что старые не буду.

tazhate ★★★★★ ()
Ответ на: комментарий от tazhate



так, я прошла квест,

берете это

http://hostap.epitest.fi/releases/wpa_supplicant-0.6.10.tar.gz

патчите этим

http://linuxwimax.org/Download?action=AttachFile&do=get&target=wpa_supplicant...

пересобираете wpa_supplicant

получаете libeap0

/include/eap_peer:
total 120
-rw-r--r-- 1 sylvia sylvia 2508 Jun 27 19:22 build_config.h
-rw-r--r-- 1 sylvia sylvia 12311 Jun 27 19:22 common.h
-rw-r--r-- 1 sylvia sylvia 6193 Jun 27 19:22 defs.h
drwxr-xr-x 2 sylvia sylvia 60 Jun 27 19:22 eap_common
-rw-r--r-- 1 sylvia sylvia 20392 Jun 27 19:22 eap_config.h
-rw-r--r-- 1 sylvia sylvia 8840 Jun 27 19:22 eap.h
-rw-r--r-- 1 sylvia sylvia 2129 Jun 27 19:22 eap_methods.h
-rw-r--r-- 1 sylvia sylvia 1559 Jun 27 19:22 includes.h
-rw-r--r-- 1 sylvia sylvia 15129 Jun 27 19:22 os.h
-rw-r--r-- 1 sylvia sylvia 20257 Jun 27 19:22 tls.h
-rw-r--r-- 1 sylvia sylvia 4041 Jun 27 19:22 wpabuf.h
-rw-r--r-- 1 sylvia sylvia 8366 Jun 27 19:22 wpa_debug.h

./include/eap_peer/eap_common:
total 4
-rw-r--r-- 1 sylvia sylvia 2571 Jun 27 19:22 eap_defs.h

./lib:
total 184
-rwxr-xr-x 1 sylvia sylvia 177748 Jun 27 19:22 libeap.so.0.0.0
drwxr-xr-x 2 sylvia sylvia 60 Jun 27 19:22 pkgconfig

./lib/pkgconfig:
total 4
-rw-r--r-- 1 sylvia sylvia 205 Jun 27 19:22 libeap0.pc

Sylvia ★★★★★ ()
Ответ на: комментарий от Sylvia

ура, собралось %) зато терь другая проблема. при попытке modprobe i2400m жалуется на invalid module format. в ядре все что касается вимакса вроде включено =\

tazhate ★★★★★ ()
Ответ на: комментарий от tazhate

/boot :$cat config-2.6.34-lu |grep -i wimax
CONFIG_WIMAX=m
CONFIG_WIMAX_DEBUG_LEVEL=8
# WiMAX Wireless Broadband devices
CONFIG_WIMAX_I2400M=m
CONFIG_WIMAX_I2400M_USB=m
CONFIG_WIMAX_I2400M_SDIO=m
# CONFIG_WIMAX_IWMC3200_SDIO is not set
CONFIG_WIMAX_I2400M_DEBUG_LEVEL=8



а с ядром вместе его собрать не пробовали?

wimax-compat это всего лишь куски из ядра, причем могут и не соответствовать версии или конфигурации и не загружаться

Sylvia ★★★★★ ()
Ответ на: комментарий от Sylvia

hag linux # cat .config | grep -i wimax
CONFIG_WIMAX=y
CONFIG_WIMAX_DEBUG_LEVEL=8
# WiMAX Wireless Broadband devices
CONFIG_WIMAX_I2400M=m
CONFIG_WIMAX_I2400M_USB=m
CONFIG_WIMAX_I2400M_SDIO=m
CONFIG_WIMAX_I2400M_DEBUG_LEVEL=8


у меня тож самое. вместе с ядром не пробовал. как это сделать ^^?

tazhate ★★★★★ ()
Ответ на: комментарий от tazhate

/lib/modules/2.6.34-lu/kernel/drivers/net/wimax/i2400m/i2400m-sdio.ko
/lib/modules/2.6.34-lu/kernel/drivers/net/wimax/i2400m/i2400m.ko
/lib/modules/2.6.34-lu/kernel/drivers/net/wimax/i2400m/i2400m-usb.ko


modprobe i2400m

? )

Sylvia ★★★★★ ()
Ответ на: комментарий от Sylvia

hag ~ # ls /lib/modules/2.6.32-gentoo-r7/kernel/drivers/net/wimax/i2400m/
hag ~ #


ээээ а куда делись о_О

tazhate ★★★★★ ()
Ответ на: комментарий от Sylvia

собрал себе 34ое ядришко, все ожило ) спасибо огроменное!

tazhate ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.