LINUX.ORG.RU

p2p


0

0

решил поставить p2p скачал gift пишу:
$./configure
...
...
configure: error:
libltdl support is temporarily required. Please install the appropriate library and header files (which includes the -dev package) See config.log for more details.
ок (далее):
$ wget www.someserver.com/libltdl.rpm //всё полностью лень //писать
$ rpm -ihv libltdl.rpm
succesSFULLY
$./configure
...
...
configure: error:
libltdl support is temporarily required. Please install the appropriate library and header files (which includes the -dev package) See config.log for more details.
в сети нашёл ltdl.h
$ cp ltdl.h /usr/include
$./configre
...
...
checking ltdl.h usability... no
checking ltdl.h presence... yes
configure: WARNING: ltdl.h: present but cannot be compiled
configure: WARNING: ltdl.h: check for missing prerequisite headers?
configure: WARNING: ltdl.h: proceeding with the preprocessor's result
configure: WARNING: ## ------------------------------------ ##
configure: WARNING: ## Report this to bug-autoconf@gnu.org. ##
configure: WARNING: ## ------------------------------------ ##
checking for ltdl.h... yes
configure: error:
libltdl support is temporarily required. Please install the appropriate
library and header files (which includes the -dev package). See config.log
for more details.
в чём дело? что я не так делаю?


anonymous

Re: p2p

Дык, написано же:
Please install the appropriatelibrary and header files (which includes the ***-dev package***).
Хэдеэр, скачаный отдельно от библиотеки - вполне возможная причина бага. Т.о. ставь -dev (или -devel) rpm-ку. В данном случае libltdl-devel-xxxx.rpm.

Kirill ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.