LINUX.ORG.RU

Postgres 8.3. Установка в Debian Lenny


0

0

Ничего понять не могу, установил postgres:

apt-get install postgresql-8.3

И больше ничего не происходит. В /etc/init.d/posrgres-8.3 все ветки пустые. Нет конфигурационного файла, блин что же так всё сложно - то. Кто сталкивался с этим?

Re: Postgres 8.3. Установка в Debian Lenny

ты о чем вообще ? все ставится с полпинка - /etc/postgresql/8.3/main/postgresql.conf

xtron ()
Ответ на: Re: Postgres 8.3. Установка в Debian Lenny от xtron

Re: Postgres 8.3. Установка в Debian Lenny

Вот об этом:

Setting up postgresql-8.3 (8.3.5-1) ...

/var/lib/dpkg/info/postgresql-8.3.postinst: line 19: /usr/share/postgresql-common/maintscripts-functions: No such file or directory

dpkg: error processing postgresql-8.3 (--configure):

subprocess post-installation script returned error exit status 1

dpkg: dependency problems prevent configuration of postgresql:

postgresql depends on postgresql-8.3; however:

Package postgresql-8.3 is not configured yet.

dpkg: error processing postgresql (--configure):

dependency problems - leaving unconfigured

Errors were encountered while processing:

postgresql-8.3

postgresql

E: Sub-process /usr/bin/dpkg returned an error code (1)

ded_mopozzz ()
Ответ на: Re: Postgres 8.3. Установка в Debian Lenny от rjaan

Re: Postgres 8.3. Установка в Debian Lenny

1 Место есть :(

2 apt-get install postgresql естественно первым делом сделал.

# df -h Filesystem Size Used Avail Use% Mounted on simfs 9.6G 530M 9.1G 6% / tmpfs 1005M 0 1005M 0% /lib/init/rw tmpfs 1005M 0 1005M 0% /dev/shm

root@iterminal:/usr/lib/postgresql/8.3/bin# apt-get -f install

Reading package lists... Done

Building dependency tree

Reading state information... Done

0 upgraded, 0 newly installed, 0 to remove and 23 not upgraded.

2 not fully installed or removed.

After this operation, 0B of additional disk space will be used.

Setting up postgresql-8.3 (8.3.5-1) ...

/var/lib/dpkg/info/postgresql-8.3.postinst: line 19: /usr/share/postgresql-common/maintscripts-functions: No such file or directory

dpkg: error processing postgresql-8.3 (--configure):

subprocess post-installation script returned error exit status 1

dpkg: dependency problems prevent configuration of postgresql:

postgresql depends on postgresql-8.3; however:

Package postgresql-8.3 is not configured yet.

dpkg: error processing postgresql (--configure):

dependency problems - leaving unconfigured

Errors were encountered while processing:

postgresql-8.3

postgresql

E: Sub-process /usr/bin/dpkg returned an error code (1)

ded_mopozzz ()
Ответ на: Re: Postgres 8.3. Установка в Debian Lenny от ded_mopozzz

Re: Postgres 8.3. Установка в Debian Lenny

Странное что-то. У меня файл /usr/share/postgresql-common/maintscripts-functions есть.

apt-get update
apt-get dist-upgrade
?

xtron ()
Ответ на: Re: Postgres 8.3. Установка в Debian Lenny от ded_mopozzz

Re: Postgres 8.3. Установка в Debian Lenny

apt-get install postgres вроде встал не ругаясь

но скрипт init.d/postgres-8.3 пустой. Просит какие то переменные

Setting environment variables for the postmaster here does not work; please

# set them in /etc/postgresql/8.3/<cluster>/environment instead.

[ -r /usr/share/postgresql-common/init.d-functions ] || exit 0

. /usr/share/postgresql-common/init.d-functions

VERSION=8.3

case "$1" in start) start $VERSION ;; stop) stop "$VERSION" ;; restart) <------>restart "$VERSION" ;; force-reload | reload) reload $VERSION ;; status) status $VERSION <------>;; autovac-start) <------>autovac_start $VERSION <------>;; autovac-stop) <------>autovac_stop $VERSION <------>;; autovac-restart) <------>autovac_restart $VERSION <------>;; *) echo "Usage: $0 {start|stop|restart|reload|force-reload|status|autovac-start|autovac-stop|autov ac-restart}" exit 1 ;; esac

exit 0

ded_mopozzz ()
Ответ на: Re: Postgres 8.3. Установка в Debian Lenny от xtron

Re: Postgres 8.3. Установка в Debian Lenny

В том то и дело, у меня на debian 4.0 Centos 5 и т.д. тоже безпроблем.

А здесь даже на /etc/init.d/postgres start не реагирует

ded_mopozzz ()

Re: Postgres 8.3. Установка в Debian Lenny

пропиши в /etc/apt/sources.list только одну строчку (выброси все кроме)
deb http://mirror.yandex.ru/debian unstable main non-free contrib

и сделай
apt-get update
apt-get dist-upgrade

все должно без какой либо ругани пройти
потом наверно:

apt-get remove postgresql
apt-get install postgresql

xtron ()
Ответ на: Re: Postgres 8.3. Установка в Debian Lenny от Lumi

Re: Postgres 8.3. Установка в Debian Lenny

ii postgresql 8.3.5-1 object-relational SQL database (supported ve

ii postgresql-8.3 8.3.5-1 object-relational SQL database, version 8.3

ii postgresql-client-8.3 8.3.5-1 front-end programs for PostgreSQL 8.3

ii postgresql-client-common 94 manager for multiple PostgreSQL client versi

ii postgresql-common 94 PostgreSQL database-cluster manager

ii postgresql-contrib-8.3 8.3.5-1 additional facilities for PostgreSQL

ded_mopozzz ()

Re: Postgres 8.3. Установка в Debian Lenny

Стоп, вернемся к началу

в /etc/init.d/posrgres-8.3 должен находится скрипт запуска, а конфигурация в /etc/postgresql :)))

rjaan ★★ ()
Ответ на: Re: Postgres 8.3. Установка в Debian Lenny от rjaan

Re: Postgres 8.3. Установка в Debian Lenny

Да. Скрипт я запуска я выложил выше, оне не срабатывает вообще. Далее в /etc/defaults несоздался файл postgres. Директория с кофигурацией /etc/postgresql не существует. Но она вроде создаётся при первом запуске /etc/init.d/postgres-8.3 start, который не реагирует вообще не на что :(

ded_mopozzz ()
Ответ на: Re: Postgres 8.3. Установка в Debian Lenny от ded_mopozzz

Re: Postgres 8.3. Установка в Debian Lenny

> ii postgresql-8.3 8.3.5-1 object-relational SQL database, version 8.3

А это точно установилось корректно. У меня сейчас негде посмотреть именно для debian, только centos, но сильно смахивает на то, что у тебя нет серверной части.

Lumi ★★★★★ ()
Ответ на: Re: Postgres 8.3. Установка в Debian Lenny от ded_mopozzz

Re: Postgres 8.3. Установка в Debian Lenny

> Далее в /etc/defaults несоздался файл postgres

А Вы точно уверены, что он должен создаваться??? В предыдущих версиях, его и в помине не было и вряд ли он будет в настоящих и будущих.

Все очень просто, у вас не был установлен пакет postgresql-common, который должен находиться на зеркале в debian/pool/main/p/postgresql-common . Этот пакет содержит скрипт /usr/share/postgresql-common/init.d-functions .

Думаю, что все ваши проблемы будет решены с установкой этого пакета :)))


rjaan ★★ ()
Ответ на: Re: Postgres 8.3. Установка в Debian Lenny от rjaan

Re: Postgres 8.3. Установка в Debian Lenny

#:/var/cache/apt# apt-get install postgresql-common

Чтение списков пакетов... Готово

Построение дерева зависимостей

Чтение информации о состоянии... Готово

Уже установлена самая новая версия postgresql-common.

:( Я уже даже незнаю куда копать...

ded_mopozzz ()
Ответ на: Re: Postgres 8.3. Установка в Debian Lenny от ded_mopozzz

Re: Postgres 8.3. Установка в Debian Lenny

> Не помогает. В /usr/share/ появилось всё, но по прежнему нет реакции на /etc/init.d/postfix-8.3 start

Кстати, наверное не /etc/init.d/postfix-8.3 start, а etc/init.d/postgresql-8.3, ... :(((

Возвращаю Вас к Вашему же посту http://www.linux.org.ru/jump-message.jsp?msgid=3459102&cid=3459369 .

Вот теперь, когда стало возможно выполнение скрипта /usr/share/postgresql-common/maintscripts-functions . Так как, если Вы помните у нас с Вами выполнение postinst завершилось крахом и пакет postgresql-8.3 остался не сконфигурирован. Попытаемся сделать это заново запустив dpkg-reconfigure(8) следующим образом:

# dpkg-reconfigure postgresql-8.3

rjaan ★★ ()
Ответ на: Re: Postgres 8.3. Установка в Debian Lenny от rjaan

Re: Postgres 8.3. Установка в Debian Lenny

Да. Конечно же не init.d/postfix start :)

Вообщем сделал:

# dpkg-reconfigure postgresql-8.3

/etc/init.d/postgres start молчит

# dpkg-reconfigure postgresql (на всякий пожарный)

/etc/init.d/postgres start молчит

Сдаётся мне что всё же что то мантейнеры намутили :\ Есть ли возможность установить старую версию - 8,2 например?

ded_mopozzz ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.