LINUX.ORG.RU

Какая-то проблема с apt-get и postgresql-8.3


0

0

Немогу обновить postgresql-8.3 и непойму в чем может быть проблема. У кого нибудь было такое?

~# apt-get install postgresql-8.3
Чтение списков пакетов... Готово
Построение дерева зависимостей       
Чтение информации о состоянии... Готово
Следующие пакеты устанавливались автоматически и больше не требуются:
  linux-headers-2.6.28-11 linux-headers-2.6.28-11-generic
Для их удаления используйте 'apt-get autoremove'.
Предлагаемые пакеты:
  oidentd ident-server
Пакеты, которые будут обновлены:
  postgresql-8.3
обновлено 1, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.
не установлено до конца или удалено 1 пакетов.
Необходимо скачать 0B/3670kB архивов.
После данной операции, объём занятого дискового пространства возрастёт на 12,3kB.
(Чтение базы данных... на данный момент установлено 263797 файлов и каталогов.)
Подготовка к замене пакета postgresql-8.3 8.3.8-0ubuntu9.04 (используется файл .../postgresql-8.3_8.3.9-0ubuntu9.04_i386.deb)...
 * Stopping PostgreSQL 8.3 database server                                       * Insecure directory in $ENV{PATH} while running with -T switch at /usr/share/postgresql-common/PgCommon.pm line 656.
                                                                         [fail]
invoke-rc.d: initscript postgresql-8.3, action "stop" failed.
dpkg: предупреждение -- старый сценарий pre-removal возвратил код ошибки 255
dpkg: попытка использовать сценарий из нового пакета...
 * Stopping PostgreSQL 8.3 database server                                       * Insecure directory in $ENV{PATH} while running with -T switch at /usr/share/postgresql-common/PgCommon.pm line 656.
                                                                         [fail]
invoke-rc.d: initscript postgresql-8.3, action "stop" failed.
dpkg: не удалось обработать параметр /var/cache/apt/archives/postgresql-8.3_8.3.9-0ubuntu9.04_i386.deb (--unpack):
 подпроцесс новый сценарий pre-removal возвратил код ошибки 255
 * Starting PostgreSQL 8.3 database server                                       * Insecure directory in $ENV{PATH} while running with -T switch at /usr/share/postgresql-common/PgCommon.pm line 656.
                                                                         [fail]
invoke-rc.d: initscript postgresql-8.3, action "start" failed.
dpkg: ошибка при очистке -
 подпроцесс post-installation script возвратил код ошибки 255
При обработке следующих пакетов произошли ошибки:
 /var/cache/apt/archives/postgresql-8.3_8.3.9-0ubuntu9.04_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Вот пробовал remove делать - тоже ошибки

~# apt-get remove postgresql-8.3
Чтение списков пакетов... Готово
Построение дерева зависимостей       
Чтение информации о состоянии... Готово
Следующие пакеты устанавливались автоматически и больше не требуются:
  linux-headers-2.6.28-11 linux-headers-2.6.28-11-generic
Для их удаления используйте 'apt-get autoremove'.
Пакеты, которые будут УДАЛЕНЫ:
  postgresql-8.3
обновлено 0, установлено 0 новых пакетов, для удаления отмечено 1 пакетов, и 0 пакетов не обновлено.
не установлено до конца или удалено 1 пакетов.
После данной операции, объём занятого дискового пространства уменьшится на 14,2MB.
Хотите продолжить [Д/н]? y
dpkg: не удалось обработать параметр postgresql-8.3 (--remove):
 Пакет абсолютно неработоспособен -- перед удалением его
 следует переустановить.
При обработке следующих пакетов произошли ошибки:
 postgresql-8.3
E: Sub-process /usr/bin/dpkg returned an error code (1)

Вот кусок кода из файла /usr/share/postgresql-common/PgCommon.pm на 656 строке

# Change effective and real user and group id. Also activates all auxiliary
# groups the user is in. Exits with an error message if user/group ID cannot be
# changed.
# Arguments: <user id> <group id>
sub change_ugid {
    my ($uid, $gid) = @_;

    # auxiliary groups
    my $uname = (getpwuid $uid)[0];
    my $groups = "$gid " . `/usr/bin/id -G $uname`;        <<<--- строка 656

    $) = $groups;
    $( = $gid;
    $> = $< = $uid;
    error 'Could not change user id' if $< != $uid;
    error 'Could not change group id' if $( != $gid;
}

Re: Какая-то проблема с apt-get и postgresql-8.3

http://tinyurl.com/y9rl32q

Вы абсолютно правы - у кого-нибудь было.

t184256 ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.