LINUX.ORG.RU

Не ставится postgresql

 


0

1

делаю: apt-get install postgresql postgresql-client

Что-то там ставится, но в /etc/ конфигов постгреса нету.

Делаю:

aptitude --purge remove postgresql postgresql-client apt-get --reinstall install postgresql postgresql-client

Не помогает, конфигов нету.

dpkg-reconfigure postgresql

тоже не помогает.

Что делать?

★★★★★

9.1+123

dan@dan-desktop:~$ ls /etc/postgresql/9.1/main/
environment  pg_ctl.conf  pg_hba.conf  pg_ident.conf  postgresql.conf  start.conf

только что поставил

melkor217 ★★★★★ ()

Какая ветка Debian'a?

В /etc/init.d/ появился скрипт для запуска демона? Что будет, если попробовать его стартануть?

Anatolik ★★ ()
Ответ на: комментарий от Anatolik

6.0 скрипт появляется, при старте/рестарте рекации никакой. Так же нет команды postgres чтобы сервер запустить

Siado ★★★★★ ()
Ответ на: комментарий от Siado

Что пишется в /var/log/postgresql/postgresql-9.1-main.log, после «/etc/init.d/postgresql start»?

Anatolik ★★ ()
Ответ на: комментарий от Siado

Заодно можно в инит-скрипте вписать

set -x

set -v

и посмотреть, где он затыкатеся. Вдруг там ещё чего нет )

melkor217 ★★★★★ ()
Последнее исправление: melkor217 (всего исправлений: 1)
Ответ на: комментарий от pylin

а получилось по принципу не читай@сразу отвечай, прошу прощения)

pylin ★★★★★ ()

Конфиги постгреса находятся в postgresql-common. Его и надо реинсталировать.

at ★★ ()

локаль!

вывод locale -a в студию)))
небось темплейт openvz с покоцаными локалями, без en_US.UTF-8.
У вас initdb в процессе инстала не прошел.
Надо удалить psql, сгенерить локаль, поставить заново

vadv ★★ ()
Ответ на: комментарий от Anatolik

Нашел где оно лежит. В /usr/lib~, там же и бинарники. Почему-то ссылки не сделались.

Siado ★★★★★ ()
Ответ на: локаль! от vadv
$ locale -a
C
C.UTF-8
en_GB.utf8
en_US.utf8
POSIX
ru_RU.utf8

На кодировку, было дело, ругалось. Сначала сгенерил локаль, потом переустановил постгрес - не помогло.

Siado ★★★★★ ()

А в дебиане разве пакет сервера не называется как-то типа «postgresql-server», как в центосах?

berrywizard ★★★★★ ()

Была такая же фигня, но полечилась;

Танцевал с бубном. Удалял, чистил, ставил. Оно молча и без ошибок ставилось и нифига не появлялось. Но потом вдруг получилось после такой последовательности: 0. Убил все прессы, что могли держать памяти куски от postgresql 1. сгенерил список: aptitude search postgresql Сделал aptitude purge всем(!) пакетам по этому списку, что были помечены «i» или «с», от отчаяния и «v» :) 2. сделал поиск по диску файлов с словом postgresql и грохнул их! 3. перегрузился. 4. не запуская ни одной программы после загрузки сразу ввел aptitude update aptitude upgrade aptitude clean aptitude install postgresql-contrib

Все поднялось. почему не поднималось НЕ ЗНАЮ! делал теже вещи, но в других комбинациях, нифига не работало. Мистика!

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.