LINUX.ORG.RU

apt-get поломался


0

0

вот надумал тут устроить большую чистку - удалил до фига пакетов, а часть из них почему-то не удалилась и теперь при каждом обращении к aptitude выкидывает их в качестве ошибок. эти пакеты - capplets-data; gnome-media-common; libgtksourceview-common; metacity-common (я весь гном пытался удалить).

пожалуйста помогите мне разрешить их зависимости!

apt-get предлагает делать apt-get -f install, но это не помогает.


Re: apt-get поломался

теперь он сообщает, что не существует каталог /var/log/apt - что это значит?

xa3ap ()

Re: apt-get поломался

>(я весь гном пытался удалить).

Это прокляте великого хига пало на твою бренную систему, но мы с тобой в проклятия не верим, потому давай сюда то что выводил аптгет отказываясь удалять противный гном.

wfrr ★★☆ ()
Ответ на: Re: apt-get поломался от wfrr

Re: apt-get поломался

ну, на

~$ ls -l /var/log |grep apt

он отвечает

-rw-r--r-- 1 root root 14978 Сен 13 15:08 aptitude

али я Вас не так понял?

# apt-get -f install
Чтение списков пакетов... Готово
Построение дерева зависимостей
Чтение информации о состоянии... Готово
Исправление зависимостей... Готово
Следующие пакеты устанавливались автоматически и больше не требуются:
python-gnome2 libosp5 cheese w3c-dtd-xhtml alacarte gnome-menus python-numeric libcamel1.2-11
libtotem-plparser10 python-pyorbit libffi5 python-glade2 libebook1.2-9 libedataserver1.2-9
python-gmenu python-gtk2 python-cairo python-gobject
Для их удаления используйте 'apt-get autoremove'.
Будут установлены следующие дополнительные пакеты:
bwidget checkpolicy fam libcamel1.2-11 libebook1.2-9 libedataserver1.2-9 libfam0 libqpol1
libsetools-tcl python-glade2 python-gmenu python-gnome2 python-gobject python-gtk2
python-pyorbit python-selinux python-semanage python-sepolgen python-support
selinux-policy-default setools tk8.4
Предлагаемые пакеты:
python-gtk2-doc python-gobject-dbg logcheck syslog-summary
Пакеты, которые будут УДАЛЕНЫ:
capplets-data gnome-media-common libgtksourceview-common metacity-common
НОВЫЕ пакеты, которые будут установлены:
bwidget checkpolicy fam libcamel1.2-11 libebook1.2-9 libedataserver1.2-9 libfam0 libqpol1
libsetools-tcl python-glade2 python-gmenu python-gnome2 python-gobject python-gtk2
python-pyorbit python-selinux python-semanage python-sepolgen python-support
selinux-policy-default setools tk8.4
обновлено 0, установлено 22 новых пакетов, для удаления отмечено 4 пакетов, и 39 пакетов не обновлено.
не установлено до конца или удалено 9 пакетов.
Необходимо скачать 2113kB/14,6MB архивов.
После данной операции, объём занятого дискового пространства возрастёт на 18,1MB.
Хотите продолжить [Д/н]? y
Получено:1 http://ftp.fi.debian.org lenny/main libqpol1 3.3.5.ds-1 [204kB]
Получено:2 http://ftp.fi.debian.org lenny/main libsetools-tcl 3.3.5.ds-1 [592kB]
Получено:3 http://ftp.fi.debian.org lenny/main setools 3.3.5.ds-1 [1317kB]
Получено 2113kБ за 3s (576kБ/c)
(Чтение базы данных... на данный момент установлено 75129 файлов и каталогов.)
Удаляется пакет capplets-data...
dpkg: не удалось обработать параметр capplets-data (--remove):
не удалось удалить файл /usr/share/locale/pt/LC_MESSAGES/gnome-control-center-2.0.mo: Отказано в доступе
Удаляется пакет gnome-media-common...
dpkg: не удалось обработать параметр gnome-media-common (--remove):
не удалось удалить файл /usr/share/locale/pt/LC_MESSAGES/gnome-media-2.0.mo: Отказано в доступе
Удаляется пакет libgtksourceview-common...
dpkg: не удалось обработать параметр libgtksourceview-common (--remove):
не удалось удалить файл /usr/share/locale/pt/LC_MESSAGES/gtksourceview-1.0.mo: Отказано в доступе
Удаляется пакет metacity-common...
dpkg: не удалось обработать параметр metacity-common (--remove):
не удалось удалить файл /usr/share/locale/pt/LC_MESSAGES/metacity.mo: Отказано в доступе
Обрабатываются триггеры для man-db ...
При обработке следующих пакетов произошли ошибки:
capplets-data
gnome-media-common
libgtksourceview-common
metacity-common
E: Каталог /var/log/apt/ отсутствует
E: Sub-process /usr/bin/dpkg returned an error code (1)

xa3ap ()
Ответ на: Re: apt-get поломался от xa3ap

Re: apt-get поломался

>али я Вас не так понял?

Конечно, не так понял.

>ls -l /var/log |grep apt

выведет на экран список подкаталогов каталога /var/log, содержащих в названии apt + расширенная информация о правах доступа.

Создавать каталог надо так:

$sudo mkdir /var/log/apt

или если sudo не настроен, из-под рута:

#mkdir /var/log/apt

Demon37 ★★★★ ()
Ответ на: Re: apt-get поломался от xa3ap

Re: apt-get поломался

Ну удали эти пакеты: capplets-data, gnome-media-common, libgtksourceview-common, metacity-common ручками, т.е. с помощью dpkg, а потом снова выполни apt-get -f install.

Demon37 ★★★★ ()
Ответ на: Re: apt-get поломался от xa3ap

Re: apt-get поломался

>не удалось удалить файл /usr/share/locale/pt/LC_MESSAGES/gnome-control-center-2.0.mo: Отказано в доступе

Вот с этим гавном придется разбираться в ручную, может там и файла уже нет, тогда придется создать или еще что, в общем смотреть по месту. Я натыкался на такой геморой но почемуто он всегда происходил с гномом, будто там самые тупые майнтейнеры.

wfrr ★★☆ ()
Ответ на: Re: apt-get поломался от Demon37

Re: apt-get поломался

А если не получится, то сделай бэкап файлов (на всякий случай), которые не может удалить apt. И попробуй вручную (ну т.е. с помощью rm) удалить их. А потом снова apt-get -f install .

Demon37 ★★★★ ()
Ответ на: Re: apt-get поломался от xa3ap

Re: apt-get поломался

поковыряйся в prerm и postrm скриптах
для этих пакетов в /var/lib/dpkg/info -
иногда помогает

hyde ()

Re: apt-get поломался

удаляй по штучно(то что он там говорит, что не может) незабывай,ч то есть ещё аптитьюд... который странным образом но работает по другому

сделай aptitude update

MiklerGM ★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.