LINUX.ORG.RU
ФорумTalks

ag install gnome-terminal ... ипаать


0

0

[/home/fedor]
fedor_mobile root # ag install gnome-terminal                                                                               [8:08]
Чтение списков пакетов... Готово
Построение дерева зависимостей       
Reading state information... Готово                       
Будут установлены следующие дополнительные пакеты:
  alacarte avahi-daemon avahi-utils bind9-host capplets-data cupsys cupsys-client cupsys-common deskbar-applet desktop-base
  desktop-file-utils evolution-data-server evolution-data-server-common foomatic-db foomatic-db-engine foomatic-filters
  gnome-about gnome-applets gnome-applets-data gnome-control-center gnome-desktop-data gnome-doc-utils gnome-media
  gnome-media-common gnome-menus gnome-netstatus-applet gnome-panel gnome-panel-data gnome-power-manager gnome-session
  gnome-settings-daemon gnome-system-monitor gnome-terminal-data gnome-user-guide gnome-utils gstreamer0.10-alsa
  gstreamer0.10-plugins-base gstreamer0.10-plugins-good gstreamer0.10-x libapm1 libavahi-compat-libdnssd1 libavahi-core5
  libbeagle1 libcairomm-1.0-1 libcamel1.2-11 libcompress-raw-zlib-perl libcompress-zlib-perl libcpufreq0 libdaemon0 libebook1.2-9
  libecal1.2-7 libedata-book1.2-2 libedata-cal1.2-6 libedataserver1.2-9 libedataserverui1.2-8 libegroupwise1.2-13 libexempi3
  libfont-afm-perl libgdata-google1.2-1 libgdata1.2-1 libglibmm-2.4-1c2a libgnome-desktop-2 libgnome-media0
  libgnome-window-settings1 libgnomecups1.0-1 libgnomekbd-common libgnomekbd2 libgnomekbdui2 libgnomeprint2.2-0
  libgnomeprint2.2-data libgnomeprintui2.2-0 libgnomeprintui2.2-common libgtkmm-2.4-1c2a libgtksourceview-common
  libgtksourceview1.0-0 libgucharmap6 libhtml-format-perl libhtml-parser-perl libhtml-tagset-perl libhtml-tree-perl
  libio-compress-base-perl libio-compress-zlib-perl libmailtools-perl libmetacity0 libnautilus-burn4 libnet-dbus-perl libnss-mdns
  liboil0.3 liboobs-1-3 libpanel-applet2-0 librarian0 libshout3 libslab0 libslp1 libsoup2.4-1 libtie-ixhash-perl
  libtotem-plparser10 libtrackerclient0 liburi-perl libvisual-0.4-0 libvisual-0.4-plugins libwavpack1 libwww-perl libxklavier12
  libxml-parser-perl libxml-twig-perl libxml-xpath-perl libxml2-utils libxss1 metacity metacity-common nautilus
  nautilus-cd-burner nautilus-data poppler-utils python-beagle python-dbus python-fpconst python-glade2 python-gmenu
  python-gnome2 python-gnome2-desktop python-libxml2 python-pyorbit python-soappy samba-common smbclient ssl-cert
  system-tools-backends yelp
Предлагаемые пакеты:
  avahi-autoipd cups-pdf cupsys-bsd cupsys-driver-gutenprint foomatic-filters-ppds hplip xpdf-korean xpdf-japanese
  xpdf-chinese-traditional xpdf-chinese-simplified cupsys-pt gtklp kdeprint xpp gnome kde xfce4 wmaker evolution
  evolution-data-server-dbg foo2zjs foomatic-db-gutenprint foomatic-db-hpijs foomatic-gui cpufreqd cpudyn powernowd tomboy
  gnome-screensaver xscreensaver xbase-clients xrdb gnome-system-tools gnome2-user-guide gcalctool openslp-doc slpd
  libio-socket-ssl-perl libunicode-map8-perl libunicode-string-perl xml-twig-tools eog totem mp3-decoder tracker python-dbus-dbg
  python-dbus-doc python-gtk2-doc python-gnome2-desktop-doc smbfs
НОВЫЕ пакеты, которые будут установлены:
  alacarte avahi-daemon avahi-utils bind9-host capplets-data cupsys cupsys-client cupsys-common deskbar-applet desktop-base
  desktop-file-utils evolution-data-server evolution-data-server-common foomatic-db foomatic-db-engine foomatic-filters
  gnome-about gnome-applets gnome-applets-data gnome-control-center gnome-desktop-data gnome-doc-utils gnome-media
  gnome-media-common gnome-menus gnome-netstatus-applet gnome-panel gnome-panel-data gnome-power-manager gnome-session
  gnome-settings-daemon gnome-system-monitor gnome-terminal gnome-terminal-data gnome-user-guide gnome-utils gstreamer0.10-alsa
  gstreamer0.10-plugins-base gstreamer0.10-plugins-good gstreamer0.10-x libapm1 libavahi-compat-libdnssd1 libavahi-core5
  libbeagle1 libcairomm-1.0-1 libcamel1.2-11 libcompress-raw-zlib-perl libcompress-zlib-perl libcpufreq0 libdaemon0 libebook1.2-9
  libecal1.2-7 libedata-book1.2-2 libedata-cal1.2-6 libedataserver1.2-9 libedataserverui1.2-8 libegroupwise1.2-13 libexempi3
  libfont-afm-perl libgdata-google1.2-1 libgdata1.2-1 libglibmm-2.4-1c2a libgnome-desktop-2 libgnome-media0
  libgnome-window-settings1 libgnomecups1.0-1 libgnomekbd-common libgnomekbd2 libgnomekbdui2 libgnomeprint2.2-0
  libgnomeprint2.2-data libgnomeprintui2.2-0 libgnomeprintui2.2-common libgtkmm-2.4-1c2a libgtksourceview-common
  libgtksourceview1.0-0 libgucharmap6 libhtml-format-perl libhtml-parser-perl libhtml-tagset-perl libhtml-tree-perl
  libio-compress-base-perl libio-compress-zlib-perl libmailtools-perl libmetacity0 libnautilus-burn4 libnet-dbus-perl libnss-mdns
  liboil0.3 liboobs-1-3 libpanel-applet2-0 librarian0 libshout3 libslab0 libslp1 libsoup2.4-1 libtie-ixhash-perl
  libtotem-plparser10 libtrackerclient0 liburi-perl libvisual-0.4-0 libvisual-0.4-plugins libwavpack1 libwww-perl libxklavier12
  libxml-parser-perl libxml-twig-perl libxml-xpath-perl libxml2-utils libxss1 metacity metacity-common nautilus
  nautilus-cd-burner nautilus-data poppler-utils python-beagle python-dbus python-fpconst python-glade2 python-gmenu
  python-gnome2 python-gnome2-desktop python-libxml2 python-pyorbit python-soappy samba-common smbclient ssl-cert
  system-tools-backends yelp
обновлено 0, установлено 131 новых пакетов, для удаления отмечено 0 пакетов, и 1 пакетов не обновлено.
Необходимо скачать 116MB/116MB архивов.
After this operation, 343MB of additional disk space will be used.
Хотите продолжить [Д/н]? 

Re: ag install gnome-terminal ... ипаать

use urxvt-unicode + screen, luke.

anonymous ()

Re: ag install gnome-terminal ... ипаать

Тоже мне, открыл америку... =)

Хочешь я тебе вкратце перескажу всё то, что тебе выскажут почитатели сего ДЕ в качестве объяснения? "Гном модульный, поэтому в нём всё распихано по разным либам, а Кеды монолит, не юниксвей и вообще говно".

Кстати, сейчас в виртуалке ставится Убунта 8.04 --- попробую сделать в ней

$ sudo aptitude install konsole

и посмотрим, что получится.

Кстати, а нафига тебе понадобился гном-терминал?

MYMUR ★★★★ ()

Re: ag install gnome-terminal ... ипаать

убанту -- это убанту. это ubuntu-desktop,xubuntu-desktop итд. Зависимости там очень мощные :) Не хочешь дефолтовый стол -- use debian.

mrdeath ★★★★★ ()
Ответ на: Re: ag install gnome-terminal ... ипаать от mrdeath

Re: ag install gnome-terminal ... ипаать

если не лень, то выясни какая зависимость тянет за собой ненужные вещи и зарепорти баг. gnome-panel, gnome-power-manager и еще пачка добра там явно не при делах.

mrdeath ★★★★★ ()
Ответ на: Re: ag install gnome-terminal ... ипаать от MYMUR

Re: ag install gnome-terminal ... ипаать

> Хочешь я тебе вкратце перескажу всё то, что тебе выскажут почитатели сего ДЕ в качестве объяснения? "Гном модульный, поэтому в нём всё распихано по разным либам, а Кеды монолит, не юниксвей и вообще говно".

4.2 Сие есть проблема бубунты, а не гнома.

anonymous ()
Ответ на: Re: ag install gnome-terminal ... ипаать от anonymous

Re: ag install gnome-terminal ... ипаать

О да, а в не бубунтах gnome-terminal от самого гнома и его хлама не зависит...

Deleted ()
Ответ на: Re: ag install gnome-terminal ... ипаать от anonymous

Re: ag install gnome-terminal ... ипаать

>4.2 Сие есть проблема бубунты, а не гнома.

Ну ладно, вот тебе Дебиан:

deb-desktop:/home/mrz# apt-get install gnome-terminal
Чтение списков пакетов... Готово
Построение дерева зависимостей
Reading state information... Готово
Будут установлены следующие дополнительные пакеты:
  alacarte app-install-data capplets-data deskbar-applet desktop-base desktop-file-utils
  docbook-xml evolution-data-server evolution-data-server-common gconf2 gconf2-common gksu
  gnome-about gnome-applets gnome-applets-data gnome-control-center gnome-desktop-data
  gnome-doc-utils gnome-icon-theme gnome-keyring gnome-media gnome-media-common gnome-menus
  gnome-mime-data gnome-mount gnome-netstatus-applet gnome-panel gnome-panel-data
  gnome-power-manager gnome-session gnome-settings-daemon gnome-system-monitor gnome-terminal-data
  gnome-user-guide gnome-utils gstreamer0.10-alsa gstreamer0.10-plugins-base
  gstreamer0.10-plugins-good gstreamer0.10-x libapm1 libavahi-glib1 libbeagle1 libbonobo2-0
  libbonobo2-common libbonoboui2-0 libbonoboui2-common libcairo-perl libcairomm-1.0-1
  libcamel1.2-10 libcompress-raw-zlib-perl libcompress-zlib-perl libcpufreq0 libebook1.2-9
  libecal1.2-7 libedata-book1.2-2 libedata-cal1.2-6 libedataserver1.2-9 libedataserverui1.2-8
  libeel2-2.20 libeel2-data libegroupwise1.2-13 libenchant1c2a libexempi3 libfont-afm-perl
  libgconf2-4 libgksu2-0 libglib-perl libglibmm-2.4-1c2a libgnome-desktop-2 libgnome-keyring0
  libgnome-media0 libgnome-menu2 libgnome-window-settings1 libgnome2-0 libgnome2-canvas-perl
  libgnome2-common libgnome2-perl libgnome2-vfs-perl libgnomecanvas2-0 libgnomecanvas2-common
  libgnomecups1.0-1 libgnomekbd-common libgnomekbd2 libgnomekbdui2 libgnomeprint2.2-0
  libgnomeprint2.2-data libgnomeprintui2.2-0 libgnomeprintui2.2-common libgnomeui-0
  libgnomeui-common libgnomevfs2-0 libgnomevfs2-common libgnomevfs2-extra
  libgstreamer-plugins-base0.10-0 libgstreamer0.10-0 libgtk2-perl libgtkmm-2.4-1c2a
  libgtksourceview-common libgtksourceview1.0-0 libgtop2-7 libgtop2-common libgucharmap6
  libhtml-format-perl libhtml-parser-perl libhtml-tagset-perl libhtml-tree-perl
  libio-compress-base-perl libio-compress-zlib-perl libmailtools-perl libmetacity0
  libnautilus-burn4 libnautilus-extension1 libnet-dbus-perl liboil0.3 liboobs-1-3 liborbit2
  libpam-gnome-keyring libpanel-applet2-0 librarian0 librsvg2-common libscrollkeeper0 libsexy2
  libslab0 libsoup2.2-8 libtie-ixhash-perl libtotem-plparser10 libtrackerclient0 liburi-perl
  libvte-common libvte9 libwnck-common libwnck22 libwww-perl libxklavier12 libxml-parser-perl
  libxml-twig-perl libxml-xpath-perl libxml2-utils libxres1 metacity metacity-common nautilus
  nautilus-cd-burner nautilus-data notification-daemon python-beagle python-fpconst python-glade2
  python-gmenu python-gnome2 python-gnome2-desktop python-libxml2 python-pyorbit python-soappy
  scrollkeeper sgml-data sudo synaptic system-tools-backends yelp
Предлагаемые пакеты:
  gnome kde xfce4 wmaker docbook docbook-dsssl docbook-xsl docbook-defguide evolution
  evolution-data-server-dbg cpufreqd cpudyn powernowd tomboy esound-clients gnome-screensaver
  xscreensaver xrdb cryptsetup gnome-system-tools gnome2-user-guide gcalctool libbonobo2-bin
  libgnomevfs2-bin gnome-app-install libvisual-0.4-plugins gstreamer0.10-plugins
  gstreamer0.10-tools libgtk2-perl-doc libio-socket-ssl-perl libunicode-map8-perl
  libunicode-string-perl xml-twig-tools eog tracker python-gtk2-doc python-gnome2-desktop-doc
  perlsgml doc-html-w3 opensp dwww
НОВЫЕ пакеты, которые будут установлены:
  alacarte app-install-data capplets-data deskbar-applet desktop-base desktop-file-utils
  docbook-xml evolution-data-server evolution-data-server-common gconf2 gconf2-common gksu
  gnome-about gnome-applets gnome-applets-data gnome-control-center gnome-desktop-data
  gnome-doc-utils gnome-icon-theme gnome-keyring gnome-media gnome-media-common gnome-menus
  gnome-mime-data gnome-mount gnome-netstatus-applet gnome-panel gnome-panel-data
  gnome-power-manager gnome-session gnome-settings-daemon gnome-system-monitor gnome-terminal
  gnome-terminal-data gnome-user-guide gnome-utils gstreamer0.10-alsa gstreamer0.10-plugins-base
  gstreamer0.10-plugins-good gstreamer0.10-x libapm1 libavahi-glib1 libbeagle1 libbonobo2-0
  libbonobo2-common libbonoboui2-0 libbonoboui2-common libcairo-perl libcairomm-1.0-1
  libcamel1.2-10 libcompress-raw-zlib-perl libcompress-zlib-perl libcpufreq0 libebook1.2-9
  libecal1.2-7 libedata-book1.2-2 libedata-cal1.2-6 libedataserver1.2-9 libedataserverui1.2-8
  libeel2-2.20 libeel2-data libegroupwise1.2-13 libenchant1c2a libexempi3 libfont-afm-perl
  libgconf2-4 libgksu2-0 libglib-perl libglibmm-2.4-1c2a libgnome-desktop-2 libgnome-keyring0
  libgnome-media0 libgnome-menu2 libgnome-window-settings1 libgnome2-0 libgnome2-canvas-perl
  libgnome2-common libgnome2-perl libgnome2-vfs-perl libgnomecanvas2-0 libgnomecanvas2-common
  libgnomecups1.0-1 libgnomekbd-common libgnomekbd2 libgnomekbdui2 libgnomeprint2.2-0
  libgnomeprint2.2-data libgnomeprintui2.2-0 libgnomeprintui2.2-common libgnomeui-0
  libgnomeui-common libgnomevfs2-0 libgnomevfs2-common libgnomevfs2-extra libgtk2-perl
  libgtkmm-2.4-1c2a libgtksourceview-common libgtksourceview1.0-0 libgtop2-7 libgtop2-common
  libgucharmap6 libhtml-format-perl libhtml-parser-perl libhtml-tagset-perl libhtml-tree-perl
  libio-compress-base-perl libio-compress-zlib-perl libmailtools-perl libmetacity0
  libnautilus-burn4 libnautilus-extension1 libnet-dbus-perl liboil0.3 liboobs-1-3 liborbit2
  libpam-gnome-keyring libpanel-applet2-0 librarian0 librsvg2-common libscrollkeeper0 libsexy2
  libslab0 libsoup2.2-8 libtie-ixhash-perl libtotem-plparser10 libtrackerclient0 liburi-perl
  libvte-common libvte9 libwnck-common libwnck22 libwww-perl libxklavier12 libxml-parser-perl
  libxml-twig-perl libxml-xpath-perl libxml2-utils libxres1 metacity metacity-common nautilus
  nautilus-cd-burner nautilus-data notification-daemon python-beagle python-fpconst python-glade2
  python-gmenu python-gnome2 python-gnome2-desktop python-libxml2 python-pyorbit python-soappy
  scrollkeeper sgml-data sudo synaptic system-tools-backends yelp
Пакеты, которые будут обновлены:
  libgstreamer-plugins-base0.10-0 libgstreamer0.10-0
обновлено 2, установлено 159 новых пакетов, для удаления отмечено 0 пакетов, и 208 пакетов не обновлено.
Необходимо скачать 113MБ архивов.
After this operation, 375MB of additional disk space will be used.
Хотите продолжить [Д/н]?

Тоже "проблема Дебиана"?

У меня ещё Мандрива в виртуалбоксе, могу там попробовать, если хочешь ;) Скажи только мандрячий аналог apt-get install, чтобы показал что он собирается ставить и сколько это займёт (и чтобы отказаться можно было :))

MYMUR ★★★★ ()
Ответ на: Re: ag install gnome-terminal ... ипаать от MYMUR

Re: ag install gnome-terminal ... ипаать

Да, кстати:

mrz@mrz-ubuntu:~$ sudo aptitude install konsole
Чтение списков пакетов... Готово
Построение дерева зависимостей
Чтение информации о состоянии... Готово
Чтение информации о расширенных состояниях
Инициализация состояний пакетов... Готово
Построение базы данных тегов... Готово
Следующие пакеты будут автоматически удержаны:
consolekit hpijs hplip xserver-xorg xserver-xorg-video-amd
Следующие НОВЫЕ пакеты будут автоматически установлены:
kdelibs-data kdelibs4c2a libakode2 libarts1-akode libarts1c2a libartsc0
libavahi-qt3-1 liblua50 liblualib50 libqt3-mt
Следующие пакеты оставлены не обновлёнными:
linux-generic linux-headers-generic linux-image-generic
linux-restricted-modules-generic ubuntu-desktop
Следующие НОВЫЕ пакеты будут установлены:
kdelibs-data kdelibs4c2a konsole libakode2 libarts1-akode libarts1c2a
libartsc0 libavahi-qt3-1 liblua50 liblualib50 libqt3-mt
0 пакетов обновлено, 11 установлено новых, 0 пакетов отмечено для удаления, и 10 пакетов не обновлено.
Необходимо получить 22,4MB архивов. После распаковки 74,5MB будет занято.
Хотите продолжить? [Д/н/?]

MYMUR ★★★★ ()

Re: ag install gnome-terminal ... ипаать

Ну дык gtk это Ъ

DNA_Seq ★★☆☆☆ ()

Re: ag install gnome-terminal ... ипаать

Умолчательный apt считает recommends-зависимости сильными. Попробуй положить в /etc/apt/apt.conf.d файлик со строчкой:

APT::Install-Recommends "0";

Должно стать чуть поменьше.

watashiwa_daredeska ★★★★ ()
Ответ на: Re: ag install gnome-terminal ... ипаать от MYMUR

Re: ag install gnome-terminal ... ипаать

Мандрива 2007.1, КДЕ
# urpmi --test gnome-terminal
ftp://192.168.1.200/pub/linux/mandriva/2007.0/i586/media/main/gnome-terminal-2. 16.0-1mdv2007.0.i586.rpm
устанавливается gnome-terminal-2.16.0-1mdv2007.0.i586.rpm из /var/cache/urpmi/rpms
Подготовка... ############################################################################
Установка возможна.

redgremlin ★★★★★ ()

Re: ag install gnome-terminal ... ипаать

Это не проблемы гнома, это неумение пользоваться аптом.

zpp ()
Ответ на: Re: ag install gnome-terminal ... ипаать от vit122

Re: ag install gnome-terminal ... ипаать

ну даже я, гномер, с трудом представляю как gnome-terminal зависит от gnome-panel и уж тем более от gnome-power-manager :) Че душой кривить то, скорее всего зависимости слишком жесткие у кого-то

mrdeath ★★★★★ ()
Ответ на: Re: ag install gnome-terminal ... ипаать от mrdeath

Re: ag install gnome-terminal ... ипаать

Да не от них он зависит, а от гнома в целом. Может конечно кому-то и интересен гном-терминал, оторваный от всей инфраструктуры гнома, но обычно она нужна вся. Мне вот не нравится evolution и я его всегда выношу, и ничего. Никакие "зависимости" мне это сделать не мешают.

vit122 ()

Re: ag install gnome-terminal ... ипаать

% sudo pacman -Sy gnome-terminal
Пароль: 
:: Синхронизируется база данных пакетов...
 core не устарел
 extra                    310,8K   13,9K/s 00:00:22 [#####################] 100%
 community                334,0K   21,5K/s 00:00:16 [#####################] 100%
разрешение зависимостей...
проверка на взаимную несовместимость...

Цели: gnome-terminal-2.22.0-1  

Размер загружаемых файлов:   2,55 МБ

Приступить к установке? [Y/n] 


% sudo pacman -Qs gnome         
local/fam 2.7.0-10
    File Alteration Monitor - used by KDE, GNOME and others
local/gail 1.22.0-1
    The GNOME Accessibility Project
local/gnome-icon-theme 2.22.0-1 (gnome)
    Default icon theme for GNOME2
local/gnome-keyring 2.22.0-2
    GNOME Password Management daemon
local/gnome-menus 2.22.0-1
    GNOME menu specifications
local/gnome-mime-data 2.18.0-3 (gnome)
    The base MIME and Application database for GNOME
local/gnome-python 2.22.0-1
    gnome-python is a set of interfaces to gnome-libs.
local/gnome-python-extras 2.14.3-1
    Gnome Python interfaces for libraries not part of the core platform
local/gnome-vfs 2.22.0-2
    The GNOME Virtual File System
local/gnumeric 1.8.2-1
    A GNOME Spreadsheet Program
local/gucharmap 2.22.0-1 (gnome-extra)
    Gnome Unicode Charmap
local/icon-naming-utils 0.8.6-1
    Maps the new names of icons for Tango to the legacy names used by the GNOME
    and KDE desktops.
local/libcroco 0.6.1-1
    GNOME CSS2 parsing and manipulation toolkit
local/libgnome 2.22.0-1
    Common libraries for GNOME
local/libgnomecanvas 2.20.1.1-1
    The GNOME Canvas library
local/libgnomecups 0.2.3-1
    GNOME cups library
local/libgnomeprint 2.18.3-1
    Printing routines for GNOME
local/libgnomeprintui 2.18.2-1
    User Interface library for printing with GNOME
local/libgnomeui 2.22.01-1
    User Interface library for GNOME
local/libgsf 1.14.8-1
    The GNOME Structured File Library is a utility library for reading and
    writing structured file formats.
local/libgsf-gnome 1.14.8-1
    Adds gnome support to libgsf
local/xfwm4 4.4.2-2 (xfce4)
    Xfce window manager, compatible with Gnome, Gnome2, KDE2, and KDE3

Т.е. от гнума в основном либы и всякие значки, частично гномицеский офис.

Если кто не понял, что это арч.

marsijanin ★★ ()
Ответ на: Re: ag install gnome-terminal ... ипаать от marsijanin

Re: ag install gnome-terminal ... ипаать

У арча тоже достаточно кривых зависимостей. Чего только стардикт, собранный в фестивалем стоит. И не пересобирается сцуко, ошибки какие-то.

Midael ★★★★★ ()

Re: ag install gnome-terminal ... ипаать

В дебиане gnome-terminal зависит от gnome-control-center. Он похоже и тянет всё остальное.

Midael ★★★★★ ()
Ответ на: Re: ag install gnome-terminal ... ипаать от MYMUR

Re: ag install gnome-terminal ... ипаать

В мандриве в своё время ставил без gstreamer-а гном, дальше думай сам.

anonymous ()
Ответ на: Re: ag install gnome-terminal ... ипаать от zort

Re: ag install gnome-terminal ... ипаать

чтобы из исходников собрать нужно dev пакеты установить а это еще большу мусора в систему ставить А по теме - у тебя раздел на винте 1 гиг ?

anonymous ()

Re: ag install gnome-terminal ... ипаать

И только гента спасет отцов русской демократии!

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.