LINUX.ORG.RU

xkb


0

0

После обновления Xfree получил следующую проблему, такое ощущение, что xkb работает неправильно, т.к. проблема интересная, от чего раскладка по дефолту русской становится... Имею в конфиге иксов.

Option "XkbRules" "xfree86" Option "XkbModel" "pc105" Option "XkbLayout" "ru" Option "XkbVariant" "winkeys" Option "XkbOptions" "grp:ctrl_shift_toggle,grp_led:scroll"

Это было и до этого, и все просто замечательно работало.

Однако теперь получаю только русскую раскладку, а переключение не работает совершенно, и русский выключить не могу, что весьма странно.

Вроде как сам xkb установлен, все его части на месте?

если я меняю Option "XkbLayout" "ru" на "en", то тогда только английская раскладка, а русскую тоже не включить..

Заранее спасибо!

anonymous

Re: xkb

IMHO, проблема с раскладкой "ru"( скорее всего в ней нет кодов для английский букв).
По документам Ивана Паскаля сделай новую раскладку, т.е. нужно скопировать "en" и сверяясь с "ru" добавлять в новую раскладку, для каждой клавиши её русский код.
Удачи!

Dux ()

Re: xkb

Я эту долго сам мучался - никак не получалось! потом сделал "XkbLayout" "ru,us" и всё ок

anonymous ()

Re: xkb

Точнее

/etc/X11/XF86Config:

Identifier "Keyboard0" Driver "keyboard" Option "XkbRules" "xfree86" Option "XkbModel" "pc105" Option "XkbLayout" "us,ru" Option "XkbOptions" "grp:ctrl_shift_toggle,grp_led:scroll"

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.