LINUX.ORG.RU

rpm


0

0

pomogite s rpm - ya ego zaporol, ne tu versiu db3 postavil, voobshem vot chto on shas pishet esli ya postavit' hochu che-nit':
rpmdb: Program version 3.3.11 doesn't match environment version 4.0.14
error: db3 error(22) from dbenv->open: Invalid argument
error: cannot open Packages index using db3 - Invalid argument (22)
error: cannot open Packages database in /var/lib/rpm
kak vernut' obratno versiu? u menya tolko 1 misl' - reinstall rpm s diska s distrom.

anonymous

Re: rpm

postav' nazad to sho bylo v ruchnuju (rpm - eto arhiv): otkryvaesh blabla.i386.rpm i kopiruesh faily i diry tuda kuda nuzno

Umka ()

Re: rpm

Возьми свою старую db3 (из старых rpm)
Потом делаешь так:
rpm --nodeps --force __твоя_rpm_С_либой
В системе всегда есть rpm статически собранный.

А вообще лучше бы слазил на ftp.altlinux.ru, забрал
бы их rpm с либами (и сам rmp) и поставил себе.

Мда, на всякий случай, потом сделай так
rpm -rebuilddb

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.