LINUX.ORG.RU

Steam и Radeon. Не запускается.

 , , ,


0

1

День добрый!

Дистрибутив OpenSUSE Tumbleweed. Steam установлен из репозитория, до этого стояла карточка NVIDIA, все работало. Поставил AMD rx 580. И в 2020 году понял, что они так и не научились делать нормальные дрова. Драйвер скачан с сайта для SLED 15, X11 понижен до версии из Leap 15.1, так как драйверу нужен «X11_ABI_VIDEODRV = 24». Драйвер установился. Запустился xonotic-glx на ультрах, но Steam при запуске начинает выдавать вот это:

Running Steam on opensuse-tumbleweed 20200504 64-bit
STEAM_RUNTIME is enabled automatically
Pins up-to-date!
Steam client's requirements are satisfied
/home/rchnh2cooh/.local/share/Steam/ubuntu12_32/steam
Installing breakpad exception handler for appid(steam)/version(1589513816)
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: radeonsi
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: radeonsi
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
Installing breakpad exception handler for appid(steam)/version(1589513816)
Installing breakpad exception handler for appid(steam)/version(1589513816)
/usr/share/themes/Breeze/gtk-2.0/widgets/entry:70: error: unexpected identifier 'direction', expected character '}'

(steam:20107): Gtk-WARNING **: 18:51:53.403: Unable to locate theme engine in module_path: "adwaita",
/usr/share/themes/Breeze/gtk-2.0/widgets/styles:36: error: invalid string constant "combobox_entry", expected valid string constant
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: radeonsi
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: radeonsi
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: radeonsi
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: radeonsi
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
Installing breakpad exception handler for appid(steam)/version(1589513816)
STEAM_RUNTIME_HEAVY: ./steam-runtime-heavy
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: radeonsi
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: radeonsi
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
Error: OpenGL GLX context is not using direct rendering, which may cause performance problems. 

Ядро - 5.6.8

Mesa-32bit установлена,

удаление конфликтующих библиотек(libstd и т.д.) пробовал(до удаления запускался, но не в работоспособном виде),

STEAM_RUNTIME=0 не помогает.

Куда копать дальше? Может кто сталкивался.

Драйвер скачан с сайта для SLED 15, X11 понижен до версии из Leap 15.1, так как драйверу нужен «X11_ABI_VIDEODRV = 24».

Сам себе злобный буратино. Говорили же вам, что AMDGPU PRO нужен только для OpenCL.

Ядро - 5.6.8

Модуль amdgpu там свежий. Просто накати последнюю Mesa и пользуйся.

И в 2020 году понял, что они так и не научились делать нормальные дрова.

AMD должно править хозяевам железа кривые руки?

Meyer ★★★★ ()
Ответ на: комментарий от XtouRusX

я не знаю, у тебя на Tumbleweed самые свежие Mesa и ядро.

glxgears 150 фпс выдает всего

у меня такая же видеокарта как у тебя и выдает 60 FPS потому что синхронизирована с частотой обновления экрана, это вообще не показатель.

Не занимайся ерундой, откати все пакеты на стоковые, то и будет твой лучший драйвер.

awesomenickname ★★★★★ ()
Ответ на: комментарий от awesomenickname

Ну так у меня монитор стандартный, а не 144. Если бы был синхронизирован с монитором, то показывал бы тоже в районе 60. С этим драйвером показывает 1600 фпс, то есть ускорение работает нормально. Капризничает Steam. Если ничего не поможет, то придется откатиться на стандартные и с ними шаманить что-то. Но хотелось бы понять, что ему сейчас не хватает.

XtouRusX ()
Ответ на: комментарий от XtouRusX

https://askubuntu.com/questions/834254/steam-libgl-error-no-matching-fbconfigs-or-visuals-found-libgl-error-failed-t

может у тебя задвоение библиотек libGL, посмотри по ссылке, ты ж навелосипедил с закрытым драйвером

awesomenickname ★★★★★ ()
Ответ на: комментарий от XtouRusX

Стандартный драйвер 150 фпс и просадки при изменении размера окна, на amdgpu стабильно 1599.

ЛОЛ, что ты называешь amdgpu? drm? Так они не отличаются, в userspace у тебя либо проприетраные блобы реализующие графические api, либо mesa, но mesa работает лучше.

150 фпс и просадки при изменении размера окна,

А ты вообще уверен что у тебя работало аппартаное ускорение? Может это была программная растеризация, потому как ты firmware не поставил и gpu не завелся.

anonymous ()
Ответ на: комментарий от XtouRusX

проверь корректно ли удалил nvidia драйвер, возможно удали конфиги стима, и попробуй заново.

такое чувство у тебя где-то еще либы валяются и стим их подтягивает.

такое может быть у тебя вообще не настроено 3д ускорение из-за конфликта библиотек.

awesomenickname ★★★★★ ()
Последнее исправление: awesomenickname (всего исправлений: 1)
Ответ на: комментарий от xDShot

Откатил на драйвер из репозиториев. Часть игр(которые запускаются вайном торомозят. Dark Souls не тормозит), видео в браузере при переключении вкладок замирает(звук идет), разворачивание видео на весь экран происходит не сразу. На nvidia 1030, таких глюков не было.

XtouRusX ()
Ответ на: комментарий от anonymous
glxinfo | grep OpenGL
OpenGL vendor string: X.Org
OpenGL renderer string: Radeon RX 580 Series (POLARIS10, DRM 3.36.0, 5.6.11-1-default, LLVM 10.0.0)
OpenGL core profile version string: 4.6 (Core Profile) Mesa 20.0.6
OpenGL core profile shading language version string: 4.60
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 4.6 (Compatibility Profile) Mesa 20.0.6
OpenGL shading language version string: 4.60
OpenGL context flags: (none)
OpenGL profile mask: compatibility profile
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.2 Mesa 20.0.6
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20
OpenGL ES profile extensions:

Пакеты:

zypper pa | grep amdgpu
i+ | Основной репозиторий (OSS)      | kernel-firmware-amdgpu                                                  | 20200424-1.1                                         | noarch
i+ | openSUSE:Factory                | kernel-firmware-amdgpu                                                  | 20200424-1.1                                         | noarch
i+ | openSUSE:Tumbleweed             | kernel-firmware-amdgpu                                                  | 20200424-1.1                                         | noarch
i+ | Основной репозиторий (OSS)      | libdrm_amdgpu1                                                          | 2.4.101-1.1                                          | x86_64
i+ | openSUSE:Factory                | libdrm_amdgpu1                                                          | 2.4.101-1.1                                          | x86_64
i+ | openSUSE:Tumbleweed             | libdrm_amdgpu1                                                          | 2.4.101-1.1                                          | x86_64
i+ | Основной репозиторий (OSS)      | libdrm_amdgpu1-32bit                                                    | 2.4.101-1.1                                          | x86_64
i+ | openSUSE:Factory                | libdrm_amdgpu1-32bit                                                    | 2.4.101-1.1                                          | x86_64
i+ | openSUSE:Tumbleweed             | libdrm_amdgpu1-32bit                                                    | 2.4.101-1.1                                          | x86_64
i+ | Основной репозиторий (OSS)      | xf86-video-amdgpu                                                       | 19.1.0-3.1                                           | x86_64
i+ | openSUSE:Factory                | xf86-video-amdgpu                                                       | 19.1.0-3.1                                           | x86_64
i+ | openSUSE:Tumbleweed             | xf86-video-amdgpu                                                       | 19.1.0-3.1                                           | x86_64

XtouRusX ()
Ответ на: комментарий от XtouRusX

Часть игр(которые запускаются вайном торомозят. Dark Souls не тормозит)

Если это периодические небольшие паузы то причина возможно в компиляции шейдеров. MESA драйвер собран с LLVM который и осуществляет компиляцию шейдеров и он делает это не достаточно быстро. Три-четыре года назад это не было проблемой т.к. игры компилировали шейдеры перед запуском, а теперь игры это делают динамически, по мере необходимости в процессе игровой сессии.

Насколько я знаю проприетрный драйвер не использует LLVM, а что-то свое и делает компиляцию шейдеров быстрее.

Но в открытом дайвере теперь появился новый компилятор ACO, который это делает лучше, я не знаю есть ли он в поставке mesa из коробки и как его включить, возможно так RADV_PERFTEST=aco ./steam, я просто в игры последние пару лет не играл.

браузере при переключении вкладок замирает(звук идет), разворачивание видео на весь экран происходит не сразу

Такого не встречал, у меня была rx470, сейчас итегрированные vega 3 и 8, десктоп работает идеально. Дистр Ubuntu 19.10-20.04.

anonymous ()
Ответ на: комментарий от anonymous

Спасибо за помощь, буду плясать с бубном. Видимо линуксоидам есть смысл переплачивать за Nvidia, для своего личного спокойствия =). Иначе рулетка получается, заведется у тебя драйвер без проблем или нет.

XtouRusX ()
Ответ на: комментарий от anonymous

Дело в том, что пека не мой. И на него по причине старого железа был установлен линукс. Ибо под XP уже не поддерживался софт, а под 7-ку и 10-ку не было дров. Комп постепенно обновился, но пользователь обратно на винду не хочет уже, и список игр не большой, большая часть доступна под linux. И последнее обновление видеокарты вызвало такие казусы.

XtouRusX ()
Ответ на: комментарий от XtouRusX

Только игровым линуксоидам, десктоп на amd обычно работает идеально и из коробки, например если ты возьмешь любой образ загружаемый с флешки с ядром версии 5+ у тебя сразу заработает видокарат и там наверняка не будет проблем с броузером, тирингом, черными экранами. Прямо сейчас тебя какая-то аномалия с десктопом.

А nvidia… ну например у меня в ноуте 1050 и она просто виснет с открытым nouveau, т.е. только чтоб загрузится нужно в груб прописывать в blacklist этот модуль. Ну и плюс конкретно 1050 даже когда не используется потребляет много энергии (вроде начиная с 1650 с этим лучше), для меня автономность важна а дискретка неважна. Про wayland рассказывать не буду, меня он пока не устраивает чтоб возможность работы с ним было преимуществом :)

anonymous ()
Ответ на: комментарий от anonymous

Это шутка? ) Во-первых глаз не видит никаких FPS, зрение не дискретно, а во вторых количество FPS - это показатель корректности работы видеодрайвера и производительности.

P.S. Ну и попробуйте в игре какой-нибудь залочить ФПС на 24, а потом на 60 хотя бы, и удивитесь.

XtouRusX ()

X11 понижен до версии

Не особо разбираюсь но как я понял месу и вслед за ней иксы лучше иметь распоследние.

Мой опыт от конца к началу

Совсем новые библиотеки для Steam тоже плохо, запустится он запустится, но на Debian Bullseye в отличии от Buster часть игр не работает и проблема похоже именно с библиотеками, а не драйверами.

torvn77 ★★★★★ ()
Последнее исправление: torvn77 (всего исправлений: 8)
Ответ на: комментарий от torvn77

На сайте AMD есть драйвер, завернутый в RPM для SUSE(SLED), и этот пакет с новыми X11 не хочет устанавливаться, ему нужны именно те, которые в репозитории SLED-а, именно потому иксы и были понижены.

Ну и да, дело скорее в библиотеках. Так как тот же Xonotic запускается одинаково. А вот Steam капризничает.

XtouRusX ()
Последнее исправление: XtouRusX (всего исправлений: 1)
Ответ на: комментарий от anonymous

xxx> Установил проприетарный драйвер AMD, всё работает, но странные сообщения при запуске Steam
yyy> Установи открытый драйвер он ЛУУУУУЧШЕ!
xxx> Установил открытый драйвер, что-то стало хуже
yyy> Ну ты подкрути тут, подставь костылик здесь... Открытый драйверы ЛУУУУУЧШЕ!

anonymous ()
Ответ на: комментарий от XtouRusX

Стим по-прежнему 32-битный. Скорее всего, 32-битная библиотека OpenGL не установилась правильно, а 64-битная установилась правильно. В этом сообщении говорят правильно.

Открой YAST посмотри пакеты с закрытыми драйверами AMD. А есть ли вообще 32-битная библиотека OpenGL? Если да, то где она?

anonymous ()
Ответ на: комментарий от anonymous

Стим по-прежнему 32-битный. Скорее всего, 32-битная библиотека OpenGL не установилась правильно, а 64-битная установилась правильно.

С Opengl скорее всего всё ОК, а вот wine и proton зависят от вулкана, он же amdvlk и вот его мантейнеры Debian’a поставляют только 64битным, если на Suse то же самое, то значит amdvlk скомпилипованный под i386 надо ставить из исходников самостоятельно, только версию надо правильную подобрать, чтобы Стим не писал про неопознанные версии.
Но вообще лично я начинаю склонятся к тому чтобы просто поместить Steam в wine и забыть о его капризах(amdvlk имхо всёже откомпелять потребуется)

torvn77 ★★★★★ ()
Последнее исправление: torvn77 (всего исправлений: 3)

Дистрибутив OpenSUSE Tumbleweed. Steam установлен из репозитория, до этого стояла карточка NVIDIA, все работало. Поставил AMD rx 580. И в 2020 году понял, что они так и не научились делать нормальные дрова.

Ну для игор и OpenCL-фана «дрова» у них так себе, для остального сойдет. Только зачем ты себ больно сделал заменив видеокарту на радеон?

RedEyedMan666 ()
Ответ на: комментарий от anonymous

xxx> Установил открытый драйвер, что-то стало хуже

Проприетарными почти никто не пользуется, они объективно хуже кроме пары кейсов, потому когда человек описывает проблемы с проприетарными дравами ему мало кто может помочь, ведь даже те кто пытался их использовать в конечном итоге уходили на открытые, потому как они банально стабильнее работают.

anonymous ()
Ответ на: комментарий от torvn77

Steam не зависит от Vulkan. При старте он проверяет именно OpenGL. Да и логи, которые ты привёл, прямо об этом говорят.

У тебя явно 64-битная библиотека OpenGL была заменена на проприетарную, а 32-битная осталась Mesa-вской. Подмени симлинк на библиотеку на правильный путь, и всё будет хорошо.

Хотя правильно решать проблему, указав путь до нужной директории с 32-битным OpenGL в /etc/ld.so.conf.d/anyfile.conf

ZenitharChampion ★★★★★ ()
Ответ на: комментарий от ZenitharChampion

Ещё можно LIBGL_ALWAYS_SOFTWARE=1 steam (взял отсюда). Тогда 32-битная библиотека Mesa будет работать в софтварном режиме, а 64-битная проприетарная библиотека будет работать аппаратно. Стим запустится, но отрисовка его интерфейса будет грузить проц.

Хотя фиг знает, может эта переменная и на проприетарную библиотеку повлияет

ZenitharChampion ★★★★★ ()
Последнее исправление: ZenitharChampion (всего исправлений: 1)
Ответ на: комментарий от ZenitharChampion

При старте он проверяет именно OpenGL.

Вулкан тоже проверяет и пишет сообщение о ошибке.

Steam не зависит от Vulkan.

Но от него зависит Стимовский Proton, по крайней мере без дополнительных настроек.
И если Proton не работает то часть игрушек может не запускаться, и это не говоря о том, что часть игрушек работают только на Vulkan’е.

torvn77 ★★★★★ ()