LINUX.ORG.RU

(deb) Откат на libc6=2.29-10 спасите-помогите

 


0

1

Привет. На днях не предал значения и обновился на libc6=2.30

Ничерта теперь не работает как надо. Задача: любой ценой вернуться на 2.29.

В репозиториях ее попросту нету. есть 2.28, но она не становится даже в ручную матерясь на зависимости (система была установлена с 2.29)

Что делать? нид хелп….

Ответ на: комментарий от swagcat228

Теперь твоя задача: прочесть вот эту ссылку ( https://www.kali.org/docs/introduction/should-i-use-kali-linux/ ), осознать, что если сами разработчики не советуют использовать их дистрибутив для чего-то кроме пентестов и указывают, что он может странно глючить при использовании как обычный десктоп — то есть повод таки прислушаться и перейти на что-то нормальное.

Vsevolod-linuxoid ★★★★★ ()
Ответ на: комментарий от swagcat228

Что угодно. Форум полон тем от пользователей Kali, которые натыкались на самые дикие и непредсказуемые глюки. Я уже кидал ссылку — для этого _узкоспециального_ дистрибутива подобное поведение нормально, сами разработчики честно об этом пишут.

Решение: перейти на что-то иное. Или если всё же нужен именно Kali для пентестов — переустановить.

Vsevolod-linuxoid ★★★★★ ()
Ответ на: комментарий от anti_win

да я добавил кали, т.к. мне нужно было быстро оттуда качнуть кое-что. и забыл убрать) и качнул новый либц….

pt-get install libc6=2.28-10 Reading package lists… Done Building dependency tree
Reading state information… Done libc6 is already the newest version (2.28-10). You might want to run ‘apt –fix-broken install’ to correct these. The following packages have unmet dependencies: alsa-utils : Depends: libc6 (>= 2.29) but 2.28-10 is to be installed cargo : Depends: libc6 (>= 2.29) but 2.28-10 is to be installed chromium : Depends: libc6 (>= 2.29) but 2.28-10 is to be installed cryfs : Depends: libc6 (>= 2.29) but 2.28-10 is to be installed cups-filters : Depends: libc6 (>= 2.29) but 2.28-10 is to be installed deepin-terminal : Depends: libc6 (>= 2.29) but 2.28-10 is to be installed edb-debugger : Depends: libc6 (>= 2.29) but 2.28-10 is to be installed etherape : Depends: libc6 (>= 2.29) but 2.28-10 is to be installed exim4-daemon-light : Depends: libc6 (>= 2.29) but 2.28-10 is to be installed

и дальше весь список пакетов что установлены на системе

swagcat228 ()
Ответ на: комментарий от swagcat228

Вообще, ситуация достаточно сложная. Наверно, проще идти переустанавливать. Только ставить нормальный дистр. Кали не предназначен для десктопного применения. Но все-таки интересно, можно ли с это что-то сделать?

anti_win ★★ ()
Ответ на: комментарий от DELIRIUM

основная проблема сраного libc-2.30 в том, что не работают лики памяти через got&plt и разработака сплоитов становится не возможной, а в виртуалку идти в лом. Не знаю как там ваше кали поживает, но мне бы просто либу откатить

swagcat228 ()
Ответ на: комментарий от swagcat228

libc — это один из стандартных компонентов линукса. Другое дело, что я не знаю способов даунгрейда в дебиане. Может, кто-нибудь знает аналог описанного мной арчевского способа?

anti_win ★★ ()
Ответ на: комментарий от DELIRIUM

Нормальный дебиан ставится меньше, чем за 10 рублей

Делирий, ты не безобразничай тут больше, а то одна звезда осталась. Береги ее.

Владимир

anonymous ()