LINUX.ORG.RU

Не удается установить пакет elementary-desktop (elementary os)

 


0

1

Всем привет! Очень прошу помощи, второй день бьюсь. В Linux я новичок (был опыт только с raspbian), извините, если вопрос тупой =) Пытаюсь установить на старый нетбук 32х разрядную elementary os по статье https://pctuner.club/n/2379 Там рассказывается об установке голой версии ubuntu 16.04 и далее установка elementary os. Все потому, что официально elementary os только 64 битная (это вы все знаете). Почти все по статье получилось выполнить, кроме последнего, но, очевидно, самого важного - установки пакета elementary-desktop Пишу: sudo apt-get install elementary-desktop Получаю:

Чтение списка пакетов... Готово
Построение дерева зависимостей
Чтение информации о состоянии... Готово
E: Невозможно найти пакет elementary-desktop

Немного подробностей: как советует автор, дистрибутив качаю c https://ubuntu.com/download/alternative-downloads Но версия 16.04 у меня по непонятным причинам не загружается после установки (я нуб - забил), поэтому скачал 18.04. Конкретно: http://archive.ubuntu.com/ubuntu/dists/bionic-updates/main/installer-i386/current/images/netboot/mini.iso

Установка прошла по инструкции, все ок. Установил пакеты, указанные автором статьи (кроме последнего, с которым проблема). После перезапуска вижу в консоли:

Welcome to elementary OS 5.0 Juno (GNU/Linux 4.15.0-66-generic i686) Built on Ubuntu 18.04.2 LTS

Т.е. внешне - вроде все круто, но нужен GUI. Логически я рассуждаю так, что если при входе в систему мне УЖЕ система пишет «Welcome to elementary OS 5.0», то система установлена и графический интерфейс уж как-то можно установить. Пожалуйста, подскажите где я туплю и как установить пакет elementary-desktop?


У тебя версия Убунту 18.04, а пакеты собраны для 16.04, естественно, пакетный менеджер их не находит. Ну и смысла возиться с 32-битным софтом нет никакого, прирост в скорости будет в пределах статпогрешности. Если тебе реально нужна лёгкая система, ставь более консервативное окружение, вроде Xfce или чего-то такого. В Linux Mint очень неплохо собирают Xfce, к слову.

meliafaro ★★★★★ ()

Зачем ты ставишь вообще эту ОС ? Поставь просто Plank и какой нибудь gnome metacity flashblack или только plank , в /etc/xdg/autostart сделаешь что бы он всегда запускался ярлык и в /usr/share/xsessions тоже вот тебе и ось потом переименовываешь и выдаешь в свет новую ОС ловишь за неё донаты и аплодисменты стоя.

anonymous ()
Ответ на: комментарий от best_elfo

В общем, я догадывался. Но думал, что раз все остальное установилось, то и desktop можно как-то запилить. Я понимаю, если бы вообще ни один пакет не установился. 16.04 тоже пробовал, но там у меня сама ubuntu почему-то не взлетела. После загрузки вижу надпись: dev/sda1: clean, 552599/6111232 files, 7119295/24414464 blocks Знаю, что это не ошибка, но больше ничего не появляется. Висит.

Гуглил по этой теме. Нажимаю Alt+Shift+F2 - логинюсь. После чего указанные в статье пакеты вообще не могу установить. Система пишет, что временные проблемы с доступом или что-то такое. И везде на права ругается, даже с sudo. Я решил, что при установке где-то накосячил, но не понял где. Попробовал ещё раз переустановить - то же самое. Поэтому и начал 18 версию пробовать, т.к. она запускается без проблем у меня.

SEsin ()
Ответ на: комментарий от best_elfo

Хочу сам в этом убедиться )) А есть варианты решить проблему с 16.04? После загрузки вижу надпись: dev/sda1: clean, 552599/6111232 files, 7119295/24414464 blocks Знаю, что это не ошибка, но больше ничего не появляется. Висит. После авторизации никуда не пускает, ругается на права доступа.

SEsin ()