LINUX.ORG.RU

Что происходит с кириллицей в libreoffice + KDE?

 , , ,


0

1

Здравствуйте!

Имею Arch Linux с актуальными обновлениями на сегодняшнюю дату(ядро 5.0.10 x86_64), KDE Plasma 5.15.4, libreoffice-still 6.1.5-5, libreoffice-still-ru 6.1.5-1 В каком-то обновлении системы на протяжении последних двух месяцев произошли изменения в следствии которых перестали отображаться кириллические названия листов в Libreoffice Calc. Одновременно с этим появился другой баг - при переключении языка интерфейса на русский - в окнах программы тоже отсутствуют надписи. Язык интерфейса для меня не проблема. Но отсутствующие названия листов во всех созданных ранее документах - проблема существенная. См. скриншот 1

Проблема присутствует только в моем профиле. В профиле жены - все нормально.

Что уже делал:

  1. Неоднократно и после каких-либо изменений удалял папку ~/.config/libreoffice
  2. Осуществил поиск в домашней папке каких-либо конфигурационных файлов с упоминанием «libreoffice» и удалил их.
  3. Привел локали в настройщике Plasma к таким, как в профиле жены (Русский, Английский)
  4. Ставил темы оформления, цветовые темы, темы оформления для gtk-приложений светлые и точно такие же как в профиле жены.
  5. Вместо libreoffice-still устанавливал libreoffice-fresh Разница только в том, что в версии still если вызвать окно переименования листа, то надпись там видно, а в версии fresh - надписи и там не видно. image1, image2
  6. Ставил вообще другие темы оформления в надежде заметить разницу цветов где-то.
  7. Удалил файлы ~/.config/locale.conf и ~/locale.conf
  8. Проверял наличие бага в зависимости от переключателя «Предпочитать темную тему GTK» в окне настроек «Стиль программ Gnome/GTK+», хотя как писал выше и выставлял все настройки в этом окне также как они выставлены в профиле жены.
  9. Полностью удалял libreoffice (pacman -Rs)...
  10. Может еще что-то делал несущественное, но после проверки возвращал в состояние «как было».

Попрошу заранее не предлагать «создать нового пользователя (новый профиль)». Уже просто в бешенство прихожу из-за такого бага.
Уже даже создавал bugreport но чет прогресса там никакого. Возможно я не совсем понял систему подачи этих отчетов.
Пробовал ставить аналог libreoffice (caligra) - но это совсем не то в плане Электронных таблиц.

$ locale

LANG=ru_RU.UTF-8
LC_CTYPE="ru_RU.UTF-8"
LC_NUMERIC="ru_RU.UTF-8"
LC_TIME="ru_RU.UTF-8"
LC_COLLATE="ru_RU.UTF-8"
LC_MONETARY="ru_RU.UTF-8"
LC_MESSAGES="ru_RU.UTF-8"
LC_PAPER="ru_RU.UTF-8"
LC_NAME="ru_RU.UTF-8"
LC_ADDRESS="ru_RU.UTF-8"
LC_TELEPHONE="ru_RU.UTF-8"
LC_MEASUREMENT="ru_RU.UTF-8"
LC_IDENTIFICATION="ru_RU.UTF-8"
LC_ALL=

# cat /etc/locale.conf

LANG=ru_RU.UTF-8

Ответ на: комментарий от alexferman

А на новом пользователе этот баг есть или нет?

На новом пользователе бага нет. В профиле жены пробовал удалять папку ~/.config/libreoffice - на стандартных настройках тоже все нормально отображается.

Zhivotnoe ()
Ответ на: комментарий от Deleted

удалить ‘~/.config/plasma-locale*’ попробуй

Видел я эти файлы. В них отражаются настройки, те что я вношу через графический настройщик локализации. При удалении эффекта никакого не произошло. Файл «plasma-localerc» создался дефолтный после перелогина, а файл «plasma-locale-settings.sh» создался после внесение изменений в графический настройщик локализации.

Zhivotnoe ()

Возможно конфиги Qt мешаются. Если когда-либо ставился qt5ct (или как его там), то стоит его удалить и снести все оставшиеся от него конфиги. При использовании KDE эта штука не нужна, но ее наличие одновременно с KDE может корежить некоторые программы.

Khnazile ★★★★★ ()
Ответ на: комментарий от Khnazile

Возможно конфиги Qt мешаются. Если когда-либо ставился qt5ct (или как его там), то стоит его удалить и снести все оставшиеся от него конфиги. При использовании KDE эта штука не нужна, но ее наличие одновременно с KDE может корежить некоторые программы.

qt5ct не ставил никогда. Спасибо за наводку. Ушел прочесывать домашний каталог на наличие каких либо конфигов «qt»

Zhivotnoe ()

Дело понемногу движется.

В статье libreoffice на арчевики нашел такой текст

LibreOffice поддерживает интеграцию тем GTK+ (Русский) and Qt (Русский). Смотри также Uniform look for Qt and GTK applications (Русский).

Наборы библиотек проверяются в следующем порядке:

gtk3 > gtk > kde4 > generic
Чтобы принудительно использовать определенный интерфейс VCL UI, используйте одну из SAL_USE_VCLPLUGIN=gen, SAL_USE_VCLPLUGIN=kde4, SAL_USE_VCLPLUGIN=gtk или SAL_USE_VCLPLUGIN=gtk3 переменных среды (environment variables (Русский)). Можно снять комментирование с этих переменных в /etc/profile.d/libreoffice-fresh.sh или /etc/profile.d/libreoffice-still.sh.

Во всех вариантах запуска электронных таблиц кроме

env SAL_USE_VCLPLUGIN=gen libreoffice --calc
отсутствовала русская кодировка.

Пока-что установил пакет gtk3 и ушел учить матчасть на арчевики GTK+, Qt.

Zhivotnoe ()