LINUX.ORG.RU

Установка node.js 12 в CentOS 6

 , ,


0

2

Да, ЦентОСь старая, я знаю, но обновить нет возможности.

Выхлоп yum install nodejs:

--> Проверка сценария
---> Package nodejs.x86_64 2:12.0.0-1nodesource will be для установки
--> Обработка зависимостей: libstdc++.so.6(CXXABI_1.3.5)(64bit) для пакета: 2:nodejs-12.0.0-1nodesource.x86_64
--> Обработка зависимостей: libc.so.6(GLIBC_2.17)(64bit) для пакета: 2:nodejs-12.0.0-1nodesource.x86_64
--> Обработка зависимостей: libstdc++.so.6(GLIBCXX_3.4.15)(64bit) для пакета: 2:nodejs-12.0.0-1nodesource.x86_64
--> Обработка зависимостей: libstdc++.so.6(GLIBCXX_3.4.18)(64bit) для пакета: 2:nodejs-12.0.0-1nodesource.x86_64
--> Обработка зависимостей: libstdc++.so.6(GLIBCXX_3.4.14)(64bit) для пакета: 2:nodejs-12.0.0-1nodesource.x86_64
--> Проверка зависимостей окончена
Ошибка: Пакет: 2:nodejs-12.0.0-1nodesource.x86_64 (nodesource)
            Необходимо: libstdc++.so.6(GLIBCXX_3.4.15)(64bit)
Ошибка: Пакет: 2:nodejs-12.0.0-1nodesource.x86_64 (nodesource)
            Необходимо: libstdc++.so.6(GLIBCXX_3.4.18)(64bit)
Ошибка: Пакет: 2:nodejs-12.0.0-1nodesource.x86_64 (nodesource)
            Необходимо: libstdc++.so.6(CXXABI_1.3.5)(64bit)
Ошибка: Пакет: 2:nodejs-12.0.0-1nodesource.x86_64 (nodesource)
            Необходимо: libc.so.6(GLIBC_2.17)(64bit)
Ошибка: Пакет: 2:nodejs-12.0.0-1nodesource.x86_64 (nodesource)
            Необходимо: libstdc++.so.6(GLIBCXX_3.4.14)(64bit)
 Вы можете попробовать --skip-broken чтобы обойти проблему
 Вы можете попробовать запустить: rpm -Va --nofiles --nodigest
Хорошо, подумал я и установил из исходных текстов glibc 2.17 сюда /opt/glibc-2.17, а при помощи Software Collection devtools-6 в /opt/rh/devtools-6/root/

Что делать дальше? Как показать пакету с нодой, но только этому пакету, мои установленные зависимости?

★★★★★

Ответ на: комментарий от menangen

А идея ставить в шестерку пакеты от семерки ничем не лучше того, чем пытается заниматься тс.

Deleted ()

А откуда вообще этот пакет взялся?

Если к нему есть SRPM, то можно попробовать пересобрать с более старыми версиями glibc и libstdc++ (если там в принципе есть то, что нужно этой версии nodejs). В этом случае смотри в сторону утилиты mock.

Если этот бинарный пакет точно совместим с CentOS/RHEL 7, то поставить CentOS 7 в chroot, туда же поставить пакет, и запускать nodejs из чрута.

Deleted ()
Последнее исправление: Deleted (всего исправлений: 1)

Скачай/распакуй бинарник ноды в opt. Посмотри, какие либы ей нужны. Поставь их, чтобы нода их видела. Пропиши path.

crutch_master ★★★★★ ()
Ответ на: комментарий от crutch_master

Нода вообще не очень требовательная к окружению. Спокойно воткнул на минт 17.

crutch_master ★★★★★ ()
Ответ на: комментарий от crutch_master

Скачай/распакуй бинарник ноды в opt. Посмотри, какие либы ей нужны. Поставь их, чтобы нода их видела. Пропиши path.

Видать придется так сделать, просто не хотелось заморачиваться так с каждым выпуском.

sniper21 ★★★★★ ()
Ответ на: комментарий от sniper21

Что там заморачиваться? Распаковываешь tar.gz, когда надо обновиться и все. Можно скрипт сделать. Либы только если какие-нибудь слинкуют другие, придётся из выколупывать.

crutch_master ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.