LINUX.ORG.RU

Не могу установить php-mcrypt centos 7

 , ,


0

1

Всем привет! В системе стоит php 5.6, нужно установить модуль php-mcrypt, но он не хочет устанавливаться, т.к. конфликтует с версией php 5.4, которой попросту нет в системе.Как можно решить проблему?

 rpm -qa | grep php
php56w-cli-5.6.22-1.w7.x86_64
php56w-opcache-5.6.22-1.w7.x86_64
php-pear-Auth-SASL-1.0.6-5.el7.noarch
php-php-gettext-1.0.11-12.el7.noarch
php56w-gd-5.6.22-1.w7.x86_64
php56w-mbstring-5.6.22-1.w7.x86_64
php-pear-Net-LDAP2-2.1.0-1.el7.noarch
phpMyAdmin-4.4.15.5-1.el7.noarch
ispmanager-pkg-php-5.56.0-3.el7.centos.x86_64
php56w-mysql-5.6.22-1.w7.x86_64
php56w-tidy-5.6.22-1.w7.x86_64
php56w-fpm-5.6.22-1.w7.x86_64
php56w-pspell-5.6.22-1.w7.x86_64
php-pear-Net-Sieve-1.3.4-4.el7.noarch
coremanager-pkg-php-5.56.0-5.el7.centos.x86_64
php-tcpdf-dejavu-sans-fonts-6.2.11-1.el7.noarch
ispmanager-pkg-phpfpm-5.56.0-3.el7.centos.x86_64
php56w-common-5.6.22-1.w7.x86_64
php56w-5.6.22-1.w7.x86_64
php56w-ldap-5.6.22-1.w7.x86_64
php56w-process-5.6.22-1.w7.x86_64
php-pear-Net-Socket-1.0.14-1.el7.noarch
php-kolab-net-ldap3-1.0.3-1.el7.noarch
php-pear-Mail-Mime-1.10.0-1.el7.noarch
php-tcpdf-6.2.11-1.el7.noarch
php56w-bcmath-5.6.22-1.w7.x86_64
php56w-xml-5.6.22-1.w7.x86_64
php-pear-Net-IDNA2-0.1.1-10.el7.noarch
php56w-pdo-5.6.22-1.w7.x86_64
php56w-intl-5.6.22-1.w7.x86_64
php56w-pear-1.10.1-1.w7.noarch
php-pear-Net-SMTP-1.7.1-1.el7.noarch
Вот что выводит:
Разрешение зависимостей
--> Проверка сценария
---> Пакет php-mcrypt.x86_64 0:5.4.16-4.el7 помечен для установки
--> Обработка зависимостей: php(api) = 20100412-64 пакета: php-mcrypt-5.4.16-4.el7.x86_64
--> Обработка зависимостей: php(zend-abi) = 20100525-64 пакета: php-mcrypt-5.4.16-4.el7.x86_64
--> Обработка зависимостей: libmcrypt.so.4()(64bit) пакета: php-mcrypt-5.4.16-4.el7.x86_64
--> Проверка сценария
---> Пакет libmcrypt.x86_64 0:2.5.8-13.el7 помечен для установки
---> Пакет php-common.x86_64 0:5.4.16-36.1.el7_2.1 помечен для установки
--> Обработка конфликта: php56w-common-5.6.22-1.w7.x86_64 конфликтует с php-common < 5.5.0
--> Проверка зависимостей окончена
Ошибка: php56w-common conflicts with php-common-5.4.16-36.1.el7_2.1.x86_64
 Вы можете попробовать --skip-broken чтобы обойти проблему
 Вы можете попробовать запустить: rpm -Va --nofiles --nodigest

Ответ на: комментарий от Work-of-Art

я так понимаю все модули нужно ставить с пометкой php56w?

Да, верно. Для интерпретатора php56 c webtatic необходимо ставить все компоненты. Они указаны в таблице.

int13h ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.