LINUX.ORG.RU

Не ставиться puppet-agent

 


0

1

Прошу помочь поставить puppet-agent на ПК. На всех поставился нормально, один пк мучу уже второй день и ничего не выходит. Всё делаю по инструкции с офф сайта.

rpm -ivh https://yum.puppetlabs.com/puppetlabs-release-pc1-el-7.noarch.rpm

package puppetlabs-release-pc1-1.1.0-5.el7.noarch is already installed

yum install puppet-agent

No package puppet-agent available. Error: Nothing to do

Спасибо

Ответ на: комментарий от dedysobr

В общем, что-то ты тупишь с ответами.

Вот отсюда подключай соответствующий репозиторий: https://yum.puppetlabs.com/

Если у тебя CentOS 6, то нужно el-6 или el-5, если CentOS 5.

Пакет скачать и поставить можно отсюда:
http://yum.puppetlabs.com/el/7/PC1/x86_64/
http://yum.puppetlabs.com/el/6/PC1/x86_64/
http://yum.puppetlabs.com/el/6/PC1/x86_64/

anonymous ()
Ответ на: комментарий от dedysobr

Так и ставь репозиторий для 6 версии, а не для 7.

AnDoR ★★★★★ ()
Ответ на: комментарий от dedysobr

CentOS release 6.10 (Final)

Failed dependencies: systemd is needed by puppet-agent-1.9.3-1.el7.x86_64

Что-то пошло «не так» в датском королевстве. В 6-й центоси нету проклятущего системд, он только в 7-й центоси появился.

slamd64 ★★★★★ ()
Ответ на: комментарий от slamd64

Всем спасибо за помощь. Проблема переросла в другое русло. Поставил репозиторий для 6 centos, паппет установился но четвёртой версии, которая не хочет работать с текущей версией паппет сервера. Ищу версию 3.8.7(как раз такая как на остальных серверах) которая судя по всему в el4 должна быть.

dedysobr ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.