LINUX.ORG.RU

Проблемы с Cmake на CENTOS 7

 ,


0

1

Здравствуйте. У кого-нибудь стоит cmake version >2.9?? Для работы требуется cmake3.6 и выше. По дефолту через yum устанавливается 2.8. Можно апгрейтнуть до 2.9. Но этоо все равно мало. Была попытка найти пакеты и установить самим. Нашли. Установили. Но сам cmake не работает. Окей. Еще раз пытаюсь установить rpm пакеты. Пишет все уже установлено. И зависимости вроде все устранены. Но cmake не работает. Скорее всего все не так просто.( что то пропустил, мб что то сделать с etc/profile.d) Может ли кто нибудь объяснить что в таких случаях делать? Уже не в первый раз так устанавливать приходиться. Или если у кого на centos стоит cmake3.x , расскажите пожалуйста как установили.

Поставь nix в centos, там есть cmake от 2.8 до 3.8 и затем поставь с помощью nix-env -qa cmake и затем там увидишь версии, уже потом ставь nix-env -i cmake-*

playX ★★ ()

подключай epel и сделай

yum info cmake3
будешь приятно удивлён

novitchok ★★★★★ ()

Чтобы не плодить треды, спрошу здесь: а что пользователям убунты в таких случаях делать? Такая же фигня, нужен cmake3.6 и выше

tiinn ★★★ ()
Ответ на: комментарий от tiinn

Такая же фигня, нужен cmake3.6 и выше

Собрать из исходников с префиксом /opt, а затем checkinstall.

kawaii_neko ★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.