LINUX.ORG.RU

ubuntu установка пакета xserver-xorg из конкретного PPA

 , , , ,


0

1

Приветствую!

Помогите ребят?

Требуется установить пакет xserver-xorg из PPA:

https://launchpad.net/~ubuntu-multiseat/ archive/ubuntu/ppa?field.series_filt...

Но версию убунту 14.04 обновил по ошибке с ядром 4.4 (стояла 3.19), вернул обратно на 3.19 = не помогло.

Маячит этот xserver-xorg (1:7.7+1ubuntu8.1) и всё тут

Как его теперь понизить?


Удали PPA,
Сделай apt update
Удали xserver-xorg и снова его поставь, правда не знаю потянет он за собой пол системы или нет, можно попробовать скачать отдельно деб под твою систему и заинсталить...

LinuxDebian ★★★★ ()
Ответ на: комментарий от babel

вот мои скачанные пакеты:

gir1.2-gdm-1.0_3.10.0.1-0ubuntu3+multiseat0_amd64.deb       xorg-server-source_1.15.1-0ubuntu2.7+multiseat0_all.deb
gir1.2-udisks-2.0_2.1.3-2git1~14.04.1~multiseat0_amd64.deb  xserver-common_1.15.1-0ubuntu2.7+multiseat0_all.deb
libgdm1_3.10.0.1-0ubuntu3+multiseat0_amd64.deb              xserver-xephyr_1.15.1-0ubuntu2.7+multiseat0_amd64.deb
libgdm-dev_3.10.0.1-0ubuntu3+multiseat0_amd64.deb           xserver-xorg-core_1.15.1-0ubuntu2.7+multiseat0_amd64.deb
libudisks2-0_2.1.3-2git1~14.04.1~multiseat0_amd64.deb       xserver-xorg-core-dbg_1.15.1-0ubuntu2.7+multiseat0_amd64.deb
libudisks2-dev_2.1.3-2git1~14.04.1~multiseat0_amd64.deb     xserver-xorg-core-udeb_1.15.1-0ubuntu2.7+multiseat0_amd64.udeb
udisks2_2.1.3-2git1~14.04.1~multiseat0_amd64.deb            xserver-xorg-dev_1.15.1-0ubuntu2.7+multiseat0_amd64.deb
xdmx_1.15.1-0ubuntu2.7+multiseat0_amd64.deb                 xserver-xorg-xmir_1.15.1-0ubuntu2.7+multiseat0_amd64.deb
xdmx-tools_1.15.1-0ubuntu2.7+multiseat0_amd64.deb           xvfb_1.15.1-0ubuntu2.7+multiseat0_amd64.deb
xnest_1.15.1-0ubuntu2.7+multiseat0_amd64.deb

Что делать с файлами: xorg-server_1.15.1-0ubuntu2.7+multiseat0.dsc xorg-server_1.15.1.orig.tar.gz

babel ()
Ответ на: комментарий от babel

Это не первый и не второй вариант, это цепочка действий... Удали сторонний репозиторий обновись и установись из официального, но может там уже тоже такая версия:

https://packages.ubuntu.com/trusty/x11/xserver-xorg

Оно что не работает?

П.С.: 16.04 с ядром 4.10 очень стабильная, с 4.4 на ноуте валится вайфай... Может стоит переехать если конечно не прибит гвоздями к 14.04

LinuxDebian ★★★★ ()
Ответ на: комментарий от babel

С такими вопросам наверное легше переустановить систему... На свой страх и риск можешь сделать:

dpkg -i *
apt install -f

Но лучше попробовать:
sudo apt-get install --reinstall ЧТО ТО ТАМ

Может у тебя ос не обновлялась год и в репах тоже уже все новое...

LinuxDebian ★★★★ ()

В synaptic можно выбрать версию пакета и lock version есть.

pawnhearts ★★★★★ ()
Ответ на: комментарий от babel

Спасибо ребят за помощь! Короч видимо чего то я недопонял с этим multiseat и xorg. Для работы multiseat нужно что бы Xephyr поддерживал захват устройств ввода (клавиатуры и мышь) evdev, а в стандартной версии Xephyr нет этой поддержки, вот существует PPA multiseat для того, что бы установить эту версию с поддержкой evdev. В моём случае вариант запуска такой:

DISPLAY=:0.1 Xephyr :2 -dpi 96 -fullscreen -screen 1280x1024 -nolisten tcp -sw-cursor -keybd evdev,,device=/dev/input/by-id/usb-RAPOO_RAPOO_2.4G_Wireless_Device-event-kbd -mouse evdev,,device=/dev/input/by-id/usb-Logitech_USB_Receiver-event-mouse &

А что касается xorg - deb пакеты я установил все, что я скачивал вручную с http://ppa.launchpad.net/ubuntu-multiseat/ppa/ubuntu/pool/main/x/xorg-server/

Что-то я тупанул, просто, давно не возвращался к этой теме (multiseat), пока не случилось проблем с железом пк, а так всё работало на ура!

babel ()
Ответ на: комментарий от babel

Финиш!

вообщем, в итоге из тех пакетов, что я скачал для установки вручную нужны только три штуки:

gir1.2-udisks-2.0 libudisks2-0 udisks2
Их версии я заблокировал в synaptic, что бы при обновлении больше не было геморов. Ядро в итоге поставил 4.2 (Wily).
sudo apt-get install linux-generic-lts-wily
И Всё работает! Multiseat в частности.

babel ()
Ответ на: Финиш! от babel

Дополнение

Ещё два пакета, у которых после установки необходимо заблокировать версию:

xserver-common xserver-xephyr

babel ()
Ответ на: комментарий от babel

Удивительно!

dpkg -l | grep multiseat
ii  gir1.2-udisks-2.0                                     2.1.3-2git1~14.04.1~multiseat0             amd64        GObject based library to access udisks2 - itrospection data
ii  libudisks2-0:amd64                                    2.1.3-2git1~14.04.1~multiseat0             amd64        GObject based library to access udisks2
ii  udisks2                                               2.1.3-2git1~14.04.1~multiseat0             amd64        D-Bus service to access and manipulate storge devices
ii  xserver-xephyr                                        2:1.15.1-0ubuntu2.7+multiseat0             amd64        nested X server

Удивительно, но и на ядре 4.4 (xential) всё запустилось! Но пакет xserver-common был замещён стандартным убунтувским.

babel ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.