LINUX.ORG.RU

Система АКТИВНО грузит только одно ядро

 , , ,


0

1

Тема решена:

* Я поставил KDE, на нем и останусь, так как такого бага нет,нагрузка распределяется равномерно. *

Здравствуйте, на моём ноутбуке стоит Linux Mint Cinamon. Я заметил, что активно используется только 1 ядро процессора, что сильно заметно при перемещение окон(они подтормаживают) или в GIMP`е(тоже тормозит).

Система 64 битная, ядро 4.8.0-53-generic

Ответ на: комментарий от Vsevolod-linuxoid

Эмм... Можно как-то его исправить без смены дистра, если нет, то посоветуйте дистр

max0000402 ()
Ответ на: комментарий от max0000402

Может и можно, не работал лично, гуглю.

На Ubuntu и производных (не форках) такого нет. Рекомендую Xubuntu. Или можешь вообще на Debian уйти, там тоже есть Cinnamon.

Vsevolod-linuxoid ★★★★★ ()
Ответ на: комментарий от max0000402

Я не развожу, честно. Мне просто и впрямь интересно, при каких условиях такое может быть полезно.

Vsevolod-linuxoid ★★★★★ ()
Ответ на: комментарий от Vsevolod-linuxoid

Спасибо, в Debian не мог что сделать, непомню, то-ли wi-fi то-ли с видяхой что-то намудрил.

max0000402 ()
Ответ на: комментарий от max0000402

Вообще пока я нашел только то, что в 32 битной версии минта по умолчанию 486 ядро. Может они стали пихать 32 и 64 битные ядра и в 64 битную поставку? Бред.

Vsevolod-linuxoid ★★★★★ ()

Важный вопрос: система активно грузит ядро 1 или вообще не видит других?

Vsevolod-linuxoid ★★★★★ ()
Ответ на: комментарий от Vsevolod-linuxoid

может там ядро под реалтайм аффинировано

anonymous ()
Ответ на: комментарий от max0000402

Баг минта. Вот если бы не видела остальные, то было бы хуже. Собственно, это просто глюк DE — оно у них то CPU под сотню, но на разные ядра не может.

Vsevolod-linuxoid ★★★★★ ()

покажи

lscpu
uname -a
anonymous ()
Ответ на: покажи от anonymous

Архитектура:x86_64 CPU op-mode(s): 32-bit, 64-bit Порядок байтов:Little Endian CPU(s): 4 On-line CPU(s) list: 0-3 Потоков на ядро:2 Ядер на сокет:2 Сокет(ы): 1 NUMA node(s): 1 Vendor ID: GenuineIntel Семейство CPU:6 Модель: 58 Model name: Intel(R) Core(TM) i5-3210M CPU @ 2.50GHz Stepping: 9 CPU МГц: 2785.949 CPU max MHz: 3100,0000 CPU min MHz: 1200,0000 BogoMIPS: 4988.88 Виртуализация:VT-x L1d cache: 32K L1i cache: 32K L2 cache: 256K L3 cache: 3072K NUMA node0 CPU(s): 0-3 Flags: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc aperfmperf eagerfpu pni pclmulqdq dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm pcid sse4_1 sse4_2 x2apic popcnt tsc_deadline_timer aes xsave avx f16c rdrand lahf_lm epb tpr_shadow vnmi flexpriority ept vpid fsgsbase smep erms xsaveopt dtherm ida arat pln pts

Linux user-laptop 4.8.0-53-generic #56~16.04.1-Ubuntu SMP Tue May 16 01:18:56 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

max0000402 ()
Ответ на: комментарий от max0000402

Не знаю точно. Возможно. Но этот глюк может быть и в других DE на минте, попробуй.

Vsevolod-linuxoid ★★★★★ ()

Забавный баг, пробуй другое ядро/дистр.

Ygor ★★★★★ ()
Ответ на: комментарий от Ygor

Конец

Я поставил KDE, на нем и останусь, так как такого бага нет, и нагрузка распределяется равномерно.

Всем спасибо, до свидания.

max0000402 ()
Ответ на: Конец от max0000402

Re: Конец

а снова поставь Cinamon, вдруг глюка уже не будет

anonymous ()
Ответ на: Re: Конец от anonymous

Видимо, ТС поставил Kubuntu (или где там ещё KDE by default).

greenman ★★★★★ ()

Я поставил KDE, на нем и останусь, так как такого бага нет,нагрузка распределяется равномерно.

KDE тут при чём? И cinnamon не виноват.

Я на протяжении нескольких лет использовал лишь 1 ядро своего процессора. Спасибо разработчикам Linux Mint!

Я на протяжении нескольких лет использовал лишь 1 ядро своего процессора. Спасибо разработчикам Linux Mint!

To guarantee compatibility with non-PAE processors, the 32-bit versions of Linux Mint Debian come with a 586 kernel by default. This kernel does not support SMP, and as a consequence is only able to detect one core and one CPU

И не надо лепить * в сообщениях, освой теги LORCODE (ссылка внизу поля ввода сообщения).

greenman ★★★★★ ()
Ответ на: комментарий от greenman

Ну как сказать. Пока я не открою какое-то приложение от cinamon в kde все работает нормально. Как только открываю что нибудь от cinamon сразу нагрузка переходит на одно ядро.

max0000402 ()
Ответ на: комментарий от max0000402

В принципе, находятся жалобы — Cinnamon high CPU usage.

Попробуй посмотреть htop.

Then it occurred to me that I had launched in software rendering mode, and when I restarted, in normal session mode, problem solved.

Cinnamon abuses CPU

I am running Mint 17.1. Cinnamon 3D holds at 40% CPU. Cinnamon 2D stays below 6%. I am using the nVidia drivers (using the driver manager). NVIDIA GT218 [GeForce 210]. In the «effects» settings I have all effects turned off in both situations.

greenman ★★★★★ ()
Последнее исправление: greenman (всего исправлений: 2)
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.