LINUX.ORG.RU

Посоветуйте торрент-клиент с удобной(желательно красивой) вебмордой

 ,


1

1

Сабж. Пробовал rtorrent+flood, все замечательно, но установка flood сложная. Пытался установить по англоязычным манам, ниасилил. Если кому-то известно, как установить, напишите краткую инструкцию на русском(или дайте ссылку, если есть, гугл молчит), пожалуйста.

Перемещено leave из talks

bvn13, UVV попробовал, зависла от большого торрент-файла(реально большого, ~20 папок со вложенными папками, столько же файлов в корне+еще в папках, всего на 95 гб), но Tixati с ним справлялся же.

complamer ()
Ответ на: комментарий от complamer

Работает вот на этой фигне. Стоит transmission 2.92 и в торрентах висит South Park, который более 100 гигов, емнип. Нареканий не было. Какая у тебя версия?

UVV ★★★★★ ()
Ответ на: комментарий от Jopich1

Да мне не пиратскую венду с фотожопом качать, торренты приватные

complamer ()
Ответ на: комментарий от UVV

Как ты забанишь торрент-клиент?

Ну вообще на некоторых трекерах есть вайтлист клиентов. Но и transmission и deluge и rtorrent там всегда присутствуют (с трансмиссией вроде с какими-то дико древними версиями только проблемы были). Клиент отдаёт свой идентификатор. Если трекер не из вайтлиста, трекер отдаёт 403. Технически, конечно, можно пропатчить торрент-клиент, чтобы он представлялся каким-нибудь rtorrent'ом, но если узнают, то забанят уже не клиент, а пользователя — за «читерство».

Psych218 ★★★★★ ()
Последнее исправление: Psych218 (всего исправлений: 2)
Ответ на: комментарий от Psych218

Все равно вебсервер. Сложно, посмотрю сначала другие варианты.

complamer ()
Ответ на: комментарий от Psych218

Технически, конечно, можно пропатчить торрент-клиент, чтобы он представлялся каким-нибудь rtorrent'ом, но если узнают, то забанят уже не клиент, а пользователя — за «читерство».

А, забыл что он одтаёт имя. Думал просто, что эта фича наподобие user-agent в браузере, где можно просто написать «Продам гараж»

UVV ★★★★★ ()
Последнее исправление: UVV (всего исправлений: 1)

О, нашел на гитхабе flood вики, сейчас попробую вкурить, может выйдет его поставить.

complamer ()
Ответ на: комментарий от complamer

Хм… Даже не знаю. У меня достаточно в «Модули» галочку поставить напротив него, и всё становится доступно. Делюга из реп, арч.

Psych218 ★★★★★ ()
Ответ на: комментарий от Jopich1
$ deluge-web
:0: UserWarning: You do not have a working installation of the service_identity module: 'No module named service_identity'.  Please install it from <https://pypi.python.org/pypi/service_identity> and make sure all of its dependencies are satisfied.  Without the service_identity module, Twisted can perform only rudimentary TLS client hostname verification.  Many valid certificate/hostname mappings may be rejected.
Traceback (most recent call last):
  File "/usr/bin/deluge-web", line 11, in <module>
    load_entry_point('deluge==1.3.15', 'console_scripts', 'deluge-web')()
  File "/usr/lib/python2.7/site-packages/deluge/ui/web/web.py", line 144, in start
    web.start()
  File "/usr/lib/python2.7/site-packages/deluge/ui/web/web.py", line 110, in start
    import server
  File "/usr/lib/python2.7/site-packages/deluge/ui/web/server.py", line 61, in <module>
    from deluge.ui.web.auth import Auth
  File "/usr/lib/python2.7/site-packages/deluge/ui/web/auth.py", line 61, in <module>
    from deluge.ui.web.json_api import JSONComponent, export
  File "/usr/lib/python2.7/site-packages/deluge/ui/web/json_api.py", line 63, in <module>
    from deluge.ui.web.common import _, compress
  File "/usr/lib/python2.7/site-packages/deluge/ui/web/common.py", line 38, in <module>
    from mako.template import Template as MakoTemplate
ImportError: No module named mako.template
complamer ()
Ответ на: комментарий от Jopich1
# pip install mako
Collecting mako
  Downloading Mako-1.0.6.tar.gz (575kB)
    100% |████████████████████████████████| 583kB 929kB/s 
Collecting MarkupSafe>=0.9.2 (from mako)
  Downloading MarkupSafe-1.0.tar.gz
Installing collected packages: MarkupSafe, mako
  Running setup.py install for MarkupSafe ... done
  Running setup.py install for mako ... done
Successfully installed MarkupSafe-1.0 mako-1.0.6
# deluge-web
:0: UserWarning: You do not have a working installation of the service_identity module: 'No module named service_identity'.  Please install it from <https://pypi.python.org/pypi/service_identity> and make sure all of its dependencies are satisfied.  Without the service_identity module, Twisted can perform only rudimentary TLS client hostname verification.  Many valid certificate/hostname mappings may be rejected.
Traceback (most recent call last):
  File "/usr/bin/deluge-web", line 11, in <module>
    load_entry_point('deluge==1.3.15', 'console_scripts', 'deluge-web')()
  File "/usr/lib/python2.7/site-packages/deluge/ui/web/web.py", line 144, in start
    web.start()
  File "/usr/lib/python2.7/site-packages/deluge/ui/web/web.py", line 110, in start
    import server
  File "/usr/lib/python2.7/site-packages/deluge/ui/web/server.py", line 61, in <module>
    from deluge.ui.web.auth import Auth
  File "/usr/lib/python2.7/site-packages/deluge/ui/web/auth.py", line 61, in <module>
    from deluge.ui.web.json_api import JSONComponent, export
  File "/usr/lib/python2.7/site-packages/deluge/ui/web/json_api.py", line 63, in <module>
    from deluge.ui.web.common import _, compress
  File "/usr/lib/python2.7/site-packages/deluge/ui/web/common.py", line 38, in <module>
    from mako.template import Template as MakoTemplate
ImportError: No module named mako.template
complamer ()
Ответ на: комментарий от complamer

если для локального использования, то не нужно

хватит и встроенного сервера php

php -S 127.0.0.1:8765 -t ~/.ruTorrent

darktic ★★★ ()
Последнее исправление: darktic (всего исправлений: 1)
Ответ на: комментарий от complamer

А, ну да, там доп-зависимость для web-интерфейса

yaourt -Qi deluge                                                                                                                                 15:29:24 ✔
Название             : deluge
Версия               : 1.3.15+2+g38d7b7cdf-1
Описание             : A BitTorrent client with multiple user interfaces in a client/server model
Архитектура          : any
URL                  : http://deluge-torrent.org/
Лицензии             : GPL3
Группы               : Нет
Предоставляет        : Нет
Зависит от           : python2-xdg  libtorrent-rasterbar  python2-twisted  python2-pyopenssl  python2-chardet  python2-setuptools
Доп. зависимости     : python2-notify: libnotify notifications [установлено]
                       pygtk: needed for gtk ui [установлено]
                       librsvg: needed for gtk ui [установлено]
                       python2-mako: needed for web ui [установлено]
Требуется            : Нет
Опционально для      : Нет
Конфликтует с        : Нет
Заменяет             : Нет
Установленный размер : 12,27 MiB
Сборщик              : Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
Дата сборки          : Сб 27 май 2017 11:50:00
Дата установки       : Вс 04 июн 2017 09:52:05
Причина установки    : Явно установлен
Установочный скрипт  : Yes
Проверен             : Подпись

python2-mako: needed for web ui

Psych218 ★★★★★ ()

Собсно даже у qBittorrent морда есть, и никаких проблем с пистоном, по причине его отсутствия. И https искаропки умеет.

pekmop1024 ★★★★★ ()
Последнее исправление: pekmop1024 (всего исправлений: 1)
23 ноября 2017 г.

такая морда вполне симпатичная, хотя на вкус и цвет...

turma ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.