LINUX.ORG.RU

Не могу установить Virtual Box Additions

 ,


0

1

Установил Debian на виртуальной машине, пытаюсь запустить VBoxLinuxAdditions.run

Building the main Guest Additions Module... fail!
Посмотрел var/log/vbox-install.log
/usr/src/linux-headers-3.16.0-4-common/scripts/Makefile.build:262: ошибка выполнения рецепта для цели "/tmp/vbox.0/VBoxGuest/linux.o"
make[4]: *** [/tmp/vbox.0/VBoxGuest-linux.o] Ошибка 1
make[3]: *** [_module_/tmp/vbox.0] Ошибка 2
Makefile:181: Ошибка выполнения рецепта для цели "sub-make"
make[1]: *** [all] Ошибка 2
Makefile:8: ошибка выполнения рецепта для цели "all"
make[1]: *** [all] Ошибка 2
/tmp/vbox.0/Makefile.include.footer:79: ошибка выполнения рецепта для цели "vboxguest"
make: *** [vboxguest] Ошибка 2
Creating user fot the guest additions.
creating udev rule for the Guest Additions kernel module.

версия Virtualbox/Virtual Box Additions какая?

так же вывод uname -a

ядро не не старовато?

samson ★★ ()

надо бы выполнить вручную компиляцию для большей инфы об ошибке.

в общем заходишь по пути расположения исходников данного дополнения (наверна в /usr/src/virtualbox/...) и делаешь

sudo make
а так ваще виртуалбокс последнее время с траблами какими то запускается, у меня на винде он просто запустился один раз, а после перезагрузки отказался... ошибка и все тут, ничо из гугла не помогло.

п.с. мб в дебиане есть свой модуль для виртуалбокса? попробуй найти в пакетах дебиана чото типа таакова: virtualbox-guest или vboxguest или virtualbox-guest-dkms.

safocl ★★ ()
Последнее исправление: safocl (всего исправлений: 2)

лучше поставь тулзы из дебиановской репы.

Deleted ()
Последнее исправление: Deleted (всего исправлений: 1)
Ответ на: комментарий от Deleted

не советуйте плахова людям... убунтовские репы отличаются отвратительной работоспособностью.. да и зачем, если у чела дебиан?

safocl ★★ ()

при чем скажи какую версию ты установил?

для дебиан она вроде как 5.1.22

safocl ★★ ()
Последнее исправление: safocl (всего исправлений: 1)
Ответ на: комментарий от safocl

Ошибся с дистром. Предлагаю просто выполнить

apt-get install virtualbox-guest-dkms virtualbox-guest-utils virtualbox-guest-x11

Deleted ()
Ответ на: комментарий от Deleted

да вот кстати, я чото на сайте дебиана в пакетах не нашел виртуалбокса для последней версии stretch... есть максимум только для jessie-backports

а так да, именно как я понял так енти пакеты должны называться в дебиан.

safocl ★★ ()
Последнее исправление: safocl (всего исправлений: 1)
Ответ на: комментарий от Deleted

Дерьмовый совет.

Зачастую бывает, что стоит Virtualbox 5.1.x, а в виртуалке штабильный debian с дополнениями в репах версии 4.1 (собственно как в old satble, который как я понимаю в топике).

Естественно, так только баги собирать.

fornlr ★★★★★ ()
Ответ на: комментарий от Deleted

Любые связанные с взаимодействием, если ты не живешь в выдуманном мире «у нас поддержка в обе стороны - как в легаси, так и в будущее». Например, из очевидного, поддержка drag and drop была добавлена в версии 5.0. Тоесть ты понял, получится неочевидное поведение для пользователя.

А уж про неочевидные с графической системой...

fornlr ★★★★★ ()
Последнее исправление: fornlr (всего исправлений: 1)
Ответ на: комментарий от Deleted

Ещё build-esential должен какой-то стоять. Вечером могу добавить подробнее как ставил. Где-то на ЛОРе и находил рецепт.

grem ★★★★★ ()
Ответ на: комментарий от fornlr

drag n drop ни разу рабочим не видел, привык к его отсутствию, даже не знал, что его таки сделали.
иногда на рабочей винде пользую livecd под коробкой, со старыми тулзами под новой коробкой проблем не возникало. и уж гораздо проще поставить через апт чем возиться с компилянием.

Deleted ()
Ответ на: комментарий от grem

Где-то на ЛОРе и находил рецепт.

А можно вообще невероятное действие сделать - справку открыть.

fornlr ★★★★★ ()
Ответ на: комментарий от samson

вывод uname -a

Linux debianRikipm 3.16.0-4-586 #1 Debian 3.16.7-ckt25-1 (2016-03-06) i686 GNU/Linux
Версия VirtualBox и VBox additions 4.1.22

rikipm ()
Ответ на: комментарий от Deleted

со старыми тулзами под новой коробкой проблем не возникало

Я тебе написал разброс 4.1 и 5.1. Если меньше, то к чему это балобольство? Тем более сам пишешь, что не используешь многие возможности гостевых дополнений.

А в справке явно написано, что их разные версии не рекомендуются.

fornlr ★★★★★ ()
Последнее исправление: fornlr (всего исправлений: 1)

А по сабжу. Скорее чего-то напердолено, по типу noexec на tmp

fornlr ★★★★★ ()
Ответ на: комментарий от rikipm

Вот (Как установить видеодрайвер на ОС в virtualbox - Debian (комментарий)). Я отсюда месяц назад метод использовал для Jessie 8.8:

Только так:

Под рутом:

apt-get install build-essential dkms module-assistant; m-a prepare;

В Virtualbox в меню «Устройства» нажать «Подключить образ дополнений гостевой ОС» а затем снова в рутовом терминале:

mount /media/cdrom; sh /media/cdrom/VBoxLinuxAdditions.run; reboot;

И никак иначе.

Нужный linux-headers, кажется, должен автоматом притянуться. В любом случае он тоже нужен.

grem ★★★★★ ()
Последнее исправление: grem (всего исправлений: 2)
Ответ на: комментарий от grem

Делаю все точно по инструкции. См. мое первое сообщение

rikipm ()
Ответ на: комментарий от rikipm

VirtualBox 4.1.22 (released 2012-09-07)

04.08.2014 Релиз ядра Linux 3.16

Обновляй Virtualbox - у разработчиков нет машины времени

fornlr ★★★★★ ()
Последнее исправление: fornlr (всего исправлений: 1)
Ответ на: комментарий от rikipm

Версия VirtualBox и VBox additions 4.1.22

Может на более новой версии попробовать? Хотя бы на 5.0.х.

grem ★★★★★ ()
Ответ на: комментарий от rikipm

Версия VirtualBox и VBox additions 4.1.22

ооо вот откуда все трабблы_))))

safocl ★★ ()
Ответ на: комментарий от grem

Может на более новой версии попробовать? Хотя бы на 5.0.х.

думаю уже везде 5.1.22 версия актуальная (на сайте виртбокса именно она для всех операционок)

safocl ★★ ()
Ответ на: комментарий от safocl

Это я из-за того, что поддержка 5.0 только в мае закончилась.

VirtualBox 5.0 (no longer supported, support ended 2017/05)

grem ★★★★★ ()
Последнее исправление: grem (всего исправлений: 1)
Ответ на: комментарий от fornlr

я не грил чо ктото снимал более старые версии с поддержки, просто все версии для загрузки предлагаемые на сайте виртбокса именно 5.1.22 для всех операционок

safocl ★★ ()
Ответ на: комментарий от safocl

все сняли, поддерживается сейчас только ветка 5.1

grem ★★★★★ ()
Ответ на: комментарий от grem

O_O Вообще на Virtualbox.org раньше было дело ошибались с такой подписью. Но все же да.

http://www.oracle.com/us/support/library/lifetime-support-hardware-301321.pdf

Что-то как-то не ынтерпрайзно у них стало. Полимеры после SUN так и просрутся в итоге...

fornlr ★★★★★ ()
Последнее исправление: fornlr (всего исправлений: 3)

c рут правами запускаешь?

Ygor ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.