LINUX.ORG.RU

Ошибка при монтировании по cifs через systemd automount

 , , ,


0

1

Добрый день!

Столкнулся со следующей проблемой: при монтировании сетевой папки, в названии которой присутствует пробел, systemd выдает ошибку. Ниже статус юнита:

[raim@Raim-PC system]$ systemctl  status mnt-SERVER-Shared_Documents.mount 
● mnt-SERVER-Shared_Documents.mount - Mount Shared_Documents from SERVER
   Loaded: loaded (/etc/systemd/system/mnt-SERVER-Shared_Documents.mount; disabled; vendor preset: disabled)
   Active: failed (Result: exit-code) since Tue 2017-07-04 16:01:23 +03; 5s ago
    Where: /mnt/SERVER/Shared_Documents
     What: "//192.168.1.100/Общие документы"
  Process: 7411 ExecMount=/usr/bin/mount "//192.168.1.100/Общие документы" /mnt/SERVER/Shared_Documents -t cifs -o credentials=/mnt/.credentials,iocharset=utf8,rw,x-systemd.automount,x-systemd.d

июл 04 16:01:23 Raim-PC systemd[1]: Mounting Mount Shared_Documents from SERVER...
июл 04 16:01:23 Raim-PC systemd[1]: mnt-SERVER-Shared_Documents.mount: Mount process exited, code=exited status=1
июл 04 16:01:23 Raim-PC systemd[1]: Failed to mount Mount Shared_Documents from SERVER.
июл 04 16:01:23 Raim-PC systemd[1]: mnt-SERVER-Shared_Documents.mount: Unit entered failed state.

в journalctl -xe:

-- Defined-By: systemd
-- Support: https://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- 
-- Произошел сбой юнита mnt-SERVER-Shared_Documents.mount.
-- 
-- Результат: failed.
июл 04 16:01:23 Raim-PC systemd[1]: mnt-SERVER-Shared_Documents.mount: Unit entered failed state.
июл 04 16:01:23 Raim-PC sudo[7408]: pam_unix(sudo:session): session closed for user root

Ниже представлены содержания юнитов:

[raim@Raim-PC system]$ cat mnt-SERVER-Shared_Documents.mount 
[Unit]
Description=Mount Shared_Documents from SERVER
Requires=systemd-networkd.service
After=network-online.target
Wants=network-online.target

[Mount]
What="//192.168.1.100/Общие документы"
Where=/mnt/SERVER/Shared_Documents
Options=credentials=/mnt/.credentials,iocharset=utf8,rw,noauto,x-systemd.automount,x-systemd.device-timeout=30,uid=1000
Type=cifs
TimeoutSec=30

[Install]
WantedBy=multi-user.target

[Unit]
Description=Mount Shared_Documents from SERVER

[Automount]
Where=/mnt/SERVER/Shared_Documents
TimeoutIdleSec=30

[Install]
WantedBy=multi-user.target

Если в имени сетевой папки пробела нет, то все работает.

Также, если вручную ввести команду

/usr/bin/mount "//192.168.1.100/Общие документы" /mnt/SERVER/Shared_Documents -t cifs -o credentials=/mnt/.credentials,iocharset=utf8,rw,x-systemd.automount,x-systemd.device-timeout=30,uid=1000
то также все работает.

В чем может быть причина?


В чем может быть причина?

В пробеле.

batya ()
Ответ на: комментарий от intelfx

Попробуй убрать кавычки из What= в юните.

Сработало! Спасибо.

Raiim ()
Ответ на: комментарий от Ygor

Да вангую стоит попробовать экранировать\ пробел.

Как ни странно, ни экранирование \, ни замена пробела на %20 или \040, ни взятие в кавычк как в " так и в ' результатов не дали.

Raiim ()
Ответ на: комментарий от Raiim

Потому что не нужно ничего экранировать или брать в кавычки, строки после What= и Where= интерпретируются дословно.

intelfx ★★★★★ ()
Последнее исправление: intelfx (всего исправлений: 1)
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.