LINUX.ORG.RU

Слетели зависимости. Как восстановить?

 , , , ,


0

1

Вчера установили Opera через dpkg. Сказали, что там были какие-то зависимости, но всё как-то само решилось и установились.

Сегодня запустил систему, запустил команды обновления системы и мне выдало over9000 зависимостей.

Linux STRELKA-ElementaryOS 4.4.0-77-generic #98-Ubuntu SMP Wed Apr 26 08:34:02 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

Ответы терминала: install -f https://pastebin.com/S88x66nX dist-upgrade: https://pastebin.com/hRrhqY3M

Возможно ли это как-то исправить? Есть backup, но пока не решаюсь восстанавливать, поскольку он 2-х месячной давности и еще много чего устанавливать придётся, может быть можно какие-то определенные файлы восстановить из backup? С таким еще ни разу не сталкивался.

P.S. ... обновлено 0, установлено 796 новых пакетов, для удаления отмечено 755 пакетов, и 0 пакетов не обновлено. Необходимо скачать 338 MБ архивов. После данной операции, объём занятого дискового пространства уменьшится на 36,9 GB. То, что вы хотите сделать, может иметь нежелательные последствия. Чтобы продолжить, введите фразу: «Да, делать, как я скажу!»

Где опера и где dist-upgrade? Вы что-то не договариваете. Пытались обновить систему до новой версии дистра?

Infra_HDC ★★★★★ ()
Ответ на: комментарий от Infra_HDC

Да я сам офигел, кроме Opera ничего не делали! Вчера я те же самые команды обновления запускал и не было никаких обновлений, а сегодня запустил те же команды обновления и вот такая ерунда... Так же я запустил обновления на второй компьютере на той же версии системы и там нет никаких обновлений.

Не могу написать точно от какой команды пошел такой вывод, поскольку у меня алиас:«alias update='sudo apt update; sudo apt upgrade; sudo apt dist-upgrade' »

BladzheR ()
Ответ на: комментарий от BladzheR

Всегда обновлял систему командами apt-get update ; apt-get upgrade. А для dist-upgrade есть целая инструкция, по крайней мере для Debian GNU/Linux.

Infra_HDC ★★★★★ ()
Ответ на: комментарий от Infra_HDC

Спасибо! Учту!

А так с данной проблемой возможно справиться? В интернете находил, что-то похожее, но безуспешно...

BladzheR ()
Ответ на: комментарий от Infra_HDC

РЕШИЛ ПРОБЛЕМУ!

Всё произошло из-за deb пакета Opera...

Сначала установил aptitude через deb пакеты взятые с «packages.ubuntu.com», по обновлению он мне ничего толкового не предложил и решить зависимости тоже не мог, попробовал через него установить одну утилиту, которая уже была у меня установлена, но сегодня пропала и он мне показал, что надо удалить некие пакеты i386 и тут я понял всю суть, поскольку у меня amd64.

Я решил проверить пакет Opera, который вчера установили, он оказался i386, я решил снова скачать с оф сайта Opera и в этот раз он автоматически скачал мне уже нужный мне amd64, я его установил и проблема с зависимостями понемногу начала идти к решению...

Потом благодаря этой статье(http://help.ubuntu.ru/wiki/кросс_архитектурное_обновл..), я посмотрел все пакеты и у меня оказались одинаковые пакеты с разницей только в i386 и amd64. И сам apt был i386. Установил deb apt amd64, запустил обновление, он автоматически удалил ненужные пакеты i386 и теперь всё работает.

BladzheR ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.