LINUX.ORG.RU

Ubuntu 16.04 LTS периодически отваливается Wi-Fi

 ,


0

1

Помогает только полная перезагрузка.

Когда происходит отключение. Не работаю команды выкл/вкл wi-fi

Вывод команды dmesg(часть всё не влезло), после отключения wi-fi:

 usb 5-1: Product:  USB OPTICAL MOUSE
[236690.354098] input:  USB OPTICAL MOUSE as /devices/pci0000:00/0000:00:1d.0/usb5/5-1/5-1:1.0/0003:0000:0538.0005/input/input20
[236690.354627] hid-generic 0003:0000:0538.0005: input,hidraw0: USB HID v1.11 Mouse [ USB OPTICAL MOUSE] on usb-0000:00:1d.0-1/input0
[236720.212064] usb 2-6: reset high-speed USB device number 3 using ehci-pci
[236753.177906] IPv6: ADDRCONF(NETDEV_UP): wlp8s0: link is not ready
[236754.384145] iwl3945 0000:08:00.0: BSM uCode verification failed at addr 0x00003800+0 (of 900), is 0xa5a5a5a2, s/b 0xf802020
[236754.384153] iwl3945 0000:08:00.0: Unable to set up bootstrap uCode: -5
[236754.430852] iwl3945 0000:08:00.0: BSM uCode verification failed at addr 0x00003800+0 (of 900), is 0xa5a5a5a2, s/b 0xf802020
[236754.430858] iwl3945 0000:08:00.0: Unable to set up bootstrap uCode: -5
[236754.477562] iwl3945 0000:08:00.0: BSM uCode verification failed at addr 0x00003800+0 (of 900), is 0xa5a5a5a2, s/b 0xf802020
[236754.477567] iwl3945 0000:08:00.0: Unable to set up bootstrap uCode: -5
[236754.524270] iwl3945 0000:08:00.0: BSM uCode verification failed at addr 0x00003800+0 (of 900), is 0xa5a5a5a2, s/b 0xf802020
[236754.524274] iwl3945 0000:08:00.0: Unable to set up bootstrap uCode: -5
[236754.571065] iwl3945 0000:08:00.0: BSM uCode verification failed at addr 0x00003800+0 (of 900), is 0xa5a5a5a2, s/b 0xf802020
[236754.571071] iwl3945 0000:08:00.0: Unable to set up bootstrap uCode: -5
[236754.607651] iwl3945 0000:08:00.0: Unable to initialize device after 5 attempts.
[236755.461758] IPv6: ADDRCONF(NETDEV_UP): wlp8s0: link is not ready
[237116.176306] usb 5-1: USB disconnect, device number 6
[237408.492196] usb 5-1: new low-speed USB device number 7 using uhci_hcd
[237408.662204] usb 5-1: New USB device found, idVendor=0000, idProduct=0538
[237408.662214] usb 5-1: New USB device strings: Mfr=0, Product=1, SerialNumber=0
[237408.662221] usb 5-1: Product:  USB OPTICAL MOUSE
[237408.681314] input:  USB OPTICAL MOUSE as /devices/pci0000:00/0000:00:1d.0/usb5/5-1/5-1:1.0/0003:0000:0538.0006/input/input21
[237408.736610] hid-generic 0003:0000:0538.0006: input,hidraw0: USB HID v1.11 Mouse [ USB OPTICAL MOUSE] on usb-0000:00:1d.0-1/input0

Сетевой адаптер Intel® PRO/Wireless 3945ABG

Такая же проблема наблюдалась на mint 18.1, не было проблем на windows XP, 7 и на Debian 8.7(но он слишком сложен для меня, пока). Все системы пробовал и 64 и 32-битные. Проблема только на ubuntu и mint без разницы на битность.


Проблема только на ubuntu и mint без разницы на битность.

Потому, что Linux Mint основан на пакетной базе Ubuntu, т.е. это и есть Ubuntu, но с другой графической оболочкой.

Отправляй bug report разработчикам Ubuntu, ну либо используй другой дистрибутив с другой версией ядра, ибо проблема, скорее всего, что в версии ядра, поставляемой с Ubuntu / Mint, ест проблема в драйвере для этого Wifi адаптера.

Ну либо пробуй сразу после установки проверить и установить обновления, в частности пакет с новым ядром.

kostik87 ★★★★★ ()

Manufacturer: Hewlett-Packard

Product Name: HP Compaq nx7300

10:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection (rev 02)
Только что тоже отвалилась, ребутнулся, жду дальнейшего развития событий :-)

krang ★★ ()
Ответ на: комментарий от kostik87

Уже на минте ставил разные версии ядра, это никак не поменяет ситуацию. Мне кажется это в драйвере проблема. Но как поставить другой я так и не разобрался.

leaga ()
Ответ на: комментарий от leaga

Драйвер идёт в составе ядра. Отдельно драйвер никак не поставить. Нужно ставить другую версию ядра, если те, что можно поставить из репозитория дистрибутива проблему не устраняют, то нужно, во-первых, написать баг репорт разработчикам дистрибутива, что бы они проверили и выпустили пакет с новой версией ядра, во-вторых, написать баг репорт на kernel.org непосредственно команде разработчиков ядра, ну либо проверить, что такой баг уже есть. Ну и в-третьих, собирать и устанавливать другую версию ядра, что бы найти в какой версии ядра бага нет или с какой версии он появился, что бы потом эти сведения предоставить разработчикам.

Но ты, скорее всего, всё это делать не будешь, поэтому для тебя выход только один: ставить другой дистрибутив, например, тот же Debian, там версия ядра более старая и, скорее всего, работать всё будет.

Удачи.

kostik87 ★★★★★ ()
Ответ на: комментарий от kostik87

Спасибо за совет. Но на Debian другая проблема. Там не ставиться нормально видео драйвер. И при попытке запустить видео, выключается экран, а звук идет дальше. Если забить горячие клавиши, то можно даже программно перезагрузить. И такая же проблема на Deepin 15.3(он тоже основан на Debian). В общем, везде какая-то засада.

leaga ()
Ответ на: комментарий от leaga

Там не ставиться нормально видео драйвер.

Что значит не ставится? И откуда вы его ставите, всё что надо есть в репозитории и нормально работает, ибо протестировано.

Для установки проприетарных драйверов нужно подключить соответствующие ветки репозиториев, а именно contrib и non-free, после чего обновить списки пакетов

apt-get update
найти и поставить драйвер
apt-cache search слово_поиска
apt-get install имя_пакета

Какая видео карта?

kostik87 ★★★★★ ()
Ответ на: комментарий от kostik87

видео карта x3100 intel Driver что идёт ядром он и вылетает. А сторонний драйвер я не смог поставить. Хотя нет, одни поставил, что пришлось через восстановления запускать с исходным драйвером.

leaga ()
Ответ на: комментарий от leaga

Драйвер для этой карты один, сторонних нет. Ты, видимо, имеешь в виду то, что ты скачал с сайта Intel.

Что значит вылетает?

kostik87 ★★★★★ ()
Ответ на: комментарий от kostik87

При запуске видео на Flash, на любом сайте приводит к отключению изображения. Экран как будто выключается. Хотя звук идёт и перезагрузить комп, горячими клавишами можно.

leaga ()
Ответ на: комментарий от leaga

Отключи аппаратное ускорение во Flash, скорее всего, проблема в этом.

Ищи в Google что-то вроде: linux flash player disable hardware acceleration.

А вообще странно, так не должно быть.

Советую использовать другой дистрибутив Linux.

kostik87 ★★★★★ ()
Ответ на: комментарий от krang

А как ребутал? sudo service networking restart , после этого отображается что типа всё ОК, подключилась. По факту интернета нет, ничего не пингуется. Если выключить Wi-Fi то она уже не включается. И на команду sudo ifconfig wlp8s0 up выдаёт SIOCSIFFLAGS: Ошибка ввода/вывода.

leaga ()
Ответ на: комментарий от leaga

В общем ничего не меняется после обновления. Wi-Fi переходит в автономный режим и всё.

sudo rfkill list
0: hci0: Bluetooth
	Soft blocked: no
	Hard blocked: no
1: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: no
2: acer-wireless: Wireless LAN
	Soft blocked: no
	Hard blocked: no 
Да и сама ОС видет драйвер и адаптер
 lspci -knn | grep Net -A2
08:00.0 Network controller [0280]: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection [8086:4222] (rev 02)
	Subsystem: Intel Corporation WM3945ABG MOW2 [8086:1001]
	Kernel driver in use: iwl3945 
Но при этом не видит доступные wi-fi. Перезапуск network-manager тоже не даёт результат. Помогает только полная перезагрузка системы.

leaga ()
Ответ на: комментарий от anonymous

Даже переход на wicd не дал результата. Даже ещё чаще wi-fi переставал работать. Буду думать, какой другой дистрибутив поставить.

leaga ()
Ответ на: комментарий от leaga

Отпишись, пожалуйста, по результату, если поможет другой дистрибутив. Сам с этой картой Intel 3945ABG перепробовал все советы, которые нашёл. И sudo modprobe iwlwifi 11n_disable=0, и iwl3945 disable_hw_scan=1 в конфиг и все версии драйверов отсюда wireless.wiki.kernel.org/en/users/drivers/iwlegacy

Всё бестолку. Так же через какое-то время исчезает интернет, хотя иконка подключения не меняется. Но стоит туда нажать и всё, мёртво, никакие команды не помогают, только перезагрузка.

anonymous ()
Ответ на: комментарий от anonymous

Вроде помогло полная переустановка. Поставил убунту с нуля. Один раз обновил и всё работает уже 5 день, даже если wi-fi точку перезагрузить, не начинает глючить. А раньше любой обрыв, означал что нужно перезагружать ОС.

~$ lsb_release -a
No LSB modules are available.
Distributor ID:	Ubuntu
Description:	Ubuntu 16.04.2 LTS
Release:	16.04
Codename:	xenial

~$ uname -a
Linux lir-ESPRIMO-Mobile-V5505 4.4.0-64-generic #85-Ubuntu SMP Mon Feb 20 11:50:30 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux 
leaga ()
Ответ на: комментарий от anonymous

Всё получилось. Установил драйвер от windows 7 C помощью программы ndiswrapper

~$ lspci -v
08:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection (rev 02)
	Subsystem: Intel Corporation WM3945ABG MOW2
	Flags: bus master, fast devsel, latency 0, IRQ 18
	Memory at fa000000 (32-bit, non-prefetchable) [size=4K]
	Capabilities: <access denied>
	Kernel driver in use: ndiswrapper
	Kernel modules: ndiswrapper 

leaga ()

Debian Stretch с фирмварью попробуй.

SuoiCat ()
Ответ на: комментарий от anonymous

Достал стареньки samsung r700 с этой карточкой, накатил 18.10 свежую убунту - нет, похоже без колхоза никак. Ничего не изменилось. Причем в федоре без вопросов все работает.

Dmitrych ()
Ответ на: комментарий от Dmitrych

костыль

В общем быстрый гуглеж показал, что есть некая проблема с powersave, и в качестве костыля предлагается его отключать (при входе в систему, да): Ищем интерфейс: iw dev

Смотрим текущее состояние: iw dev wlp4s0 get power_save

Если включено - гасим: iw dev wlp4s0 set power_save off

аптайм две недели, полет нормальный.

Dmitrych ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.