LINUX.ORG.RU

emerge --resume -> Invalid resume list

 , ,


0

2

Всем привет

emerge --resume не может возобновить установку. Куда копать?

$ emerge --resume

These are the packages that would be merged, in order:

Calculating dependencies... done!
 * Invalid resume list:
 *
 *   (u'ebuild', u'/', u'dev-qt/qtcore-5.7.1', u'merge')
 *   (u'ebuild', u'/', u'dev-util/gtk-doc-am-1.25-r1', u'merge')
 *   (u'ebuild', u'/', u'dev-lang/nasm-2.12.01', u'merge')
 *   (u'ebuild', u'/', u'dev-perl/URI-1.710.0', u'merge')
 *   (u'ebuild', u'/', u'dev-perl/Module-Build-0.421.800', u'merge')
...
*   (u'ebuild', u'/', u'kde-frameworks/kiconthemes-5.29.0', u'merge')
 *   (u'ebuild', u'/', u'kde-plasma/polkit-kde-agent-5.8.5', u'merge')
 *
 * One or more packages are either masked or have missing dependencies:
 *
 *   >=dev-libs/icu-51.2-r1:0/57=[abi_x86_32(-)] pulled in by:
 *     (dev-libs/libxml2-2.9.4-r1:2/2::gentoo, installed)
 *
 * The resume list contains packages that are either masked or have
 * unsatisfied dependencies. Please restart/continue the operation
 * manually, or use --skipfirst to skip the first package in the list and
 * any other packages that may be masked or have missing dependencies.


Из особенностей (может связано) - не установлена (и не устанавливается) версия python'а.
$ eselect python list
Available Python interpreters, in order of preference:
  [1]   python2.7
  [2]   python3.5
  [3]   python3.4


$ emerge -pv --nodeps portage

These are the packages that would be merged, in order:

[ebuild   R    ] sys-apps/portage-2.3.3::gentoo  USE="(ipc) xattr -build -doc -epydoc (-selinux)" LINGUAS="ru" PYTHON_TARGETS="python2_7 python3_4 python3_5 -pypy" 0 KiB

Total: 1 package (1 reinstall), Size of downloads: 0 KiB

★★★★★

$ python-updater -- -av1                                                                                                                             
 * Starting Python Updater...
 * Main active version of Python:    2.7
 * Active version of Python 2:       2.7
 * Active version of Python 3:       3.5
 * Globally supported Python ABIs in installed repositories:
 *   gentoo:                         2.4 2.5 2.6 2.7 3.1 3.2 3.3 2.5-jython 2.7-jython 2.7-pypy-1.7 2.7-pypy-1.8 2.7-pypy-1.9 2.7-pypy-2.0
 *   x-portage:                      2.4 2.5 2.6 2.7 3.1 3.2 3.3 2.5-jython 2.7-jython 2.7-pypy-1.7 2.7-pypy-1.8 2.7-pypy-1.9 2.7-pypy-2.0

 * No packages need to be reinstalled.

Kroz ★★★★★
() автор топика

Поставь ту версию питона, с которой ты работал на момент построения данного листа, и убедись, что дерево с того момента не изменилось. Иначе да, фейл.

r3lgar ★★★★★
()

забей на питон_3.4, а васче, кмк, лучше использовать одну версию питона для пакета

Deleted
()
Ответ на: комментарий от r3lgar

Да, это обнаружилось во время обновления мира. Ладно, сейчас пересоберу мир, посмотрим что поменяется.

Kroz ★★★★★
() автор топика
Ответ на: комментарий от Deleted

забей на питон_3.4, а васче, кмк, лучше использовать одну версию питона для пакета

Какую? Кандидаты: 2.7, 3.4, 3.5

Kroz ★★★★★
() автор топика
Ответ на: комментарий от Kroz

у меня основная 3.5, если пакету нужна 2.7, то её одну включаю для данного пакета, например, для Deluge и всем его зависимостям.

Deleted
()
Ответ на: комментарий от Deleted

если пакету нужна 2.7, то её одну включаю для данного пакета, например, для Deluge и всем его зависимостям.

А там и без вариантов. Но если пакет может и в 2.7, и в 3.5, и при этом все его зависимости могут, и, если он зависим от кого-то, те, кто его запрашивает, то не вижу смысла отказываться. Естественно, если для этого нет необходимости ставить ещё одну версию питона. Всё равно на данный момент невозможно избавиться от 2.7, но и от 3.x тоже не избавишься толком.

r3lgar ★★★★★
()
Ответ на: комментарий от Kroz

Да, это обнаружилось во время обновления мира.

Тогда можешь сразу зачищать данный лист, он уже не взлетит. За пять лет у меня ни разу не встречал успешный --resume после промежуточного (успешного или не очень) пинания emerge.

r3lgar ★★★★★
()
Ответ на: комментарий от Kroz

Не слушай этого котика, он порой ещё не отошёл от праздников.

r3lgar ★★★★★
()
Ответ на: комментарий от Deleted

Допустим, зависимости Deluge могут и в 3.5

Если они кому-то ещё нужны, и этот кто-то умеет в 3.5, то надо. А лучше на всякий случай, ибо мало ли.

но зачем

Затем, что не всё, что написано на питоне — standalone.

r3lgar ★★★★★
()
Последнее исправление: r3lgar (всего исправлений: 1)

Была недавно аналогичная проблема, насколько я понял в процессе апдейта мира обновлялся питон который использует emerge. В новом питоне поменялся формат сереализации объектов (которая используется при сохранения текущего стейта emerge), в результате повторный запуск emerge уже на новом питоне не можед десереализовать стейт из файла.

Я просто забил и запустил emerge повторно (не resume), проблема больше не воспроизводилась.

zaz ★★★★
()
Ответ на: комментарий от r3lgar

Если они кому-то ещё нужны, и этот кто-то умеет в 3.5, то надо. А лучше на всякий случай, ибо мало ли.

Если надо будет, то портаж сообщит. А просто так собирать, зачем, если не треба.

Deleted
()
Ответ на: комментарий от Deleted

Видимо, тебе не приходилось держать кучу скриптоты на питоне мимо портажа. Только не предлагай опакетить, есть такое дерьмище, которое проще переписать с нуля, чем опакетить (код, естественно, не мой, я не настолько упорот, чтобы писать на питоне).

r3lgar ★★★★★
()
Ответ на: комментарий от zaz

Была недавно аналогичная проблема, насколько я понял в процессе апдейта мира обновлялся питон который использует emerge. В новом питоне поменялся формат сереализации объектов (которая используется при сохранения текущего стейта emerge), в результате повторный запуск emerge уже на новом питоне не можед десереализовать стейт из файла.

Помимо этого, после запуска emerge с другой задачей, список ломается. Особенно, если это промежуточное действие было над как минимум одним из элементов списка. Там, судя по всему, парсер корявый.

r3lgar ★★★★★
()
Ответ на: комментарий от r3lgar

есть одна поделка, но она без проблем заработала

Deleted
()
Ответ на: комментарий от r3lgar

Версия python'а не менялась. А вот переход с gcc 4.9 gcc 5.4 действительно что-то ломал. После вдумчивого прочтения eselect news проблему решил.

Kroz ★★★★★
() автор топика
Ответ на: комментарий от r3lgar

Да. Вот только что проверил.

Помогло либо

# Toolchain compilation 
$ for x in sys-apps/portage sys-kernel/linux-headers sys-libs/glibc sys-devel/binutils-config sys-devel/binutils sys-devel/gcc-config sys-devel/gcc sys-devel/libtool ; do emerge -1 "$x" ; done
$ for x in sys-libs/glibc sys-devel/binutils sys-devel/gcc ; do emerge -1 "$x" ; done
, взятое из какого-то форума (каюсь: gcc пересобрал перед пересборкой мира, а вот про libtool забыл)
, либо
# For gentoolkit-0.3.1 or higher:
$ revdep-rebuild --library 'libstdc++.so.6' -- --exclude gcc
, взятое с eselect news <тема: GCC 5 Defaults to the New C++11 ABI>

Kroz ★★★★★
() автор топика
Ответ на: комментарий от Kroz

Я не вижу связи листа и тулчейна. Тем более, что я когда-то встречал невозможность resume даже если не были обновлены компоненты тулчейна. Надо будет в виртуалке потестить, давно мне --resume не пригождался.

r3lgar ★★★★★
()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.