LINUX.ORG.RU

gentoo vs firebird 1.5.3


0

0

Установил firebird 1.5.3, при запуске #/etc/init.d/firebird start вылетает с ошибкой: /opt/firebird/bin/fbmgr.bin: error while loading shared libraries: libfbclient.so.1: cannot open shared object file: Permission denied

Как вылечить?


Re: gentoo vs firebird 1.5.3

от root запускаешь?

fghj ★★★★★ ()

Re: gentoo vs firebird 1.5.3

error while loading shared libraries: libfbclient.so.1:

А где она лежит и есть ли вообще такая?

cannot open shared object file: Permission denied

Какие права? Стоит ли путь к либе в /etc/ld.so.conf ? Делалась ли ldconfig ?

Lumi ★★★★★ ()
Ответ на: Re: gentoo vs firebird 1.5.3 от Lumi

Re: gentoo vs firebird 1.5.3

Лежит это дело в /opt/firebird/lib/ , символические ссылки - /usr/lib/ после: chown firebird:firebird /opt/firebird/lib/libfbclient* /lib/usr/libfbclient* chmod 744 /opt/firebird/lib/libfbclient* /lib/usr/libfbclient*

все остается по старому. А что на счет /etc/ld.so.conf ? Разве ему не достаточно того, что прописан путь к ссылкам?

cod ()
Ответ на: Re: gentoo vs firebird 1.5.3 от cod

Re: gentoo vs firebird 1.5.3

Могу бросить свой /var/db/pkg/dev-db/firebird-1.5.2/CONTENTS

Lumi ★★★★★ ()
Ответ на: Re: gentoo vs firebird 1.5.3 от Lumi

Re: gentoo vs firebird 1.5.3

Такое дело, как бы запустить я его только что запустил, НО, поправив сам /etc/init.d/firebird: запускаю не от имени $FBRunUser (которое равно firebird), а от root. Это скорее всего не дело. Может что у пользователся firebird ущимленные прова? Хотя выставлял для всех пакетов firebird права для firebird:firebird..... Странно это как то...

cod ()
Ответ на: Re: gentoo vs firebird 1.5.3 от cod

Re: gentoo vs firebird 1.5.3

Ставил-то как? Готовый скомпилированый tar zxf ... ? Тогда скорее всего действительно именно с правами что-то. Посмотри pkg_setup src_install pkg_postinstall pkg_config секции в firebird-1.5.3-r1.ebuild , может чего хорошего накопаешь. А ещё лучше -- собери сам.

Lumi ★★★★★ ()
Ответ на: Re: gentoo vs firebird 1.5.3 от Lumi

Re: gentoo vs firebird 1.5.3

ставил: emerge firebird все отлично скомпилилось, а на счет firebird-1.5.3-r1.ebuild - пересмотрел, вроде все нормально. Есть подозрение на счет прав firebird:firebird

enewgroup firebird 450

enewuser firebird 450 /bin/bash /opt/firebird firebird

хотя....

cod ()
Ответ на: Re: gentoo vs firebird 1.5.3 от cod

Re: gentoo vs firebird 1.5.3

Все, уперся в файл libstdc++.so.5 дальше становиться все ясно. Спасибо

cod ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.