LINUX.ORG.RU

Выбор и установка Linux on old Pc

 ,


0

2

Всем доброго времени суток!Собираюсь испытать linux замену, winxp на такой конфигурации PIII, ОЗУ 512МБ,видео какая-то Nvidia Riva 2 64мб.Сразу оговорюсь, это делать буду just for fun, чтобы узнать что равносильное по сравнению с winxp красота функциональность может заменить ее и не хуже работать.Ибо впринципе win шустро работает на таком железе.(Proteus,CodeVision,Bascom)и даже видео не hd идет почти спокойно.Это я описал для того что обычно на других форумах советуют другим аналоги в сто крат хуже той же вин и по оформлению и по набору софта.Заранее спасибо!

Любой дистрибутив БЕЗ DE, например твой любимый.

anonymous ()

Рекомендую Puppy Linux(в частности Lupurus) и производные(DebianDog к примеру). Размер дистра обычно не больше 100 мб, на системнике времен 1998 года работало шустро.

ozzee ()
Ответ на: комментарий от ozzee

Если память мне не изменяет, то puppy позиционируется для запуска с флешки как live.А с установкой на hdd там целый квест.

NightFobos ()
Ответ на: комментарий от NightFobos

Не изменяет. Ещё там всё запускается от рута.

anonymous ()

just for fan

Слюшай, дарагой, зачем тебе такой старый вентилятор?

debugger ★★ ()
Ответ на: комментарий от NightFobos

Какие еще предложения по выбору достаточно поддерживаемых на данный момент дистрибутивов для моего типа пк.

NightFobos ()
Ответ на: комментарий от debugger

На работе стоит, документы печатать в word, pdf смотреть, чертежи разные по электронике.А linux хотел для себя поставить, мне в нем немного комфортнее.

NightFobos ()
Ответ на: комментарий от anonymous

И ядро придётся руками собирать.

anonymous ()
Ответ на: комментарий от anonymous

Ок, и тут еще очень меня интересующий вопрос.Как я могу любой другой дистр поставить, если большинство уже не влезают на cd диск.У меня в компе только cd привод, флешки загрузочные комп не читает.И инет еще не подрубил.Как 1Gb iso мне запихнуть на cd.(именно установочник любого линукса)?

NightFobos ()
Ответ на: комментарий от NightFobos

Очень просто. Разбей на несколько дисков. Типа как в дебиане.

anonymous ()
Ответ на: комментарий от anonymous

Я это ни разу не делал, ткните как?В гугле не нарыл.Похоже неверно запрос составляю.

NightFobos ()
Ответ на: комментарий от NightFobos

Или как вариант, поставь минимальный. Запиши на диски репозитарий нужного тебе дистрибутива. И ставишь всё с дисков.

anonymous ()
Ответ на: комментарий от anonymous

И все же, как разбить большой установочник dvd, на несколько cd?

NightFobos ()
Ответ на: комментарий от NightFobos

fan — вентилятор

fun — веселье

Поправь, тут почти все знают английский.

Vsevolod-linuxoid ★★★★★ ()

Хотите Slackware? Помогу, обращайтесь.
Правда по опыту PIII-800 128 MB ждать чудес не приходится, последний KDE 3.5 свопится при любом Firefox-е ;) , даже Xfce в поддерживаемых выпусках уже тяжёл...
Остаются IceWM/OpenBox или что-то старенькое...
Хотя, 512 это ж в 4 раза больше, чем 128 :)

PS. CD есть.

bormant ★★★★★ ()
Последнее исправление: bormant (всего исправлений: 2)
Ответ на: комментарий от bormant

Были мысли на счет слаки.Так как я ее в виртулке держу, собирал сам пакеты и много чего.Но все же пока подожду что скажут господа линуксоиды.

NightFobos ()
Ответ на: комментарий от NightFobos

Любой/твой любимый/который лучше всего знаешь. Жрёт больше всего не система, а прикладные программы.

anonymous ()
Ответ на: комментарий от NightFobos

А чем Debian не подходит или просто интересно как с другими?

Napitok ()
Ответ на: комментарий от NightFobos

Раз окружение не полностью чуждо, есть повод построить своими руками что-то вменяемое на грани возможного ;)
Тем более for fun ^)

С другой стороны, 13.0 и даже KDE 3.5.10 из unsupported могут быть простым и вполне рабочим выбором.

bormant ★★★★★ ()
Ответ на: комментарий от Napitok

Debian Whizy и после Jessie, у меня уже 4 лет на домашнем ноутбуке.Хотел с другими системами посмотреть

NightFobos ()
Ответ на: комментарий от mul4

Спасибо, попробую и эти дистрибутивы.Только мне потребуется несколько дней.

NightFobos ()

kde 3.5.10 тоже шустро работает на таком железе и вышел примерно в то же время, что и sp3 для xp.

grem ★★★★★ ()

Советую больше не писать на английском.

RazrFalcon ★★★★★ ()

равносильное по сравнению с winxp красота функциональность может заменить ее и не хуже работать

Любой дистрибутив года так 2004-2005го. Как раз в это время ко второму сервиспаку икспишку допилили, так что сравнение допустимое. А современные дистры сравнивать некорректно, они всё-таки современные и выпускаются во времена, когда проц уровня P3 и 512 памяти — это самый низ low-end китайских телефонов. Даже если какой openbox и будет достаточно красив и достаточно шустро, то любой современный браузер при виде 512 метров памяти скажет «так, ну на логотип я память вижу, а на работу-то где?» (впрочем, на икспишке он скажет ровно такое же).

redgremlin ★★★★★ ()

и как кстати браузер современный на XP и таком железе крутится?

ps1h ★★ ()
Ответ на: комментарий от NightFobos

У меня в компе только cd привод, флешки загрузочные комп не читает

Значит загрузчик делай на дискете^Wcd-диске.. А саму систему (с инсталлятором) — на USB-флешку пихай

user_id_68054 ★★★★★ ()
Ответ на: комментарий от ps1h

Там интернета нет, как он выше пишет.

Комп щитай вообще бесполезный. Чё там смотреть, какие ещё схемки по электроннике (если их даже скачать неоткуда)..

Кстати вроде бы интернет есть на любом компе, который по USB подключается к сотовому телефону.. Так что фразу про отсутствие интернета я не очень понимаю

user_id_68054 ★★★★★ ()

Debian+icewm/openbox+tint2/i3wm/KDE3(Trinity)

Deleted ()

Поставил на такую машинку gentoo. Да, конпелялась она на ней долго, но счас даже работает. Лучше выньХР линуксы уже на таком железе не будут, если нужно что-то адекватное, а так just for fun, я бы лучше Win2000 накатил.

Woolf ★★ ()
Ответ на: комментарий от ps1h

Да не ставятся туда уже современные браузеры. Поддержку с полгода как вырубили.

Woolf ★★ ()
Ответ на: комментарий от user_id_68054

Как раз по этому случаю заказал wifi адаптер с антенной.Уточняю что в данный момент инета нет.Есть правда андроид который через usb может быть модемом, но не факт что с этой функцией система будет корректно работать.Сейчас на первый hdd накатил lubuntu с ядром 4.2.0-16 i686.2 часа полет нормальный, но все же немного медленнее работает чем xp.(видимо по причинам современности ос).Firefox стартует за 14 сек.В хp немного медленнее.Это пока все.

NightFobos ()

не трать время на линукс и такую конфигурацию, ставь NetBSD. PuppyRUS пакеты ставить сложнее, хорошо там пользоватся тем что есть, выбора там много, но нету доведенного до конца. Это идет как LiveCD, LiveUSB, потом NetBSD или даже FreeBSD хоть и не с супер скоростью работали у меня на 128 мб оперативной памяти и 32 мб видео карта

anonymous ()

Archlinux x32 + lxde. 168Мб оперативы кушает после холодного старта. Ну лично у меня, после продолжительной настройки. Так что будь готов потратить 4-5 дней на изучение многих утилит и финтов в arch wiki и настройку, английский тебе пригодится.

mr_Heisenberg ()
Ответ на: комментарий от NightFobos

Не читает флешку!? Срамота! А если детально изучить настройки bios?

mr_Heisenberg ()
Ответ на: комментарий от NightFobos

Забыл уточнить насчет lubuntu, ее версия 15.10.Проверил вроде норм, но немного тормозит, самую малость.Кушает 178Мб ОЗУ.

NightFobos ()
Ответ на: комментарий от NightFobos

Следующий пациент Archbang.Ранее в виртуалке крутил, понравилась скорость работы.Учитывая что виртуалка была опять же на таком железе:)Буду описывать подробно, может кому из новичков пригодится.

NightFobos ()

CentOS 6 с окружением GNOME2, или CentOS 5 с окружением KDE3. В KDE3 отруби aRts, в GNOME2 отруби PulseAudio. Скайп не запустится (версия 4.3 хочет SSE2, а у тебя SSE 1), но можно запустить новый скайп, «сохранить пароль» и запустить Скайп 4.2 Тогда будет работать. Стим не запустится (хочет SSE2).

Если при установке какой-нибудь программы возникнет ошибка «хачу новый Glibc а у тебя старый ухадиии!!!», установи Glibc 2.17 с моей странички программ. Это пересборка Glibc из CentOS 7 в 5. А можно и не обновлять Glibc, а распаковать его в новый каталог, и пропатчить бинарник капризной программы с помощью patchelf, указав ей путь до нового ld-linux.so.2

LibreOfiice обнови с официального сайта - CentOS 5 поддерживается. Драйвер NVIDIA аналогично - с официального сайта. Он поддерживает ядра Linux 2.6.18 и 2.6.32. Wine поищи в EPEL, если нет то из исходников. Лично я использую Crossover Wine 11.3, это последняя версия с поддержкой CentOS 5. Кроме того, это единственная бесплатная версия эмулятора (в главном меню выбери «Зарегистрировать программу» и тебе скажут «Спасибо, не нужно»).

Торрент-клиент используй Vuze. Из легковесных советую Tixati (хочет GTK+ 2.14, а в CentOS 5 - 2.10).

Из игр советую Super Meat Boy (сборка 2011 года с SDL 1.2, но если сумеешь собрать SDL 2.0 то вперёд). Геймпад работает! Ещё для геймпада Fceux 2.1.4a (для успешной компиляции надо закомментировать одну строчку, там в About Window слишком новый вызов GTK) в GENS (официальная RPM-ка поддерживает CentOS 5).

Музыку рекомендую слушать в XMMS с плагином eq-xmms. Существует сборка проекта Rusxmms с поддержкой русских тегов. Также ты можешь просто-напросто установить любой современный плеер из репозитория Rpmfusion (поиск - на http://pkgs.org/)

Браузер Firefox 45 ESR притрмаживает, но работает. Браузер Opera 12.16 не тормозит, но не умеет некоторые современные сайты. Поэтому от браузера можно даже отказаться! Flash Player использую 11.1 или 10.3 (11.2 хочет SSE2).

ZenitharChampion ★★★★★ ()
Последнее исправление: ZenitharChampion (всего исправлений: 2)
Ответ на: комментарий от ZenitharChampion

Спасибо за информацию.Попробую и это тоже.Игры не обязательно нужны.А вот безопасный выход в интернет не помешает.В win если поставлю антивирус совсем будет некомфортно.

NightFobos ()
Ответ на: комментарий от ZenitharChampion

Тиринг «убей» командой compton --vsync opengl. Compton требует для компиляции libdrm, libconfig и dbus. А ещё заголовочные файлы из Mesa 6.5.1 для него старые, поэтому устанавливай драйвер NVIDIA с ключом --opengl-headers. И ещё мелкая правка исходного кода.

Если нужен новый компилятор, установи его из репозитория devtoolset.

ZenitharChampion ★★★★★ ()
Ответ на: комментарий от anonymous

И в Slackware ;) ftp://slackware.osuosl.org/pub/slackware-iso/slackware-14.2-iso/ Для установки достаточно первого CD, остальное можно взять с флешки или с FTP: ftp://slackware.osuosl.org/pub/slackware/slackware-14.2/

yars068 ★★★★ ()
Последнее исправление: yars068 (всего исправлений: 1)
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.