LINUX.ORG.RU

Отфильтровать говно мамонта в APT?

 


0

1

Сделал тут запрос apt-cache search postgresql и ради любопытства посмотрел чего люди полезного запилили, а оказывается есть полезное:

apgdiff - Another PostgreSQL Diff Tool

Радостно потирая руки и вбивая в гугл название, захожу на сайт и что я вижу в разделе News:

«2012-09-21: Version 2.4 Is Out!»

И какого ... это говно мамонта делает в репе? Оно уже +100500 лет не актуально. Вот бы было здорово фильтровать такое при поиске пакетов. Существуют подобные инструменты?

★★★★

Софт теряет актуальность только когда ломается, это лет 10. Большая часть софта не обновлялась значительно/вовсе лет 5

anonymous ()
Ответ на: комментарий от anonymous

В некоторых случаях и 15, например это касается игрушек. Это всё было про линукс, для венды актуально лет 20, но в зависимости от использованных использованных костылей и количества говнокода может значительно уменьшиться, в общем-то это же верно в отношении любого софта.

anonymous ()
Ответ на: комментарий от Turbid

Т.е. фильтровать пакеты по дате последнего обновления в поиске нельзя, нет таких инструментов?

foror ★★★★ ()
Последнее исправление: foror (всего исправлений: 1 )
Ответ на: комментарий от foror

Таки выполняет своё предназначение. Возможно, не поддерживает новые версии и все фичи, и есть некоторые баги, но это не значит, что оно перестало работать с более старыми версиями PostgreSQL, которые до сих пор есть в продакшене.

anonymous00 ★★ ()

Отфильтровать говно мамонта

Не использовать дистры для некрофилов.

Отфильтровать говно мамонта в APT

Увы, никак.

robus ★★★★ ()
Ответ на: комментарий от foror

Некоторые следуют принципу «работает — не трожь». Пока нет критических багов и уязвимостей — оно может и дальше годами работать. А раз инструмент затребован — то его не будут выкидывать из репозитория, пусть хоть ему и 5, и даже 10 лет.

anonymous00 ★★ ()

У меня что то это говно мамонта сломалось:
root@debian:/# apt-get -d install gdm3
Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
gdm3 : Зависит: libglib2.0-bin (>= 2.35.0) но он не будет установлен
E: Невозможно исправить ошибки, у вас отложены (held) битые пакеты.

root@ubuntu:/# cat /etc/apt/sources.list
deb http://ftp.ru.debian.org/debian jessie main contrib
deb http://ftp.ru.debian.org/debian jessie-backports main

Ось Debian jessie только установленная, локализовал консоль да поставил дрова для wi-fi + wireless-tools, iw, wpssu...как то так его )
Из нестандартного, linux-image и linux-header из jessie-backports.

Пробовал разные зеркала, PPA и прочей не чести нет.
Пробовал:
apt update
apt-get -f install
apt upgrade

Если ставить gnome-core, там сломан еще gnome-packagekit.

Вчера ставил все тоже самое, все было нормально, просто пока воевал с тач-скрином подзасрал систему не нудными пакетами, вот думал с нуля поставлю )

Попробуйте кто на дебиан:
apt-get update
apt-get -d install gnome-core

А то может в репозитории глюк

MrDanger ()
Ответ на: комментарий от MrDanger

Не обращайте внимание что у меня то:
root@debian
то:
root@ubuntu

ставил debootstrap'ом, hostname и resolv.conf он берет из хост системы, один раз исправил руками что бы не вводить в заблуждение, другой раз забыл

MrDanger ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.