LINUX.ORG.RU

Глючит тачпад Synaptic!

 , , ,


0

3

Привет! Имею систему Debian 5.0 с обновлённым из DEB-SRC графическим стеком из Debian 8.0. Сразу после загрузки не работали клавиатура, мышь и тачпад. Погуглил проблему, нашёл решение:

/etc/hal/fdi/policy/10-x11-input.fdi

<?xml version="1.0" encoding="utf-8"?><!-- -*- SGML -*- --> 
<deviceinfo version="0.2"> 
<device> 
  <match key="info.capabilities" contains="input.keyboard"> 
    <merge key="input.x11_driver" type="string">evdev</merge> 
    <merge key="input.x11_options.XkbModel" type="string">pc105</merge> 
    <!--merge key="input.x11_options.XkbModel" type="string">evdev</merge--> 
    <merge key="input.x11_options.XkbLayout" type="string">us,ru(winkeys)</merge> 
    <merge key="input.x11_options.XkbVariant" type="string">winkeys</merge> 
    <merge key="input.x11_options.XkbOptions" type="strlist">grp:ctrl_shift_toggle</merge> 
    <append key="input.x11_options.XkbOptions" type="strlist">grp:switch</append> 
    <append key="input.x11_options.XkbOptions" type="strlist">grp_led:scroll</append> 
    <append key="input.x11_options.XkbOptions" type="strlist">compose:ralt</append> 
  </match> 
</device>
<device> 
  <match key="info.capabilities" contains="input.mouse"> 
    <merge key="input.x11_driver" type="string">evdev</merge> 
  </match> 
</device>
</deviceinfo>
/etc/hal/fdi/policy/11-x11-synaptics.fdi
<?xml version="1.0" encoding="ISO-8859-1"?>
<deviceinfo version="0.2">
  <device>
    <match key="info.capabilities" contains="input.touchpad">
        <merge key="input.x11_driver" type="string">synaptics</merge>
        <!-- Arbitrary options can be passed to the driver using
             the input.x11_options property since xorg-server-1.5. -->
        <!-- EXAMPLES:
        Switch on shared memory, enables the driver to be configured at runtime
	<merge key="input.x11_options.SHMConfig" type="string">true</merge>

	Maximum movement of the finger for detecting a tap
	<merge key="input.x11_options.MaxTapMove" type="string">2000</merge>

	Enable vertical scrolling when dragging along the right edge
	<merge key="input.x11_options.VertEdgeScroll" type="string">true</merge>

	Enable vertical scrolling when dragging with two fingers anywhere on the touchpad
	<merge key="input.x11_options.VertTwoFingerScroll" type="string">true</merge>

	Enable horizontal scrolling when dragging with two fingers anywhere on the touchpad
	<merge key="input.x11_options.HorizTwoFingerScroll" type="string">true</merge>

	If on, circular scrolling is used
	<merge key="input.x11_options.CircularScrolling" type="string">true</merge>

	For other possible options, check CONFIGURATION DETAILS in synaptics man page
        -->
    </match>
  </device>
</deviceinfo>

Теперь мышка и клавиатура работают, а тачпад при нажатиии двумя пальцами делает прокрутку (так и должно быть) а потом не выходит из режима прокрутки: курсор стоит на месте, а движение пальцем скроллит страницу. Помогает Ctrl-Alt-F1 - Ctrl-Alt-F7.

После третьего-пятого переключения на консоль в логе иксов появляется ошибка:

(EE) BUG: triggered 'if (priv->num_active_touches > priv->num_slots)'
(EE) BUG: synaptics.c:2949 in UpdateTouchState()
(EE) 
(EE) Backtrace:
(EE) 0: /usr/libexec/Xorg (xorg_backtrace+0x4d) [0x81fed5d]
(EE) 1: /usr/lib/xorg/modules/input/synaptics_drv.so (0xb5c42000+0x4641) [0xb5c46641]
(EE) 2: /usr/lib/xorg/modules/input/synaptics_drv.so (0xb5c42000+0x6ba1) [0xb5c48ba1]
(EE) 3: /usr/libexec/Xorg (0x8048000+0x7beff) [0x80c3eff]
(EE) 4: /usr/libexec/Xorg (0x8048000+0xa882f) [0x80f082f]
(EE) 5: (vdso) (__kernel_sigreturn+0x0) [0xb770ce18]
(EE) 6: /usr/libexec/Xorg (0x8048000+0x36e1e) [0x807ee1e]
(EE) 7: /usr/libexec/Xorg (0x8048000+0x3af25) [0x8082f25]
(EE) 8: /usr/libexec/Xorg (0x8048000+0x23d4c) [0x806bd4c]
(EE) 9: /lib/libc.so.6 (__libc_start_main+0xe5) [0xb732b085]
(EE) 10: /usr/libexec/Xorg (0x8048000+0x23c7d) [0x806bc7d]

И тогда скроллится нормально! Как сделать так, чтобы тачпад работал нормально сразу?

Ответ на: комментарий от slon

В SPEC-файле из Debian 8.0 в строчке Configure было --disable-hal и --enable-libudev. Но в Debian 5.0 слишком старый libudev, поэтому я сделал наоборот.

ZenitharChampion ★★★★★ ()
Ответ на: комментарий от ZenitharChampion

Ставь тег [некрофилия] чтоб люди время не теряли.

Имею систему Debian 5.0 с обновлённым из DEB-SRC графическим стеком из Debian 8.0

Зачем тебе нужен Lenny?

mandala ★★★★ ()

А не рановато на 5.0-то? Может стоило на 4.0 посидеть ещё лет 5-6?

anonymous ()

Ребят ну помогите мне. Ну и что что HAL? В актуальном CentOS 6 тоже HAL!

ZenitharChampion ★★★★★ ()
Последнее исправление: ZenitharChampion (всего исправлений: 1)
Ответ на: комментарий от mandala

Ну тут же много пользователей энтерпрайс линукса! А там по-прежнему HAL! Как вы видите по логам, я обновил иксы с 1.5 до 1.17.2, и Синаптик стал глючить... Может и не в Хале дело вообще. Хал только включает авто определение устройств!

ZenitharChampion ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.