LINUX.ORG.RU

[Arch] Раскладка клавиатуры


0

0

Почему может не переключаться раскладка клавиатуры в Arch-е. Когда консоль без Х-ов, то она переключается, когда загружаю Х-ы перестает.
в rc.conf:
KEYMAP=«ru-utf» (пробовал и ru-mab (раскладки скачаны и лежат в /usr/share/kbd/keymaps/i386/qwerty)

в /etc/hal/fdi/policy/10-keymap.fdi:
<?xml version=«1.0» encoding=«utf-8»?>
<deviceinfo version=«0.2»>
<device>
<match key=«info.capabilities» contains=«input.keypad»>
<merge key=«input.xkb.rules» type=«string»>base</merge>
<merge key=«input.xkb.model» type=«string»>pc105</merge>
<merge key=«input.x11_driver» type=«string»>evdev</merge>
<merge key=«input.xkb.layout» type=«string»>us,ru</merge>
<merge key=«input.xkb.variant» type=«string»>,winkeys</merge>
<merge key=«input.xkb.options» type=«string»>grp:rctrl_toggle</merge>
</match>
</device>
</deviceinfo>

Hal запущен.

Не проще через xorg.conf настроить, чем с халовыми xml-ами возится?

Viglim ()

setxkbmap -layout «us,ru(winkeys)» -model pc105 -option grp:ctrl_shift_toggle,grp_led:scroll

AITap ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.