LINUX.ORG.RU

Установка Samba

 ,


0

1

Установил самбу, накосячил с настройкой smb.conf (бэкапить надо было!), удалил самбу, теперь пытаюсь установить ее заново, выдает ошибки:

apt-get install samba Чтение списков пакетов… Готово Построение дерева зависимостей Чтение информации о состоянии… Готово Уже установлена самая новая версия samba. обновлено 0, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено. не установлено до конца или удалено 5 пакетов. После данной операции, объём занятого дискового пространства возрастёт на 0 B. Хотите продолжить? [Д/н] y Настраивается пакет samba (2:4.2.10+dfsg-0+deb8u3) … insserv: warning: script 'galaxy1' missing LSB tags and overrides insserv: warning: script 'galaxy' missing LSB tags and overrides Job for smbd.service failed. See 'systemctl status smbd.service' and 'journalctl -xn' for details. invoke-rc.d: initscript smbd, action «start» failed. dpkg: ошибка при обработке пакета samba (--configure): подпроцесс установлен сценарий post-installation возвратил код ошибки 1 dpkg: зависимости пакетов не позволяют настроить пакет winbind: winbind зависит от samba (= 2:4.2.10+dfsg-0+deb8u3), однако: Пакет samba пока не настроен.

dpkg: ошибка при обработке пакета winbind (--configure): проблемы зависимостей — оставляем не настроенным dpkg: зависимости пакетов не позволяют настроить пакет libnss-winbind:amd64: libnss-winbind:amd64 зависит от winbind (= 2:4.2.10+dfsg-0+deb8u3), однако: Пакет winbind пока не настроен.

dpkg: ошибка при обработке пакета libnss-winbind:amd64 (--configure): проблемы зависимостей — оставляем не настроенным dpkg: зависимости пакетов не позволяют настроить пакет libpam-winbind:amd64: libpam-winbind:amd64 зависит от winbind (= 2:4.2.10+dfsg-0+deb8u3), однако: Пакет winbind пока не настроен.

dpkg: ошибка при обработке пакета libpam-winbind:amd64 (--configure): проблемы зависимостей — оставляем не настроенным dpkg: зависимости пакетов не позволяют настроить пакет libapache2-mod-auth-ntlm-winbind: libapache2-mod-auth-ntlm-winbind зависит от winbind, однако: Пакет winbind пока не настроен.

dpkg: ошибка при обработке пакета libapache2-mod-auth-ntlm-winbind (--configure): проблемы зависимостей — оставляем не настроенным При обработке следующих пакетов произошли ошибки: samba winbind libnss-winbind:amd64 libpam-winbind:amd64 libapache2-mod-auth-ntlm-winbind E: Sub-process /usr/bin/dpkg returned an error code (1)


See 'systemctl status smbd.service' and 'journalctl -xn' for details.

this.

conalex ★★★ ()

Проблему решил забросом стандартного smb.conf в /etc/samba

bb8 ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.