LINUX.ORG.RU

Ubuntu 14.04 x64 Вышло сообщение не все обновления могу быть установленыю.

 ,


0

1

Доброе время суток уважаемые. Помогите пожалуйста решить проблему.

Во время очередного обновления приложений вышло окно:

[img]http://savepic.ru/8376729m.png[/img]

Если выбрать частичное то появляется вот это окно:

[img]http://savepic.ru/8324507m.png[/img]

где в списке пакетов которые больше не нужны и будут удалены почти всё окружение Unity и программы и если согласиться Unity вообще не загрузиться. И его придётся ставить заново

Команда

sudo apt-get dist-upgrade 
приводит к такому же результату.

Предыдущее обновление (за день до этого) прошло нормально между ними компьютер никто вообще не трогал не выключал и не перезагружал.

И да, команда

sudo apt-get upgrade
Выводит
Пакеты, которые будут оставлены в неизменном виде:
  gcc-4.9-base gcc-4.9-base:i386 lib32gcc1 libgcc1 libgcc1:i386
обновлено 0, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 5 пакетов не обновлено.

При попытке их пере установить система предлагает снести почти весь Unity. Возможно это и является причиной вывода сообщения: о частичном обновлении.

Что это за пакеты почему их обновление ведёт к таким последствиям и как это исправить.

В линуксе работаю всего несколько месяцев поэтому большая просьба ногами сильно не пинать если, что не так.

Возможно, виртуальный пакет ссылается на неверный конечный пакет. Недавно такое было на PPA с ядрами команды убунты. Ссылается на один файл (версия в имени) а в реале лежит другой.

targitaj ★★★★★ ()

какой сервер для обновлений используешь? Если «Российская Федерация», то лучше поставь «Основной» (в /etc/apt/sources.list должно быть deb http://archive.ubuntu.com/ubuntu). У меня с РФ иногда глюки при обновлении были (видимо, у него проблема с синхронизацией)

Sahas ★★★★★ ()

Если уж убунта глючит, чего ждать от других. Дааааа, а ещё линукс куда-то рыпается, на декстопы лезет. Нормально обновиться-то не может.

anonymous ()
Ответ на: комментарий от targitaj

Спасибо за ответ но понял я вас весьма смутно и ситуацию для меня это не прояснило

Shaman207 ()
Ответ на: комментарий от Shaman207

ну тогда cat /etc/apt/sources.list и выхлоп apt-get upgrade в студию. Но сначала попробуй sudo aptitude, он более продвинутый в плане разруливания зависимостей

Sahas ★★★★★ ()
Ответ на: комментарий от targitaj

Не следует использовать aptitude для установки пакетов.

это почему? Я, правда, не использую (в основном), но иногда он выручал

Sahas ★★★★★ ()
Ответ на: комментарий от Sahas

Баги. Деталей не помню. Обсуждалось. Вроде как бьёт признак «автоматической установки», в том числе. Не рекомендуется, в общем, использовать для установки пакетов. На свежих убунтах и в джесси есть утилита на замену. Просто apt. Типа apt install packet. В визи такой утилиты нет. aptitude для поиска рулит.

targitaj ★★★★★ ()
Ответ на: комментарий от targitaj

ок, взял на заметку. Но для обновлений можно и его поюзать...

Sahas ★★★★★ ()
Ответ на: комментарий от Sahas

sources.list

выхлоп sudo apt-get upgrade

Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Расчёт обновлений…Готово
Пакеты, которые будут оставлены в неизменном виде:
  gcc-4.9-base gcc-4.9-base:i386 lib32gcc1 libgcc1 libgcc1:i386
обновлено 0, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 5 пакетов не обновлено
Shaman207 ()
Ответ на: комментарий от Shaman207

Подскажите как убирать под спойлер?

Делаю [«cut»]Текст, который будет скрыт внутри спойлера[«/cut»] Естественно без кавычек.

А получается:

Текст, который будет скрыт внутри спойлера

Shaman207 ()
Ответ на: комментарий от Shaman207

Я не знаю, что я должен там увидеть

замочек. Но раз нет, значит не залочен... Всё-таки рекомендую попробовать aptitude

Sahas ★★★★★ ()
Ответ на: комментарий от Shaman207

да, ещё в synaptic посмотри по разделам (Состояние-> Закреплённые и Специальные фильтры -> с ошибками), может, что интересное найдёшь...

Sahas ★★★★★ ()

Я когда на 14.04.3 обновлялся весь замучился. Я уже не помню всей ситуации, но суть в том, что обновление не ставилось из-за каких-то установленных пакетов. При попытке их удалить пакетный менеджер предлагал снести полсистемы. Причем, эти пакеты - обычные прикладные софтины. И это Ubuntu LTS. Таки замечу, что на Debian тоже были подобные приключения. С чем связано такое поведение даже не могу предположить. Видимо, это болячка всех deb-based.

Попробуй отдельно по каждому пакету, что не могут установиться при обновлении, ставить, разруливая вручную его зависимости.

permafrost ★★ ()
Ответ на: комментарий от Sahas

Спасибо всем кто помогал.

Извините, что пропал.

В фильтрах с ошибками не было ничего. Попробовал обновить эти 5 пакетов из синаптика система упала совсем. Поэтому и пропал т.к. писал с неё.

После «обновления» был удален даже пакет apt система грузилась демоны типа FTP, DLNA, SSH, SMB работали а настроить установить или удалить что либо было не возможно.

Надоело мучатся накатил систему с архива т.к. время потраченное на устранение неисправности уже в несколько раз превысило время необходимое на доводку после восстановления. А это самое главное. Жаль конечно, что и не разобрался.

Shaman207 ()

Да нифига себе...
Ник то смени. У завсегдатаев ЛОРа на Шому уже рефлекс выработан.

Краем глаза узрел Шаман + Убунта + обновления...

Думал какая то важная инфа проскочила...
А тут какие-то виртуалы бегают 8-/

Deleted ()
Ответ на: комментарий от Shaman207

Спасибо

да не за что, проблема-то не решена... Если такая история вдруг повторится, на твоём месте просто бы повременил с обновлениями

Sahas ★★★★★ ()
Последнее исправление: Sahas (всего исправлений: 1)
Ответ на: комментарий от Deleted

Вы о чем, если мой ник с кем то совпадает я то здесь причем?

Нашел форум поиском в процессе решения проблемы. зарегистрировался и спросил.

Shaman207 ()
Ответ на: комментарий от Sahas

Скорее всего так и сделаю. После настройки снова сделал архив. Так, что можно рискнуть.

Shaman207 ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.