LINUX.ORG.RU

Поломалось обновление системы


0

1

Обновил дистрибутив до Debian Sid.

В Sid Multiarch, потому что бы установить скайп хотел библиотеки библиотеки i386. Сделал все в соответствии с инструкцией по установке скайпа с сайта дебиан:

# dpkg --add-architecture i386
# apt-get update
# wget -O skype-install.deb http://www.skype.com/go/getskype-linux-deb
# dpkg -i skype-install.deb
Скайп установился нормально, но появились проблемы с обновлением системы
 
root@deqox:/# apt-get dist-upgrade
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Возможно, для исправления этих ошибок вы захотите воспользоваться «apt-get -f install».
Пакеты, имеющие неудовлетворённые зависимости:
 libldap-2.4-2:i386 : Зависит: libsasl2-2:i386 (>= 2.1.24) но он не установлен
 libnss-ldap:i386 : Зависит: libsasl2-2:i386 (>= 2.1.24) но он не установлен
E: Неудовлетворённые зависимости. Попытайтесь использовать -f.
root@deqox:/# apt-get -f install
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Исправление зависимостей… Готово
Будут установлены следующие дополнительные пакеты:
  libsasl2-2:i386 libsasl2-modules:i386
Предлагаемые пакеты:
  libsasl2-modules-otp:i386 libsasl2-modules-ldap:i386 libsasl2-modules-sql:i386 libsasl2-modules-gssapi-mit:i386 libsasl2-modules-gssapi-heimdal:i386
НОВЫЕ пакеты, которые будут установлены:
  libsasl2-2:i386 libsasl2-modules:i386
обновлено 0, установлено 2 новых пакетов, для удаления отмечено 0 пакетов, и 97 пакетов не обновлено.
не установлено до конца или удалено 133 пакетов.
Необходимо скачать 0 B/231 kB архивов.
После данной операции, объём занятого дискового пространства возрастёт на 497 kB.
Хотите продолжить [Д/н]? y
(Чтение базы данных ... на данный момент установлено 233796 файлов и каталогов.)
Распаковывается пакет libsasl2-2:i386 (из файла .../libsasl2-2_2.1.25.dfsg1-4+b1_i386.deb)...
dpkg: error processing /var/cache/apt/archives/libsasl2-2_2.1.25.dfsg1-4+b1_i386.deb (--unpack):
 trying to overwrite shared '/usr/share/doc/libsasl2-2/changelog.Debian.gz', which is different from other instances of package libsasl2-2:i386
Распаковывается пакет libsasl2-modules:i386 (из файла .../libsasl2-modules_2.1.25.dfsg1-4+b1_i386.deb)...
dpkg: error processing /var/cache/apt/archives/libsasl2-modules_2.1.25.dfsg1-4+b1_i386.deb (--unpack):
 trying to overwrite shared '/usr/share/doc/libsasl2-modules/changelog.Debian.gz', which is different from other instances of package libsasl2-modules:i386
При обработке следующих пакетов произошли ошибки:
 /var/cache/apt/archives/libsasl2-2_2.1.25.dfsg1-4+b1_i386.deb
 /var/cache/apt/archives/libsasl2-modules_2.1.25.dfsg1-4+b1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Как восстановить обновление, но не сломать скайп?

/usr/share/doc/libsasl2-modules/changelog.Debian.gz

Выньте этот файл из /var/cache/apt/archives/libsasl2-modules_2.1.25.dfsg1-4+b1_i386.deb и сравните с существующим в системе.

Может быть, нужно сначала обновить libsasl2-2:amd64 до последней версии?

AITap ★★★★★ ()
Ответ на: комментарий от AITap

Скачал и установил вручную libsasl2-2_2.1.25.dfsg1-4+b1_amd64.deb

Выньте этот файл из /var/cache/apt/archives/libsasl2-modules_2.1.25.dfsg1-4+b1_i386.deb и сравните с существующим в системе.

Поменял один на другой. Остались те же ошибки

QIQuJIunn ★★ ()
Ответ на: комментарий от QIQuJIunn

Чем различаются существующий /usr/share/doc/libsasl2-modules/changelog.Debian.gz и файл из пакета libsasl2-modules_2.1.25.dfsg1-4+b1_i386.deb?

AITap ★★★★★ ()

Переименуй /usr/share/doc/libsasl2-2/changelog.Debian.gz во что-нибудь другое. Мультиарч пока еще сыроват, а с сидом впридачу еще веселее :)

leave ★★★★★ ()
Ответ на: комментарий от AITap

его вообще небыло, после того как я этот пакет в ручную пытался поставить, он не поставился, но файл появился. Помню что различались тем что в одном архитектура i386 была указана, в другом amd64. Но сейчас ничем не отличаются

QIQuJIunn ★★ ()
Ответ на: комментарий от leave
root@deqox:/# apt-get dist-upgrade 
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Возможно, для исправления этих ошибок вы захотите воспользоваться «apt-get -f install».
Пакеты, имеющие неудовлетворённые зависимости:
 libxml2 : Ломает: libxml2:i386 (!= 2.8.0+dfsg1-5) но 2.8.0+dfsg1-4 уже установлен
 libxml2:i386 : Рекомендует: xml-core:i386 но он не может быть установлен
                Ломает: libxml2 (!= 2.8.0+dfsg1-4) но 2.8.0+dfsg1-5 уже установлен
E: Неудовлетворённые зависимости. Попытайтесь использовать -f.
QIQuJIunn ★★ ()
Ответ на: комментарий от QIQuJIunn

Ломает: libxml2:i386 (!= 2.8.0+dfsg1-5) но 2.8.0+dfsg1-4 уже установлен
Ломает: libxml2 (!= 2.8.0+dfsg1-4) но 2.8.0+dfsg1-5 уже установлен

Сделайте так, чтобы версии libxml2:i386 и libxml2:amd64 в системе совпадали.

AITap ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.