LINUX.ORG.RU

Не запускается Steam в ArchLinux

 ,


0

1

Пишу в терминале Steam, все вроде норм, но потом:

[reedych@archlinux-0 retroshare-svn]$ steam
/home/reedych/.local/share/Steam/steam.sh: line 161: VERSION_ID: unbound variable
/home/reedych/.local/share/Steam/steam.sh: line 161: VERSION_ID: unbound variable
Running Steam on arch  32-bit
/home/reedych/.local/share/Steam/steam.sh: line 161: VERSION_ID: unbound variable
STEAM_RUNTIME is enabled automatically
Installing breakpad exception handler for appid(steam)/version(0)
и зависает ничего дальше не делая... Чем я не угодил стиму? Дрова xf86-video-ati. Еще вот:

[reedych@archlinux-0 retroshare-svn]$ cd /home/reedych/.local/share/Steam/
[reedych@archlinux-0 Steam]$ ./steam.sh
./steam.sh: line 161: VERSION_ID: unbound variable
./steam.sh: line 161: VERSION_ID: unbound variable
Running Steam on arch  32-bit
./steam.sh: line 161: VERSION_ID: unbound variable
STEAM_RUNTIME is enabled automatically
ILocalize::AddFile() failed to load file "public/steambootstrapper_english.txt".
[2015-07-23 00:34:34] Startup - updater built May  5 2015 12:15:27
Installing breakpad exception handler for appid(steam)/version(0)
SteamUpdateUI: An X Error occurred
X Error of failed request:  BadMatch (invalid parameter attributes)
Major opcode of failed request:  1 (X_CreateWindow)
Serial number of failed request:  25
xerror_handler: X failed, continuing
SteamUpdateUI: An X Error occurred
X Error of failed request:  BadWindow (invalid Window parameter)
Major opcode of failed request:  18 (X_ChangeProperty)
Resource id in failed request:  0x3400002
Serial number of failed request:  27
xerror_handler: X failed, continuing
SteamUpdateUI: An X Error occurred
X Error of failed request:  BadWindow (invalid Window parameter)
Major opcode of failed request:  18 (X_ChangeProperty)
Resource id in failed request:  0x3400002
Serial number of failed request:  29
xerror_handler: X failed, continuing
SteamUpdateUI: An X Error occurred
X Error of failed request:  BadWindow (invalid Window parameter)
Major opcode of failed request:  18 (X_ChangeProperty)
Resource id in failed request:  0x3400002
Serial number of failed request:  32
xerror_handler: X failed, continuing
SteamUpdateUI: An X Error occurred
X Error of failed request:  BadDrawable (invalid Pixmap or Window parameter)
SteamUpdateUI: An X Error occurred
X Error of failed request:  BadDrawable (invalid Pixmap or Window parameter)

Чем я не угодил стиму?

арчем

amorpher ★★★★★ ()

В steam и arch не шарю, но разве 32-bit всё ещё актуальны?

beastie ★★★★★ ()
Ответ на: комментарий от Reedych

Hardware and Software Requirements

Steam for Linux requires the following:

1 GHz Pentium 4 or AMD Opteron with 512 megabytes of RAM and 5 gigabytes of hard drive space, or better
Internet connection (Cable/DSL speeds recommended)
Ubuntu 12.04 LTS, fully updated
Latest graphics driver
NVidia driver support - For recent cards (e.g. series 8), you will need to install 310.x. For older cards, driver 304.x supports the NVidia 6 and 7 GPU series. To access these drivers, first update your cache and then install the specific driver you need from the list in Additional Drivers.
AMD driver support - For recent cards (e.g. series 5 and above), we recommend installing the 12.11 driver. For older cards, Catalyst 13.1 Legacy supports the HD 2400 Pro card and is the latest for the 2 and 4 GPU series.
Intel HD 3000/4000 driver support - you will need to use the latest Mesa drivers, Mesa 9 or later. For installation instructions, see here.

https://github.com/ValveSoftware/steam-for-linux

amorpher ★★★★★ ()
Ответ на: комментарий от Reedych

Тебе же белым по чёрному писано:

./steam.sh: line 161: VERSION_ID: unbound variable
Смотри, что там не так.

beastie ★★★★★ ()
Ответ на: комментарий от amorpher

перечитал 100 раз, не помог, может русскую прочитать

Reedych ★☆ ()
Ответ на: комментарий от f1u77y

Я без понятия в этих ваших игрульках, но это намекает, что что-то там не так, что скорей всего можно поправить в один-два едита.

beastie ★★★★★ ()

гуглинг по SteamUpdateUI: An X Error occurred дал вот это: https://github.com/ValveSoftware/steam-for-linux/issues/3820. краткий пересказ: ставь блоб, и всё будет хорошо. другого выхода нет, т.к. issue не закрыто.

неужели нельзя было повторить ту же последовательность действий?

f1u77y ★★★ ()

Может быть ты хотя бы видеокарту напишешь и её драйвер?

RelativeLayout ()
Ответ на: комментарий от beastie

ну вроде как можно догадаться, что отсутствие VERSION_ID(емнип, это штука в /etc/*release) вряд ли может закрашить стим.

f1u77y ★★★ ()
Ответ на: комментарий от RelativeLayout

Дрова xf86-video-ati

думаю, этого достаточно. если сможешь найти информацию, специфичную для какой-то модели, желаю удачи.

f1u77y ★★★ ()
Ответ на: комментарий от f1u77y
./ubuntu12_32/steam-runtime/amd64/lib/x86_64-linux-gnu/libgcc_s.so.1
./ubuntu12_32/steam-runtime/amd64/usr/lib/x86_64-linux-gnu/libstdc++.so.6.0.18
./ubuntu12_32/steam-runtime/i386/lib/i386-linux-gnu/libgcc_s.so.1
./ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/libstdc++.so.6.0.18

Вот эти файлы нужно спрятать от стима при использовании открытых драйверов.

RelativeLayout ()
Ответ на: комментарий от f1u77y

Ещё раз — мну баз понятия, т.к. steam в глаза ниразу не видел (и не собираюсь), но от этой переменной могут зависть параметры или подгрузка библиотек. Т.ч. не плохо было бы глянуть, что там не так.

beastie ★★★★★ ()
Ответ на: комментарий от RelativeLayout

странно, не увидел этого в issues на гитхабе. откуда?

f1u77y ★★★ ()
Ответ на: комментарий от Reedych

если не помогло, попробуй пустить под блобом. на гитхабе говорят, что это проблему решает.

f1u77y ★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.