LINUX.ORG.RU

Как настроить Google Public DNS?

 , ,


0

1

У меня проблемы с интернетом, а точнее со всеми сервисами гугла, включая шрифтовые googleapis ЛОРа, либо не грузится вообще, либо медленно.

Я решил настроить Google Public DNS, поскольку гугл (по этой же причине) не работает, в виках и гентуфоруме нашел кусочки настроек.

Что нужно, чтобы настроить? Поскольку я не понял, где именно нужно настроить: на компе или на роутере (openwrt), то настраиваю везде. Сейчас у меня так:

Гента:

/etc/conf.d/net

modules="!ifconfig"

bridge_br0="eth0 tap0"
rc_net_br0_need="net.eth0 net.tap0"

brctl_br0="setfd 0
sethello 10
stp off"

mac_br0="DE:AD:BE:EF:F1:21"

config_eth0=null

tuntap_tap0="tap"
config_tap0=null

dns_servers="8.8.8.8 8.8.4.4"
dhcp="nodns"
/etc/dhcpcd.conf:
static domain_name_servers=8.8.8.8
cat /etc/resolv.conf:
cat /etc/resolv.conf 
# Generated by dhcpcd from br0, eth0
# /etc/resolv.conf.head can replace this line
domain lan
nameserver 8.8.8.8
# /etc/resolv.conf.tail can replace this line

Роутер:

-> cat /etc/config/network

config interface 'wan'
	...
	...
	option dns '8.8.8.8 8.8.4.4'
-> cat /etc/dnsmasq.conf
 
server=8.8.8.8
server=8.8.4.4
-> cat /etc/config/dhcp

config dnsmasq

	...
	...
	option server '8.8.8.8'
        option server '8.8.4.4'

-> cat /tmp/resolv.conf.auto 

# Interface wan
nameserver 8.8.8.8
nameserver 8.8.4.4

Как проверить, что у меня действительно настроен и работает Google Public DNS вместо провайдерского? Потому что нихрена google поиск, сервисы типа шрифтов, гугл группы, аналитикс и всё, что связанно с гуглом на сайтах либо адски тормозит, либо не работает вообще. Спасибо.


А с чего ты взял, что проблема вообще в dns?!

daemonpnz ★★★★★ ()
emerge bind-tools
nslookup ya.ru
Server:		8.8.8.8
Address:	8.8.8.8#53

Non-authoritative answer:
Name:	ya.ru
Address: 213.180.204.3
Name:	ya.ru
Address: 93.158.134.3
Name:	ya.ru
Address: 213.180.193.3
daemonpnz ★★★★★ ()
Последнее исправление: daemonpnz (всего исправлений: 1)
Ответ на: комментарий от daemonpnz
→ nslookup ya.ru
Server:		8.8.8.8
Address:	8.8.8.8#53

Non-authoritative answer:
Name:	ya.ru
Address: 213.180.204.3
Name:	ya.ru
Address: 93.158.134.3
Name:	ya.ru
Address: 213.180.193.3

А с чего ты взял, что проблема вообще в dns?!

Да вот спрашивал здесь в тебе, подсказали что возможно оно: Объясните, что у меня происходит с браузерами и интернетом?.

slon ()
Ответ на: комментарий от daemonpnz

Всё так же тупит, ровно до того момента, пока не почистишь кеш на любом из браузеров, но чистка кеша помогает только один запрос на гугл сделать, следующие уже не работают если опять не почистить кеш.

Вопрос: достаточно настроить на генте или на роутере тоже должно работать? Потому что там пока не получается убедиться в том, что работает через 8.8.8.8 как не настраивай. Вышеуказанная инфа была с генты.

slon ()
Ответ на: комментарий от slon

Ну так тупит у тебя на Генте, запросы посылает гента через шлюз, шлюз в данном случае просто связывает комп с днс. Так что проблема тут явно не в днс.

Для чистоты эксперимента, грузишься с ливцд любого удобного для тебя дистра, например, убунта. И там ппроверяешь работу. Если там работает норм. То значит косяк на твоей стороне.

daemonpnz ★★★★★ ()
Последнее исправление: daemonpnz (всего исправлений: 1)
Ответ на: комментарий от daemonpnz

Прикол в том, черт бы его подрал, что в виртуалке на этой же машине всё прекрасно работает, а виртуалка получает же сеть с генты, с вышеуказанного /etc/conf.d/net через бридж.

Вообще понять не могу, что происходит.

slon ()
Ответ на: комментарий от slon

Значит что-то начудил со сборкой браузеров в самой системе.

daemonpnz ★★★★★ ()
Ответ на: комментарий от Chaser_Andrey

Спасибо, похоже, но еще нужно протестировать, помогло раскомментирование опции в /etc/dhcpcd.conf:

# Respect the network MTU.
# Some interface drivers reset when changing the MTU so disabled by default.

option interface_mtu
хотя сам mtu у интерфейсов не поменялся, насколько я смотрю в ifconfig.

slon ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.