LINUX.ORG.RU
ФорумAdmin

проблема с DNS


0

1

ни с того ни ссего перестали резолвится хосты:

stas@SunFire:~$ ping linux.org.ru
ping: unknown host linux.org.ru

Хотя вроде бы все правильно... недорубаю...

stas@SunFire:~$ cat /etc/resolv.conf 
nameserver 192.168.1.4
nameserver 8.8.8.8
nameserver 8.8.4.4

stas@SunFire:~$ cat /etc/network/interfaces 
auto lo
iface lo inet loopback

# The primary network interface
allow-hotplug eth0
iface eth0 inet static
        address 192.168.1.4
        netmask 255.255.255.0
        network 192.168.1.0
        broadcast 192.168.1.255
        gateway 192.168.1.1
        # dns-* options are implemented by the resolvconf package, if installed
#       dns-nameservers 8.8.8.8 8.8.4.4
stas@SunFire:~$ cat /etc/dhcp/dhcpd.conf
subnet 192.168.1.0  netmask 255.255.255.224 {
  range 192.168.1.7 192.168.1.11;
  option routers 192.168.1.1;
  option domain-name-servers 8.8.8.8, 8.8.4.4, 192.168.1.4; 
  option domain-name fire;

host debian {
  hardware ethernet *************************;
  fixed-address 192.168.1.2;
}

host hp {
  hardware ethernet *************************;
  fixed-address 192.168.1.3;
}

}   

★★★

dig @8.8.8.8 linux.org.ru
dig @8.8.4.4 linux.org.ru
dig @192.168.1.4 linux.org.ru
adriano32 ★★★ ()
Ответ на: комментарий от adriano32

stas@SunFire:~$ dig @8.8.8.8 linux.org.ru

; <<>> DiG 9.7.3 <<>> @8.8.8.8 linux.org.ru
; (1 server found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 495
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;linux.org.ru.                  IN      A

;; ANSWER SECTION:
linux.org.ru.           860     IN      A       217.76.32.61

;; Query time: 72 msec
;; SERVER: 8.8.8.8#53(8.8.8.8)
;; WHEN: Fri Nov 11 02:21:25 2011
;; MSG SIZE  rcvd: 46

stas@SunFire:~$ dig @8.8.4.4 linux.org.ru

; <<>> DiG 9.7.3 <<>> @8.8.4.4 linux.org.ru
; (1 server found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 65070
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;linux.org.ru.                  IN      A

;; ANSWER SECTION:
linux.org.ru.           860     IN      A       217.76.32.61

;; Query time: 66 msec
;; SERVER: 8.8.4.4#53(8.8.4.4)
;; WHEN: Fri Nov 11 02:21:25 2011
;; MSG SIZE  rcvd: 46

stas@SunFire:~$ dig @192.168.1.4 linux.org.ru

; <<>> DiG 9.7.3 <<>> @192.168.1.4 linux.org.ru
; (1 server found)
;; global options: +cmd
;; connection timed out; no servers could be reached
stas@SunFire:~$ 
disee ★★★ ()
Ответ на: комментарий от disee

no servers could be reached

Кто там у тебя по 192.168.1.4? Поменяй порядок, гуглы вверх, работать должно. Или разберись что с этим DNS-сервером

adriano32 ★★★ ()
Ответ на: комментарий от adriano32

выпилил его вообще из resolv.conf . без результатов. раскоментил

      dns-nameservers 8.8.8.8 8.8.4.4
в intefaces. без толку. :(

disee ★★★ ()
Ответ на: комментарий от adriano32

кста 192.168.1.4 это и есть сам сервер который лишился dns.

disee ★★★ ()
Ответ на: комментарий от adriano32

tas@SunFire:/etc/network$ dig @192.168.1.1 linux.org.ru

; <<>> DiG 9.7.3 <<>> @192.168.1.1 linux.org.ru
; (1 server found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 57092
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 2

;; QUESTION SECTION:
;linux.org.ru.                  IN      A

;; ANSWER SECTION:
linux.org.ru.           3600    IN      A       217.76.32.61

;; AUTHORITY SECTION:
linux.org.ru.           556     IN      NS      ns2.linux.org.ru.
linux.org.ru.           556     IN      NS      ns1.linuxhacker.ru.

;; ADDITIONAL SECTION:
ns1.linuxhacker.ru.     37776   IN      A       217.76.32.61
ns2.linux.org.ru.       744     IN      A       81.177.34.140

;; Query time: 67 msec
;; SERVER: 192.168.1.1#53(192.168.1.1)
;; WHEN: Fri Nov 11 02:35:28 2011
;; MSG SIZE  rcvd: 126
disee ★★★ ()
Ответ на: комментарий от disee

Вот его и пропиши в resolv.conf. Или если у тебя bind/dnsmasq крутится, укажи его в качестве forwarders и верни 192.168.1.4 на место после перезапуска своего DNS_сервера

adriano32 ★★★ ()
Ответ на: комментарий от adriano32

вообще ничего не понимаю

stas@SunFire:/etc/network$ nslookup -sil www.linux.org.ru
Server:         8.8.8.8
Address:        8.8.8.8#53

Non-authoritative answer:
Name:   www.linux.org.ru
Address: 217.76.32.61

stas@SunFire:/etc/network$ ping linux.org.ru
ping: unknown host linux.org.ru
stas@SunFire:/etc/network$ 

disee ★★★ ()
Ответ на: комментарий от adriano32

самое интересное что 192.168.1.1 - модем, на котором отключен DNS сервер о_О. Ща попробую

disee ★★★ ()
Ответ на: комментарий от adriano32
root@SunFire:/etc# cat /etc/resolv.conf 
nameserver 192.168.1.1
nameserver 8.8.8.8
nameserver 8.8.4.4
#nameserver 192.168.1.4
root@SunFire:/etc# ping linux.org.ru
ping: unknown host linux.org.ru
disee ★★★ ()
Ответ на: комментарий от adriano32

интересно что в той же сети стоит десктоп, у которого все отлично... и

root@debian:/etc/samba# cat /etc/resolv.conf 
nameserver 192.168.1.4
nameserver 8.8.8.8
nameserver 8.8.4.4

disee ★★★ ()
Ответ на: комментарий от disee

что у тебя стоит в качестве DNS-сервера на 192.168.1.4? Где 53-й порт открыты?

adriano32 ★★★ ()
Ответ на: комментарий от adriano32

в качестве dns сервера стоит ничего . Я прописал его в резолвы только потому, что он работает в качестве пдц. И боялся что мой доменчег не будет виден в домашней сети. Кстати в последнее время я очень много капаюсь с самбой (домен знаете ли настраиваю). Из последних нововведений winbind. Но я думаю это вряд ли может повеять

disee ★★★ ()
Ответ на: комментарий от disee

в качестве dns сервера стоит ничего

Ну а какого чёрта ты его прописываешь в resolv.conf?

adriano32 ★★★ ()
Ответ на: комментарий от adriano32

боялся что мой доменчег не будет виден в домашней сети

ладно это пофиг!
Что еще может быть не так?

disee ★★★ ()
Ответ на: комментарий от disee

пакет resolvconf стоит? впиши в /etc/network/interfaces 192.168.1.1, подними/опусти интерфейс, перепроверь

adriano32 ★★★ ()
Ответ на: комментарий от adriano32

resolvconf не стоит, хотя заметил что папочка такая в etc есть :)


root@SunFire:/home/stas# cat /etc/network/interfaces 

auto lo
iface lo inet loopback

# The primary network interface
allow-hotplug eth0
iface eth0 inet static
        address 192.168.1.4
        netmask 255.255.255.0
        network 192.168.1.0
        broadcast 192.168.1.255
        gateway 192.168.1.1
        # dns-* options are implemented by the resolvconf package, if installed
        dns-nameservers 192.168.1.1 8.8.8.8 8.8.4.4
root@SunFire:/home/stas# ping google.com
ping: unknown host google.com

disee ★★★ ()
Ответ на: комментарий от disee

выключи и включи интерфейс.

ip link set dev eth0 down / ip link set dev eth0 up

adriano32 ★★★ ()
Ответ на: комментарий от adriano32

с этим проблема потому что к серверу по ssh. поэтому мне легче отправить shutdown -r now :)

пробовал.. не помогло :(

disee ★★★ ()
Ответ на: комментарий от adriano32

на модеме есть dhcp сервер, если его включаешь тогда есть возможность указать dns сервер (всегда стояло 8.8.8.8 8.8.4.4) но я dhcp сервер на модеме отключил давным давно, и тысячу раз перерезагружал как модем так и все машины, и все работало. а сейчас ни с того ни ссего...

disee ★★★ ()
Ответ на: комментарий от disee

какой порядок в nsswitch.conf? что в hosts? что-нибудь кроме ЛОРа пробовал ресолвить?

adriano32 ★★★ ()
Ответ на: комментарий от disee

лень. Нельзя на pastebin выкинуть или сюда незакомментированные строки?

adriano32 ★★★ ()
Ответ на: комментарий от adriano32

root@SunFire:/home/stas# cat /etc/nsswitch.conf 
# /etc/nsswitch.conf
#
# Example configuration of GNU Name Service Switch functionality.
# If you have the `glibc-doc-reference' and `info' packages installed, try:
# `info libc "Name Service Switch"' for information about this file.

passwd:         compat
group:          compat
shadow:         compat

hosts:          files mdns4_minimal [NOTFOUND=return] dns mdns4
networks:       files

protocols:      db files
services:       db files
ethers:         db files
rpc:            db files

netgroup:       nis
hosts:          files wins          # измененная для использования wins

root@SunFire:/home/stas# cat /etc/hosts
127.0.0.1       localhost
192.168.1.4     SunFire

# The following lines are desirable for IPv6 capable hosts
::1     ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters

пробовал резолвить все что не лень... ничего не рабоатет

disee ★★★ ()
Ответ на: комментарий от adriano32

З.Ы. было бы быстрее если бы ты сам потыкал немного

disee ★★★ ()
Ответ на: комментарий от disee
hosts:          files mdns4_minimal [NOTFOUND=return] dns mdns4
hosts:          files wins          # измененная для использования wins

как дурак пялился в это и не понял, где загвоздка :)

adriano32 ★★★ ()
Ответ на: комментарий от disee

замени в /etc/nsswitch.conf

hosts: files dns
networks: files dns

и будет тебе счастье.

kam ★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.